Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Listener test failed with Exchange 2003

4 posts in Trial Discussion Last posting was on 2008-11-17 19:22:39.0Z
Guobin Huang Posted on 2008-06-10 09:37:53.0Z
From: "guobin huang" <ghuang@sybase.com>
Newsgroups: ianywhere.public.secureemail.trial
Subject: Listener test failed with Exchange 2003
Lines: 157
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <484e4b71@forums-1-dub>
Date: 10 Jun 2008 02:37:53 -0700
X-Trace: forums-1-dub 1213090673 10.22.241.152 (10 Jun 2008 02:37:53 -0700)
X-Original-Trace: 10 Jun 2008 02:37:53 -0700, vip152.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.secureemail.trial:249
Article PK: 11045

Hi,
I install a onebridge server for exchange,when I try the listener test,it is
failed but adapter test is passed.
Exchange is 2003 with sp1(6.5.7226.0),onebridge is 5.5.2006.1112.
CDO's version is 6.5.7974.0,and I already update the EMSMDB32.DLL's version
to 6.5.7830.0,
but the test still report the 8004011d error,here is the detail information:

------------ Adapter Test ---------------------

Windows Version:
Windows NT 5.0 Build 2195 Service Pack 4


Testing Windows Messaging System:
Found Windows Messaging System (MAPI Profiles)
Found Directory Registry Key
Directory C:\Documents and Settings\All Users\Documents\MAPIProfiles is
valid.


Testing CDO:
Found CDO registry entry.
Using C:\WINNT\system32\\cdo.dll for CDO functionality
CDO Version: 6.5.7974.0
The threading model for CDO is "Both"
Creation of MAPI Session object successful


Testing configuration files:
Parsing OK.

Testing Exchange adapter data directory C:\Program Files\Extended
Systems\OneBridge Sync Server\Data\Adapters\ExchangeData\:
Directory C:\Program Files\Extended Systems\OneBridge Sync
Server\Data\Adapters\ExchangeData\ is valid.


Testing Exchange adapter temp directory C:\Program Files\Extended
Systems\OneBridge Sync Server\Data\Adapters\ExchangeTemp\:
Directory C:\Program Files\Extended Systems\OneBridge Sync
Server\Data\Adapters\ExchangeTemp\ is valid.


Opening Checkpoint database:
Database successfully opened.


Opening CDO Session:
Reading Name Resolver configuration file
Authentication mode: SecuredMode

Using Exchange Resolver Account:
NT User: administrator
NT Domain: obtest
Exchange User: administrator
Exchange Server: vm-shscob

Attempting to Resolve User Name "TU001" using Mapi.
Performing authenticated connection with obtest\administrator to exchange
server [vm-shscob] with User [administrator]

Calling LogonUser for obtest\administrator
User obtest\administrator as successfully logged into WIN32
Successfully created an instance of a CDO Session Object
Generated profile string.
User Administrator (Exchange logon name administrator) successfully logged
into Exchange server vm-shscob

Resolving User TU001 to email address.
Opening mail account for TU001
Successfully resolved TU001 into a valid NT identity [OBTEST\TU001] using
TU001@OBTest.com

Calling LogonUser for OBTEST\TU001
User OBTEST\TU001 as successfully logged into WIN32

Logging User "TU001" into Exchange.
Successfully created an instance of a CDO Session Object
Generated profile string.
User User01 Test (Exchange logon name TU001@OBTest.com) successfully
logged into Exchange server VM-SHSCOB

Using CDO CdoTimeZones id = 21

Successfully opened CDO Session.


Closing CDO Session.

CDO session successfully closed.

Adapter test passed.


------------ Listener Test ---------------------

Test result:Failed.

Configuration details:
Following information can be modified in Exchange Adapter settings of the
Listener server.
Data folder=C:\Program Files\Extended Systems\OneBridge Sync
Server\Data\Adapters\ExchangeData\
Temp folder=C:\Program Files\Extended Systems\OneBridge Sync
Server\Data\Adapters\ExchangeTemp\
Primary server URL=http://localhost:8001/

Verifying databases:
ExchLReg initialization succeeded.
ExchLChkp initialization succeeded.
ExchLRecQ initialization succeeded.

Confirming registrations:
There are no registrations found for user TU001

Checking user account:
Exchange api initializaion failed for user TU001 with error code -1. Most
common cause is insufficient rights to access the user account
Some more diagnostic information follows.


Opening Checkpoint database:
Database successfully opened.


Opening CDO Session:
Reading Name Resolver configuration file
Authentication mode: SecuredMode
Exchange Server: vm-shscob
Attempting to Resolve User Name "TU001" using Mapi.
Performing authenticated connection with obtest\administrator to exchange
server [vm-shscob] with User [administrator]

Calling LogonUser for obtest\administrator
User obtest\administrator as successfully logged into WIN32
Successfully created an instance of a CDO Session Object
Generated profile string.
User Administrator (Exchange logon name administrator) successfully logged
into Exchange server vm-shscob

Resolving User TU001 to email address.
Opening mail account for TU001
Successfully resolved TU001 into a valid NT identity [OBTEST\TU001] using
TU001@OBTest.com

Logging User "TU001" into Exchange.
Successfully created an instance of a CDO Session Object
Generated profile string.
Unexpected Error. This could be an indication the Exchange server is down.
User: TU001@OBTest.com Error: 8004011d
Failed to perform logon to Exchange server with profile [VM-SHSCOB
SMTP:TU001@OBTest.com] Error: 8004011d

Anyone know how to resolve it?


Ted Hamlin Posted on 2008-06-10 20:43:12.0Z
From: "Ted Hamlin" <ted.hamlin@ianywhere.com>
Newsgroups: ianywhere.public.secureemail.trial
References: <484e4b71@forums-1-dub>
Subject: Re: Listener test failed with Exchange 2003
Lines: 170
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <484ee760$1@forums-1-dub>
Date: 10 Jun 2008 13:43:12 -0700
X-Trace: forums-1-dub 1213130592 10.22.241.152 (10 Jun 2008 13:43:12 -0700)
X-Original-Trace: 10 Jun 2008 13:43:12 -0700, vip152.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.secureemail.trial:251
Article PK: 19151

For Live Connect to function:
Exchange 2000/2003 - The account running the Adapter service must have the
View Information Store Status and Receive As privileges enabled for all
mailboxes. The account must also have Administrator privileges in the local
machine and have Act as part of operating system set in the local security
policy.

"guobin huang" <ghuang@sybase.com> wrote in message
news:484e4b71@forums-1-dub...
> Hi,
> I install a onebridge server for exchange,when I try the listener test,it
> is failed but adapter test is passed.
> Exchange is 2003 with sp1(6.5.7226.0),onebridge is 5.5.2006.1112.
> CDO's version is 6.5.7974.0,and I already update the EMSMDB32.DLL's
> version to 6.5.7830.0,
> but the test still report the 8004011d error,here is the detail
> information:
>
> ------------ Adapter Test ---------------------
>
> Windows Version:
> Windows NT 5.0 Build 2195 Service Pack 4
>
>
> Testing Windows Messaging System:
> Found Windows Messaging System (MAPI Profiles)
> Found Directory Registry Key
> Directory C:\Documents and Settings\All Users\Documents\MAPIProfiles is
> valid.
>
>
> Testing CDO:
> Found CDO registry entry.
> Using C:\WINNT\system32\\cdo.dll for CDO functionality
> CDO Version: 6.5.7974.0
> The threading model for CDO is "Both"
> Creation of MAPI Session object successful
>
>
> Testing configuration files:
> Parsing OK.
>
> Testing Exchange adapter data directory C:\Program Files\Extended
> Systems\OneBridge Sync Server\Data\Adapters\ExchangeData\:
> Directory C:\Program Files\Extended Systems\OneBridge Sync
> Server\Data\Adapters\ExchangeData\ is valid.
>
>
> Testing Exchange adapter temp directory C:\Program Files\Extended
> Systems\OneBridge Sync Server\Data\Adapters\ExchangeTemp\:
> Directory C:\Program Files\Extended Systems\OneBridge Sync
> Server\Data\Adapters\ExchangeTemp\ is valid.
>
>
> Opening Checkpoint database:
> Database successfully opened.
>
>
> Opening CDO Session:
> Reading Name Resolver configuration file
> Authentication mode: SecuredMode
>
> Using Exchange Resolver Account:
> NT User: administrator
> NT Domain: obtest
> Exchange User: administrator
> Exchange Server: vm-shscob
>
> Attempting to Resolve User Name "TU001" using Mapi.
> Performing authenticated connection with obtest\administrator to exchange
> server [vm-shscob] with User [administrator]
>
> Calling LogonUser for obtest\administrator
> User obtest\administrator as successfully logged into WIN32
> Successfully created an instance of a CDO Session Object
> Generated profile string.
> User Administrator (Exchange logon name administrator) successfully
> logged into Exchange server vm-shscob
>
> Resolving User TU001 to email address.
> Opening mail account for TU001
> Successfully resolved TU001 into a valid NT identity [OBTEST\TU001] using
> TU001@OBTest.com
>
> Calling LogonUser for OBTEST\TU001
> User OBTEST\TU001 as successfully logged into WIN32
>
> Logging User "TU001" into Exchange.
> Successfully created an instance of a CDO Session Object
> Generated profile string.
> User User01 Test (Exchange logon name TU001@OBTest.com) successfully
> logged into Exchange server VM-SHSCOB
>
> Using CDO CdoTimeZones id = 21
>
> Successfully opened CDO Session.
>
>
> Closing CDO Session.
>
> CDO session successfully closed.
>
> Adapter test passed.
>
>
> ------------ Listener Test ---------------------
>
> Test result:Failed.
>
> Configuration details:
> Following information can be modified in Exchange Adapter settings of the
> Listener server.
> Data folder=C:\Program Files\Extended Systems\OneBridge Sync
> Server\Data\Adapters\ExchangeData\
> Temp folder=C:\Program Files\Extended Systems\OneBridge Sync
> Server\Data\Adapters\ExchangeTemp\
> Primary server URL=http://localhost:8001/
>
> Verifying databases:
> ExchLReg initialization succeeded.
> ExchLChkp initialization succeeded.
> ExchLRecQ initialization succeeded.
>
> Confirming registrations:
> There are no registrations found for user TU001
>
> Checking user account:
> Exchange api initializaion failed for user TU001 with error code -1. Most
> common cause is insufficient rights to access the user account
> Some more diagnostic information follows.
>
>
> Opening Checkpoint database:
> Database successfully opened.
>
>
> Opening CDO Session:
> Reading Name Resolver configuration file
> Authentication mode: SecuredMode
> Exchange Server: vm-shscob
> Attempting to Resolve User Name "TU001" using Mapi.
> Performing authenticated connection with obtest\administrator to exchange
> server [vm-shscob] with User [administrator]
>
> Calling LogonUser for obtest\administrator
> User obtest\administrator as successfully logged into WIN32
> Successfully created an instance of a CDO Session Object
> Generated profile string.
> User Administrator (Exchange logon name administrator) successfully
> logged into Exchange server vm-shscob
>
> Resolving User TU001 to email address.
> Opening mail account for TU001
> Successfully resolved TU001 into a valid NT identity [OBTEST\TU001] using
> TU001@OBTest.com
>
> Logging User "TU001" into Exchange.
> Successfully created an instance of a CDO Session Object
> Generated profile string.
> Unexpected Error. This could be an indication the Exchange server is
> down. User: TU001@OBTest.com Error: 8004011d
> Failed to perform logon to Exchange server with profile [VM-SHSCOB
> SMTP:TU001@OBTest.com] Error: 8004011d
>
> Anyone know how to resolve it?
>


Florencia Gonzalez Posted on 2008-11-14 14:38:00.0Z
Sender: 4f4d.491d84e6.1804289383@sybase.com
From: Florencia Gonzalez
Newsgroups: ianywhere.public.secureemail.trial
Subject: Re: Listener test failed with Exchange 2003
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <491d8d48.5057.1681692777@sybase.com>
References: <484ee760$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 14 Nov 2008 06:38:00 -0800
X-Trace: forums-1-dub 1226673480 10.22.241.41 (14 Nov 2008 06:38:00 -0800)
X-Original-Trace: 14 Nov 2008 06:38:00 -0800, 10.22.241.41
Lines: 179
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.secureemail.trial:280
Article PK: 19172

Hello!
I have the same problem as Guobin. I checked the information
you send Ted and it's OK.
Can someone help me?

Thanks in advance!
Florencia.

> For Live Connect to function:
> Exchange 2000/2003 - The account running the Adapter
> service must have the View Information Store Status and
> Receive As privileges enabled for all mailboxes. The
> account must also have Administrator privileges in the
> local machine and have Act as part of operating system
> set in the local security policy.
>
>
>
> "guobin huang" <ghuang@sybase.com> wrote in message
> news:484e4b71@forums-1-dub...
> > Hi,
> > I install a onebridge server for exchange,when I try the
> > listener test,it is failed but adapter test is passed.
> > Exchange is 2003 with sp1(6.5.7226.0),onebridge is
> > 5.5.2006.1112. CDO's version is 6.5.7974.0,and I already
> > update the EMSMDB32.DLL's version to 6.5.7830.0,
> > but the test still report the 8004011d error,here is the
> > detail information:
> >
> > ------------ Adapter Test ---------------------
> >
> > Windows Version:
> > Windows NT 5.0 Build 2195 Service Pack 4
> >
> >
> > Testing Windows Messaging System:
> > Found Windows Messaging System (MAPI Profiles)
> > Found Directory Registry Key
> > Directory C:\Documents and Settings\All
> > Users\Documents\MAPIProfiles is valid.
> >
> >
> > Testing CDO:
> > Found CDO registry entry.
> > Using C:\WINNT\system32\\cdo.dll for CDO functionality
> > CDO Version: 6.5.7974.0
> > The threading model for CDO is "Both"
> > Creation of MAPI Session object successful
> >
> >
> > Testing configuration files:
> > Parsing OK.
> >
> > Testing Exchange adapter data directory C:\Program
> > Files\Extended Systems\OneBridge Sync
> > Server\Data\Adapters\ExchangeData\: Directory C:\Program
> > Files\Extended Systems\OneBridge Sync
> Server\Data\Adapters\ExchangeData\ is valid. >
> >
> > Testing Exchange adapter temp directory C:\Program
> > Files\Extended Systems\OneBridge Sync
> > Server\Data\Adapters\ExchangeTemp\: Directory C:\Program
> > Files\Extended Systems\OneBridge Sync
> Server\Data\Adapters\ExchangeTemp\ is valid. >
> >
> > Opening Checkpoint database:
> > Database successfully opened.
> >
> >
> > Opening CDO Session:
> > Reading Name Resolver configuration file
> > Authentication mode: SecuredMode
> >
> > Using Exchange Resolver Account:
> > NT User: administrator
> > NT Domain: obtest
> > Exchange User: administrator
> > Exchange Server: vm-shscob
> >
> > Attempting to Resolve User Name "TU001" using Mapi.
> > Performing authenticated connection with
> > obtest\administrator to exchange server [vm-shscob]
> with User [administrator] >
> > Calling LogonUser for obtest\administrator
> > User obtest\administrator as successfully logged into
> > WIN32 Successfully created an instance of a CDO Session
> > Object Generated profile string.
> > User Administrator (Exchange logon name administrator)
> > successfully logged into Exchange server vm-shscob
> >
> > Resolving User TU001 to email address.
> > Opening mail account for TU001
> > Successfully resolved TU001 into a valid NT identity
> > [OBTEST\TU001] using TU001@OBTest.com
> >
> > Calling LogonUser for OBTEST\TU001
> > User OBTEST\TU001 as successfully logged into WIN32
> >
> > Logging User "TU001" into Exchange.
> > Successfully created an instance of a CDO Session
> > Object Generated profile string.
> > User User01 Test (Exchange logon name TU001@OBTest.com)
> > successfully logged into Exchange server VM-SHSCOB
> >
> > Using CDO CdoTimeZones id = 21
> >
> > Successfully opened CDO Session.
> >
> >
> > Closing CDO Session.
> >
> > CDO session successfully closed.
> >
> > Adapter test passed.
> >
> >
> > ------------ Listener Test ---------------------
> >
> > Test result:Failed.
> >
> > Configuration details:
> > Following information can be modified in Exchange
> > Adapter settings of the Listener server.
> > Data folder=C:\Program Files\Extended Systems\OneBridge
> > Sync Server\Data\Adapters\ExchangeData\
> > Temp folder=C:\Program Files\Extended Systems\OneBridge
> > Sync Server\Data\Adapters\ExchangeTemp\
> > Primary server URL=http://localhost:8001/
> >
> > Verifying databases:
> > ExchLReg initialization succeeded.
> > ExchLChkp initialization succeeded.
> > ExchLRecQ initialization succeeded.
> >
> > Confirming registrations:
> > There are no registrations found for user TU001
> >
> > Checking user account:
> > Exchange api initializaion failed for user TU001 with
> > error code -1. Most common cause is insufficient rights
> > to access the user account Some more diagnostic
> information follows. >
> >
> > Opening Checkpoint database:
> > Database successfully opened.
> >
> >
> > Opening CDO Session:
> > Reading Name Resolver configuration file
> > Authentication mode: SecuredMode
> > Exchange Server: vm-shscob
> > Attempting to Resolve User Name "TU001" using Mapi.
> > Performing authenticated connection with
> > obtest\administrator to exchange server [vm-shscob]
> with User [administrator] >
> > Calling LogonUser for obtest\administrator
> > User obtest\administrator as successfully logged into
> > WIN32 Successfully created an instance of a CDO Session
> > Object Generated profile string.
> > User Administrator (Exchange logon name administrator)
> > successfully logged into Exchange server vm-shscob
> >
> > Resolving User TU001 to email address.
> > Opening mail account for TU001
> > Successfully resolved TU001 into a valid NT identity
> > [OBTEST\TU001] using TU001@OBTest.com
> >
> > Logging User "TU001" into Exchange.
> > Successfully created an instance of a CDO Session
> > Object Generated profile string.
> > Unexpected Error. This could be an indication the
> > Exchange server is down. User: TU001@OBTest.com Error:
> > 8004011d Failed to perform logon to Exchange server
> > with profile [VM-SHSCOB SMTP:TU001@OBTest.com] Error:
> 8004011d >
> > Anyone know how to resolve it?
> >
>
>