Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Integrated login failed

5 posts in General Discussion Last posting was on 2008-06-12 14:43:15.0Z
cordas Posted on 2008-06-12 10:31:54.0Z
From: cordas@sybase.com
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Integrated login failed
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4850fb1a$1@forums-1-dub>
Date: 12 Jun 2008 03:31:54 -0700
X-Trace: forums-1-dub 1213266714 10.22.241.152 (12 Jun 2008 03:31:54 -0700)
X-Original-Trace: 12 Jun 2008 03:31:54 -0700, vip152.sybase.com
Lines: 14
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6895
Article PK: 5123

Hi all,

I have an ASA ( 9.0.2.3661) in Windows XP Professional. I am trying to
use Integrated login with ODBC and when i do TEST CONNECTION in ODBC
Administratior i get :

Connection Failed: Integrated Login failed

I think i am missing something .. Any ideas???

Thanks in advance,

Cristina


David Fishburn Posted on 2008-06-12 12:05:12.0Z
Newsgroups: ianywhere.public.general
Subject: Re: Integrated login failed
From: David Fishburn <fishburn_spam_off@ianywhere.com>
References: <4850fb1a$1@forums-1-dub>
Organization: iAnywhere Solutions
Message-ID: <Xns9ABB524392981fishburnsybasecom@192.138.151.106>
User-Agent: Xnews/2005.10.18
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 12 Jun 2008 05:05:12 -0700
X-Trace: forums-1-dub 1213272312 10.22.241.152 (12 Jun 2008 05:05:12 -0700)
X-Original-Trace: 12 Jun 2008 05:05:12 -0700, vip152.sybase.com
Lines: 49
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6898
Article PK: 5128

cordas@sybase.com wrote in news:4850fb1a$1@forums-1-dub
of ianywhere.public.general:

c> I have an ASA ( 9.0.2.3661) in Windows XP Professional. I am trying
to
c> use Integrated login with ODBC and when i do TEST CONNECTION in ODBC
c> Administratior i get :
c>
c> Connection Failed: Integrated Login failed

Did you read through this section of the Help?

ASA Database Administration Guide
Connecting to a Database
Using integrated logins

It and the following pages take you through the process of setting
this up. Especially:

ASA Database Administration Guide
Connecting to a Database
Using integrated logins
Setting up integrated logins


If things are still failing, show us the commands you used to
"turn on" integrated logins.

--
David Fishburn
Certified ASA Developer Version 8
iAnywhere Solutions - Sybase
Professional Services
Please only post to the newsgroup
Please ALWAYS include version and MORE importantly BUILD number with
EACH post (dbeng10 -v).

EBFs and Maintenance Releases
http://downloads.sybase.com/

Developer Community / Whitepapers
http://www.ianywhere.com/developer

Case-Express - to report bugs
http://case-express.sybase.com

CodeXchange - Free samples
http://ianywhere.codexchange.sybase.com/servlets/ProjectDocumentList


cordas Posted on 2008-06-12 12:18:34.0Z
Message-ID: <48511419.6000508@sybase.com>
From: cordas@sybase.com
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
To: David Fishburn <fishburn_spam_off@ianywhere.com>
Subject: Re: Integrated login failed
References: <4850fb1a$1@forums-1-dub> <Xns9ABB524392981fishburnsybasecom@192.138.151.106>
In-Reply-To: <Xns9ABB524392981fishburnsybasecom@192.138.151.106>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 12 Jun 2008 05:18:34 -0700
X-Trace: forums-1-dub 1213273114 10.22.241.152 (12 Jun 2008 05:18:34 -0700)
X-Original-Trace: 12 Jun 2008 05:18:34 -0700, vip152.sybase.com
Lines: 58
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6899
Article PK: 5129

Hi David,

thanks for your answer. I followed the ASA Database Administration Guide
to configure de Integrated Login.

I upgrade my 9.0.2 because of BUG 427121.

Then i read about documentation changes about the GRANT INTEGRATED LOGIN
TO "domain\user" AS USE user_name

so i exec

GRANT INTEGRATED LOGIN TO "sybase\jmartin2" AS USER DBA

i also have Itegrated login for jmartin2

so when i test ODBC connection with login jmartin2 and password
everything works ok. But when i test with integrated login i see the
error message i sent before.

A collegue has told me something about a change in "Local Security
Policy" in the machine , but i dont find anything in sybase
documentation about it.

Thanks a lot

Cristina

David Fishburn wrote:
> cordas@sybase.com wrote in news:4850fb1a$1@forums-1-dub
> of ianywhere.public.general:
>
> c> I have an ASA ( 9.0.2.3661) in Windows XP Professional. I am trying
> to
> c> use Integrated login with ODBC and when i do TEST CONNECTION in ODBC
> c> Administratior i get :
> c>
> c> Connection Failed: Integrated Login failed
>
> Did you read through this section of the Help?
>
> ASA Database Administration Guide
> Connecting to a Database
> Using integrated logins
>
> It and the following pages take you through the process of setting
> this up. Especially:
>
> ASA Database Administration Guide
> Connecting to a Database
> Using integrated logins
> Setting up integrated logins
>
>
> If things are still failing, show us the commands you used to
> "turn on" integrated logins.
>


David Fishburn Posted on 2008-06-12 13:07:37.0Z
Newsgroups: ianywhere.public.general
Subject: Re: Integrated login failed
From: David Fishburn <fishburn_spam_off@ianywhere.com>
References: <4850fb1a$1@forums-1-dub> <Xns9ABB524392981fishburnsybasecom@192.138.151.106> <48511419.6000508@sybase.com>
Organization: iAnywhere Solutions
Message-ID: <Xns9ABB5CD8E8251fishburnsybasecom@10.22.241.106>
User-Agent: Xnews/2005.10.18
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 12 Jun 2008 06:07:37 -0700
X-Trace: forums-1-dub 1213276057 10.22.241.152 (12 Jun 2008 06:07:37 -0700)
X-Original-Trace: 12 Jun 2008 06:07:37 -0700, vip152.sybase.com
Lines: 55
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6900
Article PK: 5125

cordas@sybase.com wrote in news:48511419.6000508@sybase.com
of ianywhere.public.general:

c> Hi David,
c>
c> thanks for your answer. I followed the ASA Database Administration
Guide
c> to configure de Integrated Login.
...
c> GRANT INTEGRATED LOGIN TO "sybase\jmartin2" AS USER DBA

It doesn't sound like you enabled the logins yet:

ASA Database Administration Guide
Connecting to a Database
Using integrated logins
Setting up integrated logins

From the above page, step 1 is to set the LOGIN_MODE option:

To use an integrated login:

Enable the integrated login feature in a database by setting the value
of the LOGIN_MODE database option to either Mixed or Integrated (the
option is case insensitive), in place of the default value of
Standard. This step requires DBA authority.

So you would have done something like this:
SET OPTION PUBLIC.LOGIN_MODE = 'Mixed';


Had you done that step?


--
David Fishburn
Certified ASA Developer Version 8
iAnywhere Solutions - Sybase
Professional Services
Please only post to the newsgroup
Please ALWAYS include version and MORE importantly BUILD number with
EACH post (dbeng10 -v).

EBFs and Maintenance Releases
http://downloads.sybase.com/

Developer Community / Whitepapers
http://www.ianywhere.com/developer

Case-Express - to report bugs
http://case-express.sybase.com

CodeXchange - Free samples
http://ianywhere.codexchange.sybase.com/servlets/ProjectDocumentList


cordas Posted on 2008-06-12 14:43:15.0Z
Message-ID: <48513602.4080709@sybase.com>
From: cordas@sybase.com
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
To: David Fishburn <fishburn_spam_off@ianywhere.com>
Subject: Re: Integrated login failed
References: <4850fb1a$1@forums-1-dub> <Xns9ABB524392981fishburnsybasecom@192.138.151.106> <48511419.6000508@sybase.com> <Xns9ABB5CD8E8251fishburnsybasecom@10.22.241.106>
In-Reply-To: <Xns9ABB5CD8E8251fishburnsybasecom@10.22.241.106>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 12 Jun 2008 07:43:15 -0700
X-Trace: forums-1-dub 1213281795 10.22.241.152 (12 Jun 2008 07:43:15 -0700)
X-Original-Trace: 12 Jun 2008 07:43:15 -0700, vip152.sybase.com
Lines: 39
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:6901
Article PK: 5126

Hi,

yes, i have test with both "Mixed" and "Integrated"

David Fishburn wrote:
> cordas@sybase.com wrote in news:48511419.6000508@sybase.com
> of ianywhere.public.general:
>
> c> Hi David,
> c>
> c> thanks for your answer. I followed the ASA Database Administration
> Guide
> c> to configure de Integrated Login.
> ...
> c> GRANT INTEGRATED LOGIN TO "sybase\jmartin2" AS USER DBA
>
> It doesn't sound like you enabled the logins yet:
>
> ASA Database Administration Guide
> Connecting to a Database
> Using integrated logins
> Setting up integrated logins
>
> From the above page, step 1 is to set the LOGIN_MODE option:
>
> To use an integrated login:
>
> Enable the integrated login feature in a database by setting the value
> of the LOGIN_MODE database option to either Mixed or Integrated (the
> option is case insensitive), in place of the default value of
> Standard. This step requires DBA authority.
>
> So you would have done something like this:
> SET OPTION PUBLIC.LOGIN_MODE = 'Mixed';
>
>
> Had you done that step?
>
>