Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

TestMessage error on WM5

2 posts in QAnywhere Last posting was on 2008-07-18 15:31:49.0Z
Harry Chen Posted on 2008-07-09 18:07:36.0Z
Sender: 365d.487254c1.1804289383@sybase.com
From: Harry Chen
Newsgroups: ianywhere.public.sqlanywhere.qanywhere
Subject: TestMessage error on WM5
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4874fe68.1984.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 9 Jul 2008 11:07:36 -0700
X-Trace: forums-1-dub 1215626856 10.22.241.41 (9 Jul 2008 11:07:36 -0700)
X-Original-Trace: 9 Jul 2008 11:07:36 -0700, 10.22.241.41
Lines: 18
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.sqlanywhere.qanywhere:268
Article PK: 18785

Hi,
We are evaluating QAnywhere for WM5. I built TestMessage
app and deployed it on a WM5 device using VisualStudio 2005.
When I ran the app, I got the following error:
An ynexpected error has occurred in TestMessage.exe....
Whn I clicked Details button, I got the following msg:
TestMessage.exe TypeLoadException.

When I ran it using debugger. I got a different error:
This applcation (TestMessage.exe) requires a newer version
of the Microsfot .NET Compact Framework than the version
installed on this device.

I have Compact Framework 2sp1 installed on the device. I
don't think it requires 3.5 to run. What is missing here?
Thanks.

Harry


Andy Quick Posted on 2008-07-18 15:31:49.0Z
From: "Andy Quick" <andy.quick@sybase.com>
Newsgroups: ianywhere.public.sqlanywhere.qanywhere
References: <4874fe68.1984.1681692777@sybase.com>
Subject: Re: TestMessage error on WM5
Lines: 30
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4880b765@forums-1-dub>
Date: 18 Jul 2008 08:31:49 -0700
X-Trace: forums-1-dub 1216395109 10.22.241.152 (18 Jul 2008 08:31:49 -0700)
X-Original-Trace: 18 Jul 2008 08:31:49 -0700, vip152.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.sqlanywhere.qanywhere:271
Article PK: 18786

Which version of SQL Anywhere are you using, 10.0.1 or 11.0.0?

The TestMessage sample in 10.0.1 can be built with Compact Framework 1.0 or
2.0 QAnywhere assemblies, but in 11.0.0 we only ship QAnywhere assemblies
for CF 2.0.

Andy Quick
iAnywhere Solutions Engineering

<Harry Chen> wrote in message news:4874fe68.1984.1681692777@sybase.com...
> Hi,
> We are evaluating QAnywhere for WM5. I built TestMessage
> app and deployed it on a WM5 device using VisualStudio 2005.
> When I ran the app, I got the following error:
> An ynexpected error has occurred in TestMessage.exe....
> Whn I clicked Details button, I got the following msg:
> TestMessage.exe TypeLoadException.
>
> When I ran it using debugger. I got a different error:
> This applcation (TestMessage.exe) requires a newer version
> of the Microsfot .NET Compact Framework than the version
> installed on this device.
>
> I have Compact Framework 2sp1 installed on the device. I
> don't think it requires 3.5 to run. What is missing here?
> Thanks.
>
> Harry