Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

DW Select Problem

6 posts in DataWindow Last posting was on 2008-08-25 18:01:02.0Z
Kevin Arnold Posted on 2008-08-25 13:44:23.0Z
Sender: 492d.48b2b6de.1804289383@sybase.com
From: Kevin Arnold
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: DW Select Problem
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <48b2b737.4937.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 25 Aug 2008 06:44:23 -0700
X-Trace: forums-1-dub 1219671863 10.22.241.41 (25 Aug 2008 06:44:23 -0700)
X-Original-Trace: 25 Aug 2008 06:44:23 -0700, 10.22.241.41
Lines: 12
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87621
Article PK: 416877

I am testing the upgrade of my Pb 9 app to Pb 11.5
connecting to Sql Anywhere 11. The problem I am having is
any datawindow that has a sql select with double quotes
fails on the retrieve when running the app. These
datawindows work fine in Pb9, but fail in Pb11.5. I have
checked the pbodb files and they are identical for my
database settings. When I remove the quotes from the select,
the dw works fine. Anyone have any ideas? I do not want to
remove quotes from all of my datawindows since there are
hundreds of them.

Thanks.


Chris Pollach Posted on 2008-08-25 14:38:54.0Z
From: "Chris Pollach" <cpollach@travel-net.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <48b2b737.4937.1681692777@sybase.com>
Subject: Re: DW Select Problem
Lines: 60
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <48b2c3fe$1@forums-1-dub>
Date: 25 Aug 2008 07:38:54 -0700
X-Trace: forums-1-dub 1219675134 10.22.241.152 (25 Aug 2008 07:38:54 -0700)
X-Original-Trace: 25 Aug 2008 07:38:54 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87622
Article PK: 416878

Hi Kevin;

Since PB 11.5 is still in Beta, I would suggest posting this to the Beta
forum for proper resolution.

Note: The PB 11.5 beta that most people have is an old build. I have a
newer PB 11.5 working with SA11 with no problems and I use the standard
default quoted identifiers. Here is an example from one of my test
applications with SA11 (I am still using the SA11 beta - Panorama) ...

SELECT "groupo"."contacts"."id",
"groupo"."contacts"."surname",
"groupo"."contacts"."givenname",
"groupo"."contacts"."title",
"groupo"."contacts"."street",
"groupo"."contacts"."city",
"groupo"."contacts"."state",
"groupo"."contacts"."country",
"groupo"."contacts"."postalcode",
"groupo"."contacts"."phone",
"groupo"."contacts"."fax",
"groupo"."contacts"."customerid"
FROM "groupo"."contacts"
WHERE "groupo"."contacts"."id" = 1

------------------------------------- Connection
Parameters -----------------------------

// Profile SQL Anywhere 11 Demo
SQLCA.DBMS = "ODBC"
SQLCA.AutoCommit = False
SQLCA.DBParm = "ConnectString='DSN=SQL Anywhere 11
Demo;UID=dba;PWD=sql',Async=1,DBGetTime=5,PacketSize=1024,ConnectOption='SQL_DRIVER_CONNECT,SQL_DRIVER_NOPROMPT'"


HTH


--
Regards ... Chris
ISUG - NA RUG Director
http://chrispollach.pbdjmagazine.com

<Kevin Arnold> wrote in message news:48b2b737.4937.1681692777@sybase.com...
>I am testing the upgrade of my Pb 9 app to Pb 11.5
> connecting to Sql Anywhere 11. The problem I am having is
> any datawindow that has a sql select with double quotes
> fails on the retrieve when running the app. These
> datawindows work fine in Pb9, but fail in Pb11.5. I have
> checked the pbodb files and they are identical for my
> database settings. When I remove the quotes from the select,
> the dw works fine. Anyone have any ideas? I do not want to
> remove quotes from all of my datawindows since there are
> hundreds of them.
>
> Thanks.


Kevin Arnold Posted on 2008-08-25 16:25:23.0Z
Sender: 492d.48b2b6de.1804289383@sybase.com
From: Kevin Arnold
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: DW Select Problem
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <48b2dcf3.4ffc.1681692777@sybase.com>
References: <48b2c3fe$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 25 Aug 2008 09:25:23 -0700
X-Trace: forums-1-dub 1219681523 10.22.241.41 (25 Aug 2008 09:25:23 -0700)
X-Original-Trace: 25 Aug 2008 09:25:23 -0700, 10.22.241.41
Lines: 66
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87626
Article PK: 416880

Thanks Chris. I just installed PB11 and migrated the PBL's
from 9 to 11 and I am still having the problem with the the
upgrade in PB11.

> Hi Kevin;
>
> Since PB 11.5 is still in Beta, I would suggest
> posting this to the Beta forum for proper resolution.
>
> Note: The PB 11.5 beta that most people have is an old
> build. I have a newer PB 11.5 working with SA11 with no
> problems and I use the standard default quoted
> identifiers. Here is an example from one of my test
> applications with SA11 (I am still using the SA11 beta -
> Panorama) ...
>
> SELECT "groupo"."contacts"."id",
> "groupo"."contacts"."surname",
> "groupo"."contacts"."givenname",
> "groupo"."contacts"."title",
> "groupo"."contacts"."street",
> "groupo"."contacts"."city",
> "groupo"."contacts"."state",
> "groupo"."contacts"."country",
> "groupo"."contacts"."postalcode",
> "groupo"."contacts"."phone",
> "groupo"."contacts"."fax",
> "groupo"."contacts"."customerid"
> FROM "groupo"."contacts"
> WHERE "groupo"."contacts"."id" = 1
>
> ------------------------------------- Connection
> Parameters -----------------------------
>
> // Profile SQL Anywhere 11 Demo
> SQLCA.DBMS = "ODBC"
> SQLCA.AutoCommit = False
> SQLCA.DBParm = "ConnectString='DSN=SQL Anywhere 11
> Demo;UID=dba;PWD=sql',Async=1,DBGetTime=5,PacketSize=1024
> ,ConnectOption='SQL_DRIVER_CONNECT,SQL_DRIVER_NOPROMPT'"
>
>
> HTH
>
>
> --
> Regards ... Chris
> ISUG - NA RUG Director
> http://chrispollach.pbdjmagazine.com
>
>
> <Kevin Arnold> wrote in message
> news:48b2b737.4937.1681692777@sybase.com... >I am testing
> > the upgrade of my Pb 9 app to Pb 11.5 connecting to Sql
> > Anywhere 11. The problem I am having is any datawindow
> > that has a sql select with double quotes fails on the
> > retrieve when running the app. These datawindows work
> > fine in Pb9, but fail in Pb11.5. I have checked the
> > pbodb files and they are identical for my database
> > settings. When I remove the quotes from the select, the
> > dw works fine. Anyone have any ideas? I do not want to
> > remove quotes from all of my datawindows since there are
> hundreds of them. >
> > Thanks.
>
>


Chris Pollach Posted on 2008-08-25 16:38:58.0Z
From: "Chris Pollach" <cpollach@travel-net.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <48b2c3fe$1@forums-1-dub> <48b2dcf3.4ffc.1681692777@sybase.com>
Subject: Re: DW Select Problem
Lines: 75
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <48b2e022$1@forums-1-dub>
Date: 25 Aug 2008 09:38:58 -0700
X-Trace: forums-1-dub 1219682338 10.22.241.152 (25 Aug 2008 09:38:58 -0700)
X-Original-Trace: 25 Aug 2008 09:38:58 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87627
Article PK: 416883

It could be that SA11 is not properly supported until PB 11.5 then (IMHO).
Have you tried your database with SA10?

<Kevin Arnold> wrote in message news:48b2dcf3.4ffc.1681692777@sybase.com...
> Thanks Chris. I just installed PB11 and migrated the PBL's
> from 9 to 11 and I am still having the problem with the the
> upgrade in PB11.
>
>> Hi Kevin;
>>
>> Since PB 11.5 is still in Beta, I would suggest
>> posting this to the Beta forum for proper resolution.
>>
>> Note: The PB 11.5 beta that most people have is an old
>> build. I have a newer PB 11.5 working with SA11 with no
>> problems and I use the standard default quoted
>> identifiers. Here is an example from one of my test
>> applications with SA11 (I am still using the SA11 beta -
>> Panorama) ...
>>
>> SELECT "groupo"."contacts"."id",
>> "groupo"."contacts"."surname",
>> "groupo"."contacts"."givenname",
>> "groupo"."contacts"."title",
>> "groupo"."contacts"."street",
>> "groupo"."contacts"."city",
>> "groupo"."contacts"."state",
>> "groupo"."contacts"."country",
>> "groupo"."contacts"."postalcode",
>> "groupo"."contacts"."phone",
>> "groupo"."contacts"."fax",
>> "groupo"."contacts"."customerid"
>> FROM "groupo"."contacts"
>> WHERE "groupo"."contacts"."id" = 1
>>
>> ------------------------------------- Connection
>> Parameters -----------------------------
>>
>> // Profile SQL Anywhere 11 Demo
>> SQLCA.DBMS = "ODBC"
>> SQLCA.AutoCommit = False
>> SQLCA.DBParm = "ConnectString='DSN=SQL Anywhere 11
>> Demo;UID=dba;PWD=sql',Async=1,DBGetTime=5,PacketSize=1024
>> ,ConnectOption='SQL_DRIVER_CONNECT,SQL_DRIVER_NOPROMPT'"
>>
>>
>> HTH
>>
>>
>> --
>> Regards ... Chris
>> ISUG - NA RUG Director
>> http://chrispollach.pbdjmagazine.com
>>
>>
>> <Kevin Arnold> wrote in message
>> news:48b2b737.4937.1681692777@sybase.com... >I am testing
>> > the upgrade of my Pb 9 app to Pb 11.5 connecting to Sql
>> > Anywhere 11. The problem I am having is any datawindow
>> > that has a sql select with double quotes fails on the
>> > retrieve when running the app. These datawindows work
>> > fine in Pb9, but fail in Pb11.5. I have checked the
>> > pbodb files and they are identical for my database
>> > settings. When I remove the quotes from the select, the
>> > dw works fine. Anyone have any ideas? I do not want to
>> > remove quotes from all of my datawindows since there are
>> hundreds of them. >
>> > Thanks.
>>
>>


Kevin Arnold Posted on 2008-08-25 17:04:52.0Z
Sender: 525f.48b2e5e6.1804289383@sybase.com
From: Kevin Arnold
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: DW Select Problem
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <48b2e634.526e.1681692777@sybase.com>
References: <48b2e022$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 25 Aug 2008 10:04:52 -0700
X-Trace: forums-1-dub 1219683892 10.22.241.41 (25 Aug 2008 10:04:52 -0700)
X-Original-Trace: 25 Aug 2008 10:04:52 -0700, 10.22.241.41
Lines: 76
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87628
Article PK: 416884

My most recent test was with PB 11 and SA 10. Same problem.

> It could be that SA11 is not properly supported until PB
> 11.5 then (IMHO). Have you tried your database with SA10?
>
>
>
> <Kevin Arnold> wrote in message
> > news:48b2dcf3.4ffc.1681692777@sybase.com... Thanks
> > Chris. I just installed PB11 and migrated the PBL's from
> > 9 to 11 and I am still having the problem with the the
> upgrade in PB11. >
> >> Hi Kevin;
> >>
> >> Since PB 11.5 is still in Beta, I would suggest
> >> posting this to the Beta forum for proper resolution.
> >>
> >> Note: The PB 11.5 beta that most people have is an
> old >> build. I have a newer PB 11.5 working with SA11
> with no >> problems and I use the standard default
> quoted >> identifiers. Here is an example from one of my
> test >> applications with SA11 (I am still using the SA11
> beta - >> Panorama) ...
> >>
> >> SELECT "groupo"."contacts"."id",
> >> "groupo"."contacts"."surname",
> >> "groupo"."contacts"."givenname",
> >> "groupo"."contacts"."title",
> >> "groupo"."contacts"."street",
> >> "groupo"."contacts"."city",
> >> "groupo"."contacts"."state",
> >> "groupo"."contacts"."country",
> >> "groupo"."contacts"."postalcode",
> >> "groupo"."contacts"."phone",
> >> "groupo"."contacts"."fax",
> >> "groupo"."contacts"."customerid"
> >> FROM "groupo"."contacts"
> >> WHERE "groupo"."contacts"."id" = 1
> >>
> >> ------------------------------------- Connection
> >> Parameters -----------------------------
> >>
> >> // Profile SQL Anywhere 11 Demo
> >> SQLCA.DBMS = "ODBC"
> >> SQLCA.AutoCommit = False
> >> SQLCA.DBParm = "ConnectString='DSN=SQL Anywhere 11
> >> Demo;UID=dba;PWD=sql',Async=1,DBGetTime=5
> ,PacketSize=1024 >> ,ConnectOption='SQL_DRIVER_CONNECT
> ,SQL_DRIVER_NOPROMPT'" >>
> >>
> >> HTH
> >>
> >>
> >> --
> >> Regards ... Chris
> >> ISUG - NA RUG Director
> >> http://chrispollach.pbdjmagazine.com
> >>
> >>
> >> <Kevin Arnold> wrote in message
> >> news:48b2b737.4937.1681692777@sybase.com... >I am
> testing >> > the upgrade of my Pb 9 app to Pb 11.5
> connecting to Sql >> > Anywhere 11. The problem I am
> having is any datawindow >> > that has a sql select with
> double quotes fails on the >> > retrieve when running the
> app. These datawindows work >> > fine in Pb9, but fail in
> Pb11.5. I have checked the >> > pbodb files and they are
> identical for my database >> > settings. When I remove the
> quotes from the select, the >> > dw works fine. Anyone
> have any ideas? I do not want to >> > remove quotes from
> all of my datawindows since there are >> hundreds of them.
> > >> > Thanks.
> >>
> >>
>
>


Chris Pollach Posted on 2008-08-25 18:01:02.0Z
From: "Chris Pollach" <cpollach@travel-net.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <48b2e022$1@forums-1-dub> <48b2e634.526e.1681692777@sybase.com>
Subject: Re: DW Select Problem
Lines: 83
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <48b2f35e$1@forums-1-dub>
Date: 25 Aug 2008 11:01:02 -0700
X-Trace: forums-1-dub 1219687262 10.22.241.152 (25 Aug 2008 11:01:02 -0700)
X-Original-Trace: 25 Aug 2008 11:01:02 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87629
Article PK: 416885

Wow ... I have never seen that before! :-(

<Kevin Arnold> wrote in message news:48b2e634.526e.1681692777@sybase.com...
> My most recent test was with PB 11 and SA 10. Same problem.
>
>> It could be that SA11 is not properly supported until PB
>> 11.5 then (IMHO). Have you tried your database with SA10?
>>
>>
>>
>> <Kevin Arnold> wrote in message
>> > news:48b2dcf3.4ffc.1681692777@sybase.com... Thanks
>> > Chris. I just installed PB11 and migrated the PBL's from
>> > 9 to 11 and I am still having the problem with the the
>> upgrade in PB11. >
>> >> Hi Kevin;
>> >>
>> >> Since PB 11.5 is still in Beta, I would suggest
>> >> posting this to the Beta forum for proper resolution.
>> >>
>> >> Note: The PB 11.5 beta that most people have is an
>> old >> build. I have a newer PB 11.5 working with SA11
>> with no >> problems and I use the standard default
>> quoted >> identifiers. Here is an example from one of my
>> test >> applications with SA11 (I am still using the SA11
>> beta - >> Panorama) ...
>> >>
>> >> SELECT "groupo"."contacts"."id",
>> >> "groupo"."contacts"."surname",
>> >> "groupo"."contacts"."givenname",
>> >> "groupo"."contacts"."title",
>> >> "groupo"."contacts"."street",
>> >> "groupo"."contacts"."city",
>> >> "groupo"."contacts"."state",
>> >> "groupo"."contacts"."country",
>> >> "groupo"."contacts"."postalcode",
>> >> "groupo"."contacts"."phone",
>> >> "groupo"."contacts"."fax",
>> >> "groupo"."contacts"."customerid"
>> >> FROM "groupo"."contacts"
>> >> WHERE "groupo"."contacts"."id" = 1
>> >>
>> >> ------------------------------------- Connection
>> >> Parameters -----------------------------
>> >>
>> >> // Profile SQL Anywhere 11 Demo
>> >> SQLCA.DBMS = "ODBC"
>> >> SQLCA.AutoCommit = False
>> >> SQLCA.DBParm = "ConnectString='DSN=SQL Anywhere 11
>> >> Demo;UID=dba;PWD=sql',Async=1,DBGetTime=5
>> ,PacketSize=1024 >> ,ConnectOption='SQL_DRIVER_CONNECT
>> ,SQL_DRIVER_NOPROMPT'" >>
>> >>
>> >> HTH
>> >>
>> >>
>> >> --
>> >> Regards ... Chris
>> >> ISUG - NA RUG Director
>> >> http://chrispollach.pbdjmagazine.com
>> >>
>> >>
>> >> <Kevin Arnold> wrote in message
>> >> news:48b2b737.4937.1681692777@sybase.com... >I am
>> testing >> > the upgrade of my Pb 9 app to Pb 11.5
>> connecting to Sql >> > Anywhere 11. The problem I am
>> having is any datawindow >> > that has a sql select with
>> double quotes fails on the >> > retrieve when running the
>> app. These datawindows work >> > fine in Pb9, but fail in
>> Pb11.5. I have checked the >> > pbodb files and they are
>> identical for my database >> > settings. When I remove the
>> quotes from the select, the >> > dw works fine. Anyone
>> have any ideas? I do not want to >> > remove quotes from
>> all of my datawindows since there are >> hundreds of them.
>> > >> > Thanks.
>> >>
>> >>
>>
>>