Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Cannot Start Sybase Central ASA 10.0.1

3 posts in General Discussion Last posting was on 2008-09-19 19:50:22.0Z
Lebrocoli Posted on 2008-09-19 00:17:33.0Z
Sender: 4cf.48d2ed8f.1804289383@sybase.com
From: Lebrocoli
Newsgroups: ianywhere.public.general
Subject: Cannot Start Sybase Central ASA 10.0.1
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <48d2ef9d.513.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 18 Sep 2008 17:17:33 -0700
X-Trace: forums-1-dub 1221783453 10.22.241.41 (18 Sep 2008 17:17:33 -0700)
X-Original-Trace: 18 Sep 2008 17:17:33 -0700, 10.22.241.41
Lines: 15
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:7091
Article PK: 5312

Hi all,

The Server is running Windows Server 2003 64 Bits.
The Main ASA version is 10.0.1
The EBF installed is 3750.

Each time I double-click on the Sybase Central icon to
start-it up, it crashes with a message like this one:

"The mobilink plug-in could not start properly". When I look
inside the error, I see a java null pointer.

I pretty sure that before the EBF, it was fine.

Please let me know how to fix this issue! Thanks!


Reg Domaratzki (Sybase iAnywhere) Posted on 2008-09-19 13:59:00.0Z
Newsgroups: ianywhere.public.general
Subject: Re: Cannot Start Sybase Central ASA 10.0.1
From: "Reg Domaratzki (Sybase iAnywhere)" <FirstName.LastName@ianywhere.com>
References: <48d2ef9d.513.1681692777@sybase.com>
Organization: Sybase iAnywhere
Message-ID: <Xns9B1E658EA7BE5RegDSybiAnywhere@10.22.241.106>
User-Agent: Xnews/5.04.25
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 19 Sep 2008 06:59:00 -0700
X-Trace: forums-1-dub 1221832740 10.22.241.152 (19 Sep 2008 06:59:00 -0700)
X-Original-Trace: 19 Sep 2008 06:59:00 -0700, vip152.sybase.com
Lines: 74
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:7092
Article PK: 5313

For future posts about SQL Anywhere or their administration
tools, the proper newsgroup would be
sybase.public.sqlanywhere.general.

I'm not sure why installing the EBF has caused problems, but
let's try and fix it now that you're in this state.

Sybase Central ( in v10.0.1 ) uses a file called .scRepository
to locate and load the plugins that are installed.

I think it will be located at either

C:\Documents and Settings\All Users\Sybase Central 5.0.0
or
C:\Documents and Settings\[userThatInstalledSA]\Sybase Central 5.0.0

If it is not at either of those locations, please let us know where
you found the file.

Open the file, and locate the section that looks similar to :

Providers/mobilink1000/Version=
Providers/mobilink1000/UseClassloader=true
Providers/mobilink1000/ClassloaderId=SA1000
Providers/mobilink1000/Classpath=c:\\sa10\\java\\mlplugin.jar
Providers/mobilink1000/Name=MobiLink 10
Providers/mobilink1000/AdditionalClasspath=[lots of jar files]
Providers/mobilink1000/Provider=com.sybase.mobilink.plugin.MLPlugin
Providers/mobilink1000/ProviderId=mobilink1000
Providers/mobilink1000/InitialLoadOrder=1

Verify that the paths in "Classpath" and "AdditionalClasspath" all
point to jar files that exist. If they do, then please post the
following information :

1) The location of the .scRepository file
2) The contents of the .scRepository file
3) The contents of the sybasecentral.bat file that is generated when
you run "scjview -batch" from a DOS prompt.
4) The contents of the stack trace when you click on "Show Details"
when Sybase Central fails to load the ML Plugin.

--
Reg Domaratzki, Sybase iAnywhere Solutions
Please reply only to the newsgroup

iAnywhere Developer Community : http://www.ianywhere.com/developer
iAnywhere Docs : http://www.ianywhere.com/developer/product_manuals
ASA Patches and EBFs : http://downloads.sybase.com/swd/base.do
-> Choose SQL Anywhere Studio
-> Set filter to "Display ALL platforms IN ALL MONTHS"

Lebrocoli wrote in news:48d2ef9d.513.1681692777@sybase.com:

> Hi all,
>
> The Server is running Windows Server 2003 64 Bits.
> The Main ASA version is 10.0.1
> The EBF installed is 3750.
>
> Each time I double-click on the Sybase Central icon to
> start-it up, it crashes with a message like this one:
>
> "The mobilink plug-in could not start properly". When I look
> inside the error, I see a java null pointer.
>
> I pretty sure that before the EBF, it was fine.
>
> Please let me know how to fix this issue! Thanks!
>


Lebrocoli Posted on 2008-09-19 19:50:22.0Z
Sender: 1721.48d3ad9c.1804289383@sybase.com
From: lebrocoli
Newsgroups: ianywhere.public.general
Subject: Re: Cannot Start Sybase Central ASA 10.0.1
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <48d4027e.20cc.1681692777@sybase.com>
References: <48d2ef9d.513.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 19 Sep 2008 12:50:22 -0700
X-Trace: forums-1-dub 1221853822 10.22.241.41 (19 Sep 2008 12:50:22 -0700)
X-Original-Trace: 19 Sep 2008 12:50:22 -0700, 10.22.241.41
Lines: 27
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:7093
Article PK: 5314

Excellent. I had a look in the original scRepository file
and all the paths have the C:\\Program Files (x86)\\ folder.

After the EBF is installed, all the paths in the
scRepository file point to C:\\Program Files\\SQL Anywhere
10\\, without the (x86)!

The funny thing is that Yesterday, I install the 32bits
version and the EBF and got the same problem.

The conclusion is that, when you install Sybase 10.0.1, 32
Bits OR 64 Bits, the install is done in the (x86) folder. So
when you install the EBF, it changes the paths file to the
not x86 and nothing works anymore.

I just look in the server right now and I can confirm that
all the Sybase got install into the X86 folder, even if the
64 bits install was selected.

All that aside, our application that uses sybase is a 32
bits application and I doubt that our application will use
64 bits in the near future.

So should I install sybase 64 bits to talk to our 32 bits
application or should I install sybase 32 bits?

Thanks a lot for all your help.