Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Rich Text

4 posts in DataWindow Last posting was on 2009-02-24 21:34:54.0Z
Randy Posted on 2008-10-09 19:47:43.0Z
From: Randy <CGreenwellAtsparusaDotcom>
Reply-To: CGreenwellAtsparusaDotcom
Organization: SPAR Associates, Inc
User-Agent: Thunderbird 2.0.0.17 (Windows/20080914)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Rich Text
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <48ee5fdf$1@forums-1-dub>
Date: 9 Oct 2008 12:47:43 -0700
X-Trace: forums-1-dub 1223581663 10.22.241.152 (9 Oct 2008 12:47:43 -0700)
X-Original-Trace: 9 Oct 2008 12:47:43 -0700, vip152.sybase.com
Lines: 19
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87964
Article PK: 417220

Perhaps I am having a brain melt down here, but I have not been able to
figure this one out. Perhaps someone can point me in the right direction.

PB11.5

1. I have a column on a DW which is named Part_Description.
2. I set the Edit Style to Rich Text.
3. I retrieve data and the column is blank.
4. The column is defined on the DB as a long Varchar and has text in it,
but is not formatted as Rich Text. If I put Rich Text into the column on
the database, it displays OK.

5. So,I guess there is not an automatic conversion here, Should there be?

Now, the hard part. How can I update this column on the DB so that it
is formated as Rich Text and this will work?

TIA
Randy


Calvin Allen Posted on 2009-02-24 17:43:46.0Z
From: Calvin Allen <calvin.allen@primarysolutions.net>
Subject: Re: Rich Text
Newsgroups: sybase.public.powerbuilder.datawindow
User-Agent: 40tude_Dialog/2.0.15.1
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Reply-To: calvin.allen@primarysolutions.net
References: <48ee5fdf$1@forums-1-dub>
Message-ID: <ivslnqhmh34b.8u8yr0k44ew4$.dlg@40tude.net>
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 24 Feb 2009 09:43:46 -0800
X-Trace: forums-1-dub 1235497426 10.22.241.152 (24 Feb 2009 09:43:46 -0800)
X-Original-Trace: 24 Feb 2009 09:43:46 -0800, vip152.sybase.com
Lines: 30
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:88858
Article PK: 418111


On 9 Oct 2008 12:47:43 -0700, Randy wrote:

> Perhaps I am having a brain melt down here, but I have not been able to
> figure this one out. Perhaps someone can point me in the right direction.
>
> PB11.5
>
> 1. I have a column on a DW which is named Part_Description.
> 2. I set the Edit Style to Rich Text.
> 3. I retrieve data and the column is blank.
> 4. The column is defined on the DB as a long Varchar and has text in it,
> but is not formatted as Rich Text. If I put Rich Text into the column on
> the database, it displays OK.
>
> 5. So,I guess there is not an automatic conversion here, Should there be?
>
> Now, the hard part. How can I update this column on the DB so that it
> is formated as Rich Text and this will work?
>
> TIA
> Randy

I am having the same issue, does ANYONE have any information on how to
solve this?

Thanks,
--
Calvin Allen
PowerBuilder Developer
Columbus, OH


Bruce Armstrong [TeamSybase] Posted on 2009-02-24 19:08:48.0Z
From: "Bruce Armstrong [TeamSybase]" <NOCANSPAM_bruce.armstrong@teamsybase.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <48ee5fdf$1@forums-1-dub> <ivslnqhmh34b.8u8yr0k44ew4$.dlg@40tude.net>
Subject: Re: Rich Text
Lines: 51
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49a445c0$1@forums-1-dub>
Date: 24 Feb 2009 11:08:48 -0800
X-Trace: forums-1-dub 1235502528 10.22.241.152 (24 Feb 2009 11:08:48 -0800)
X-Original-Trace: 24 Feb 2009 11:08:48 -0800, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:88859
Article PK: 418110

No, there is no automatic conversion. You could write a little utility that
reads the column directly in the background, inserts it into a rich text
control and then pull out the rich text and save it back to the column. Run
that once on the database and your'e done.

--
-----------------------------------

My Web 2.0 Stuff

Blog: http://bruce.pbdjmagazine.com/
Facebook: http://www.facebook.com/people/Bruce-Armstrong/1600223798
Fotki: http://public.fotki.com/brucearmstrong/
LinkedIn: http://www.linkedin.com/in/bruceaarmstrong
Twitter: http://twitter.com/bruce_armstrong
YouTube: http://www.youtube.com/user/brucearmstrong

"Calvin Allen" <calvin.allen@primarysolutions.net> wrote in message
news:ivslnqhmh34b.8u8yr0k44ew4$.dlg@40tude.net...
> On 9 Oct 2008 12:47:43 -0700, Randy wrote:
>
>> Perhaps I am having a brain melt down here, but I have not been able to
>> figure this one out. Perhaps someone can point me in the right
>> direction.
>>
>> PB11.5
>>
>> 1. I have a column on a DW which is named Part_Description.
>> 2. I set the Edit Style to Rich Text.
>> 3. I retrieve data and the column is blank.
>> 4. The column is defined on the DB as a long Varchar and has text in it,
>> but is not formatted as Rich Text. If I put Rich Text into the column on
>> the database, it displays OK.
>>
>> 5. So,I guess there is not an automatic conversion here, Should there be?
>>
>> Now, the hard part. How can I update this column on the DB so that it
>> is formated as Rich Text and this will work?
>>
>> TIA
>> Randy
>
> I am having the same issue, does ANYONE have any information on how to
> solve this?
>
> Thanks,
> --
> Calvin Allen
> PowerBuilder Developer
> Columbus, OH


Randy Posted on 2009-02-24 21:34:54.0Z
From: Randy <CGreenwellAtsparusaDotcom>
Reply-To: CGreenwellAtsparusaDotcom
Organization: SPAR Associates, Inc
User-Agent: Thunderbird 2.0.0.19 (Windows/20081209)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: Rich Text
References: <48ee5fdf$1@forums-1-dub> <ivslnqhmh34b.8u8yr0k44ew4$.dlg@40tude.net>
In-Reply-To: <ivslnqhmh34b.8u8yr0k44ew4$.dlg@40tude.net>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49a467fe$1@forums-1-dub>
Date: 24 Feb 2009 13:34:54 -0800
X-Trace: forums-1-dub 1235511294 10.22.241.152 (24 Feb 2009 13:34:54 -0800)
X-Original-Trace: 24 Feb 2009 13:34:54 -0800, vip152.sybase.com
Lines: 50
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:88860
Article PK: 418112

I did it a couple of different ways but finally decided on using SQL (I
had to update 40 or so tables and a dozen different columns). I simply
update the columns I want to format as rich text like this:

//Build a SQL statement for the table and column to update
ls_sql = "Update " + ls_tableNameDesc + " Set " + ls_colName +
"='{\rtf1\ansi\ansicpg1252\uc1\deff0{\fonttbl{\f0\fswiss\fcharset0\fprq2
Tahoma;}}\f0\fs20 ' + " + ls_colname + " + '}' "

//Execute the SQL
EXECUTE IMMEDIATE :ls_sql using sqlca;

It was a little overkill for the rtf formating, but I wanted all of the
descriptions to look the same and use the same fonts. You could probably
get away with '{\rtf1' + ls_colName + '}'

The datastore method (using 2 datastores, one to read the data and
another to update it) was problematic in that there are bugs in earlier
versions of 11.5 for the RTE.

HTH
Randy

Calvin Allen wrote:
> On 9 Oct 2008 12:47:43 -0700, Randy wrote:
>
>> Perhaps I am having a brain melt down here, but I have not been able to
>> figure this one out. Perhaps someone can point me in the right direction.
>>
>> PB11.5
>>
>> 1. I have a column on a DW which is named Part_Description.
>> 2. I set the Edit Style to Rich Text.
>> 3. I retrieve data and the column is blank.
>> 4. The column is defined on the DB as a long Varchar and has text in it,
>> but is not formatted as Rich Text. If I put Rich Text into the column on
>> the database, it displays OK.
>>
>> 5. So,I guess there is not an automatic conversion here, Should there be?
>>
>> Now, the hard part. How can I update this column on the DB so that it
>> is formated as Rich Text and this will work?
>>
>> TIA
>> Randy
>
> I am having the same issue, does ANYONE have any information on how to
> solve this?
>
> Thanks,