Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

empty the keyboard buffer on protected cells. (PB 11.5)

4 posts in DataWindow Last posting was on 2008-11-04 06:36:06.0Z
Roberto Lammoglia <roberto.lammoglia Posted on 2008-10-28 14:00:12.0Z
From: Roberto Lammoglia <roberto.lammoglia@NOSPAM_becromal.it>
User-Agent: Thunderbird 2.0.0.17 (Windows/20080914)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: empty the keyboard buffer on protected cells. (PB 11.5)
X-Enigmail-Version: 0.95.7
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49071aec$1@forums-1-dub>
Date: 28 Oct 2008 06:00:12 -0800
X-Trace: forums-1-dub 1225202412 10.22.241.152 (28 Oct 2008 06:00:12 -0800)
X-Original-Trace: 28 Oct 2008 06:00:12 -0800, vip152.sybase.com
Lines: 15
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:88051
Article PK: 417307

Dear all,

In a datawindow there are some cells that are "protected".

When the user goes in the cell and digit some characters they not
appeared on the screen, but when the users move the cursor on a "not
protected cell" the characters appear on this cell and this is wrong and
can cause errors !

Is there a mode to avoid this behaviour ?

eg: for a cell protected does'nt accepting any character.

TIA
bob


Philip Salgannik Posted on 2008-10-28 14:51:46.0Z
Reply-To: "Philip Salgannik" <PhilipSalgannik@work.com>
From: "Philip Salgannik" <PhilipSalgannik@work.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <49071aec$1@forums-1-dub>
Subject: Re: empty the keyboard buffer on protected cells. (PB 11.5)
Lines: 21
Organization: ATWORK
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5512
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49072702@forums-1-dub>
Date: 28 Oct 2008 06:51:46 -0800
X-Trace: forums-1-dub 1225205506 10.22.241.152 (28 Oct 2008 06:51:46 -0800)
X-Original-Trace: 28 Oct 2008 06:51:46 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:88053
Article PK: 417308

If this is indeed happening, it is a bug in version 11.5 and you need to
report it to Sybase. (I've never seen this in any version up 10.5)

"Roberto Lammoglia" <roberto.lammoglia@NOSPAM_becromal.it> wrote in message
news:49071aec$1@forums-1-dub...
> Dear all,
>
> In a datawindow there are some cells that are "protected".
>
> When the user goes in the cell and digit some characters they not
> appeared on the screen, but when the users move the cursor on a "not
> protected cell" the characters appear on this cell and this is wrong and
> can cause errors !
>
> Is there a mode to avoid this behaviour ?
>
> eg: for a cell protected does'nt accepting any character.
>
> TIA
> bob


Roberto Lammoglia <roberto.lammoglia Posted on 2008-10-29 10:52:35.0Z
From: Roberto Lammoglia <roberto.lammoglia@NOSPAM_becromal.it>
User-Agent: Thunderbird 2.0.0.17 (Windows/20080914)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: empty the keyboard buffer on protected cells. (PB 11.5)
References: <49071aec$1@forums-1-dub> <49072702@forums-1-dub>
In-Reply-To: <49072702@forums-1-dub>
X-Enigmail-Version: 0.95.7
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49084073$1@forums-1-dub>
Date: 29 Oct 2008 02:52:35 -0800
X-Trace: forums-1-dub 1225277555 10.22.241.152 (29 Oct 2008 02:52:35 -0800)
X-Original-Trace: 29 Oct 2008 02:52:35 -0800, vip152.sybase.com
Lines: 27
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:88064
Article PK: 417320


Philip Salgannik wrote:
> If this is indeed happening, it is a bug in version 11.5 and you need to
> report it to Sybase. (I've never seen this in any version up 10.5)
> "Roberto Lammoglia" <roberto.lammoglia@NOSPAM_becromal.it> wrote in message
> news:49071aec$1@forums-1-dub...
>> Dear all,
>>
>> In a datawindow there are some cells that are "protected".
>>
>> When the user goes in the cell and digit some characters they not
>> appeared on the screen, but when the users move the cursor on a "not
>> protected cell" the characters appear on this cell and this is wrong and
>> can cause errors !
>>
>> Is there a mode to avoid this behaviour ?
>>
>> eg: for a cell protected does'nt accepting any character.
>>
>> TIA
>> bob
>
>

Dear Philip,
I don't know how to make this, but I have the same behaviour in PB 11.2
and in PB 11.5.

Some other from the sybase staff ?


Roberto Lammoglia <roberto.lammoglia Posted on 2008-11-04 06:36:06.0Z
From: Roberto Lammoglia <roberto.lammoglia@NOSPAM_becromal.it>
User-Agent: Thunderbird 2.0.0.17 (Windows/20080914)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: empty the keyboard buffer on protected cells. (PB 11.5)
References: <49071aec$1@forums-1-dub> <49072702@forums-1-dub> <49084073$1@forums-1-dub>
In-Reply-To: <49084073$1@forums-1-dub>
X-Enigmail-Version: 0.95.7
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <490fed56$1@forums-1-dub>
Date: 3 Nov 2008 22:36:06 -0800
X-Trace: forums-1-dub 1225780566 10.22.241.152 (3 Nov 2008 22:36:06 -0800)
X-Original-Trace: 3 Nov 2008 22:36:06 -0800, vip152.sybase.com
Lines: 8
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:88097
Article PK: 417354

This happened only with the DW grid type.

If I put (in the source of dw) the processing to 1 this not happened !

idea ?

TIA
bob