Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

crash while importing xml-File into DW

2 posts in DataWindow Last posting was on 2009-01-09 17:38:15.0Z
Daniela Posted on 2009-01-09 12:16:58.0Z
Sender: 12dd.4966278d.1804289383@sybase.com
From: Daniela
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: crash while importing xml-File into DW
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4967403a.39ee.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 9 Jan 2009 04:16:58 -0800
X-Trace: forums-1-dub 1231503418 10.22.241.41 (9 Jan 2009 04:16:58 -0800)
X-Original-Trace: 9 Jan 2009 04:16:58 -0800, 10.22.241.41
Lines: 14
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:88527
Article PK: 417782

I'm working with Powerbuilder Version 10.0 Build 5032.

I generate an XML-File with the following statement:

dw_1.SaveAs(is_object, XML!, false)

when I import this file with

dw_1.ImportFile(XML!, is_object)

in development environment all works fine but at runtime
Powerbuilder crashes.

Any idea what I did wrong?


Bruce Armstrong [TeamSybase] Posted on 2009-01-09 17:38:15.0Z
From: "Bruce Armstrong [TeamSybase]" <NOCANSPAM_bruce.armstrong@teamsybase.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4967403a.39ee.1681692777@sybase.com>
Subject: Re: crash while importing xml-File into DW
Lines: 31
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49678b87@forums-1-dub>
Date: 9 Jan 2009 09:38:15 -0800
X-Trace: forums-1-dub 1231522695 10.22.241.152 (9 Jan 2009 09:38:15 -0800)
X-Original-Trace: 9 Jan 2009 09:38:15 -0800, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:88549
Article PK: 417802

Perhaps missing runtime files. There are a number of extra ones (Xerces
etc) that are required for XML import.

--
-----------------------------------

My Web 2.0 Stuff

Blog: http://bruce.pbdjmagazine.com/
Facebook: http://www.facebook.com/people/Bruce-Armstrong/1600223798
Fotki: http://public.fotki.com/brucearmstrong/
LinkedIn: http://www.linkedin.com/in/bruceaarmstrong
Twitter: http://twitter.com/bruce_armstrong
YouTube: http://www.youtube.com/user/brucearmstrong

<Daniela> wrote in message news:4967403a.39ee.1681692777@sybase.com...
> I'm working with Powerbuilder Version 10.0 Build 5032.
>
> I generate an XML-File with the following statement:
>
> dw_1.SaveAs(is_object, XML!, false)
>
> when I import this file with
>
> dw_1.ImportFile(XML!, is_object)
>
> in development environment all works fine but at runtime
> Powerbuilder crashes.
>
> Any idea what I did wrong?