Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Compatibility between AnyWhere-versions

4 posts in General Discussion Last posting was on 2009-02-02 08:59:28.0Z
Bengt Åström Posted on 2009-02-01 09:35:00.0Z
Sender: 5c55.49856a9e.1804289383@sybase.com
From: Bengt Åström
Newsgroups: ianywhere.public.general
Subject: Compatibility between AnyWhere-versions
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <49856cc4.5ca1.1681692777@sybase.com>
MIME-Version: 1.0
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: quoted-printable
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 1 Feb 2009 01:35:00 -0800
X-Trace: forums-1-dub 1233480900 10.22.241.41 (1 Feb 2009 01:35:00 -0800)
X-Original-Trace: 1 Feb 2009 01:35:00 -0800, 10.22.241.41
Lines: 13
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:7336
Article PK: 5754

After installing PB 11.5 and SQL AnyWhere 11 I realize that
this
db-platform is'nt compatible to older versions like Adaptive
Server AnyWhere 8.0.
I failed to write a pipe-object, got a message like ....
'different versions...'

How do I pipe data from AnyWhere 8.0 to AnyWhere 11 in a
most convenient way?

Best Regards

Bengt Åström, new PB 11.5 - owner


"Chris Keating [Sybase iAnywhere]" <keating_no Posted on 2009-02-01 17:28:43.0Z
From: "Chris Keating [Sybase iAnywhere]" <keating_no@spam_sybase.com>
User-Agent: Thunderbird 2.0.0.19 (Windows/20081209)
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: Compatibility between AnyWhere-versions
References: <49856cc4.5ca1.1681692777@sybase.com>
In-Reply-To: <49856cc4.5ca1.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4985dbcb$1@forums-1-dub>
Date: 1 Feb 2009 09:28:43 -0800
X-Trace: forums-1-dub 1233509323 10.22.241.152 (1 Feb 2009 09:28:43 -0800)
X-Original-Trace: 1 Feb 2009 09:28:43 -0800, vip152.sybase.com
Lines: 23
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:7337
Article PK: 5751

It is important to provide the exact error since some error text can be
very similar but have different causes.

In this case, the error suggests that you are autostarting the database
and have not provided unique server names for the SA8 and SA11 database
engines. In that case, the 'default' engine will be used. Verify that
you have defined the server name value in each of the SA DSNs used and
that those server names are unique.

Bengt Åström wrote:

> After installing PB 11.5 and SQL AnyWhere 11 I realize that
> this
> db-platform is'nt compatible to older versions like Adaptive
> Server AnyWhere 8.0.
> I failed to write a pipe-object, got a message like ....
> 'different versions...'
>
> How do I pipe data from AnyWhere 8.0 to AnyWhere 11 in a
> most convenient way?
>
> Best Regards
>

> Bengt Åström, new PB 11.5 - owner


Bengt Å. Posted on 2009-02-02 08:38:52.0Z
Sender: 1970.4986a811.1804289383@sybase.com
From: Bengt Å.
Newsgroups: ianywhere.public.general
Subject: Re: Compatibility between AnyWhere-versions
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4986b11c.1a14.1681692777@sybase.com>
References: <4985dbcb$1@forums-1-dub>
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="-=_forums-1-dub4986b11c"
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 2 Feb 2009 00:38:52 -0800
X-Trace: forums-1-dub 1233563932 10.22.241.41 (2 Feb 2009 00:38:52 -0800)
X-Original-Trace: 2 Feb 2009 00:38:52 -0800, 10.22.241.41
Lines: 2354
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:7339
Article PK: 5759


> It is important to provide the exact error since some
> error text can be very similar but have different causes.
>
> In this case, the error suggests that you are autostarting
> the database and have not provided unique server names
> for the SA8 and SA11 database engines. In that case, the
> 'default' engine will be used. Verify that you have
> defined the server name value in each of the SA DSNs used
> and that those server names are unique.
>
> Bengt Åström wrote:
> > After installing PB 11.5 and SQL AnyWhere 11 I realize
> > that this
> > db-platform is'nt compatible to older versions like
> > Adaptive Server AnyWhere 8.0.
> > I failed to write a pipe-object, got a message like ....
> > 'different versions...'
> >
> > How do I pipe data from AnyWhere 8.0 to AnyWhere 11 in a
> > most convenient way?
> >
> > Best Regards
> >
> > Bengt Åström, new PB 11.5 - owner

I got two ODBC-datasources, Ekonomi within SA-8 and Economy
within SA-11. In PB 11.5 DB-painter I'll try to create a new
ODBC-profile for Ekonomi but failed. I guess the problem
would be similar if I in PB 9 would create a ODBC-profile
for Economy (SA-11)