Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Disappearing rows in nested report

4 posts in DataWindow Last posting was on 2009-03-19 22:00:55.0Z
Mike Marston Posted on 2009-03-19 16:16:25.0Z
From: "Mike Marston" <mikem@ksitech.com>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Disappearing rows in nested report
Lines: 19
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49c26fd9$1@forums-1-dub>
Date: 19 Mar 2009 08:16:25 -0800
X-Trace: forums-1-dub 1237479385 10.22.241.152 (19 Mar 2009 08:16:25 -0800)
X-Original-Trace: 19 Mar 2009 08:16:25 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89010
Article PK: 418264

We have a nested report in the footer band of the master report. All
infomation is retrieved correctly, including all the rows in the nested
report. When the report is printed, several rows in the nested report
disappear and are not printed.

While trying to debug this in the IDE we discovered that after retrieving
the data, ANY change to the master report in the design frame result in the
same disapperaring rows. Something as simple as checking the Print Preview
property or moving the nested report container 1 pixel causes the problem.

We are currently using PB 11.2 Build 8739. This report worked and still
works without a problem in PB 8.0.3.

Any ideas?

TIA,
Mike


"Paul Horan[Sybase]" <phoran_remove Posted on 2009-03-19 16:41:37.0Z
From: "Paul Horan[Sybase]" <phoran_remove@remove_sybase.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <49c26fd9$1@forums-1-dub>
Subject: Re: Disappearing rows in nested report
Lines: 35
Organization: Sybase
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49c275c1@forums-1-dub>
Date: 19 Mar 2009 08:41:37 -0800
X-Trace: forums-1-dub 1237480897 10.22.241.152 (19 Mar 2009 08:41:37 -0800)
X-Original-Trace: 19 Mar 2009 08:41:37 -0800, vip152.sybase.com
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89011
Article PK: 418263

"several" rows? Is it all the rows, or a subset? What is it about those
rows that differentiates them from those that aren't removed?

Some debugging you can do: if you do a RowCount() on that nested dw, does
that return the right number? If it does, then they're present but not
shown (for whatever reason), and if it does not, then they've been removed
(either to the deleted or filter buffer).

--
Paul Horan[Sybase]
paulhoran.pbdjmagazine.com

"Mike Marston" <mikem@ksitech.com> wrote in message
news:49c26fd9$1@forums-1-dub...
> We have a nested report in the footer band of the master report. All
> infomation is retrieved correctly, including all the rows in the nested
> report. When the report is printed, several rows in the nested report
> disappear and are not printed.
>
> While trying to debug this in the IDE we discovered that after retrieving
> the data, ANY change to the master report in the design frame result in
> the same disapperaring rows. Something as simple as checking the Print
> Preview property or moving the nested report container 1 pixel causes the
> problem.
>
> We are currently using PB 11.2 Build 8739. This report worked and still
> works without a problem in PB 8.0.3.
>
> Any ideas?
>
> TIA,
> Mike
>


Mike Marston Posted on 2009-03-19 20:56:27.0Z
From: "Mike Marston" <mikem@ksitech.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <49c26fd9$1@forums-1-dub> <49c275c1@forums-1-dub>
Subject: Re: Disappearing rows in nested report
Lines: 50
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49c2b17b$1@forums-1-dub>
Date: 19 Mar 2009 12:56:27 -0800
X-Trace: forums-1-dub 1237496187 10.22.241.152 (19 Mar 2009 12:56:27 -0800)
X-Original-Trace: 19 Mar 2009 12:56:27 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89012
Article PK: 418261

Paul,
Thanks for the response. As it turns out we had to check the "Autosize
Height" property of the footer band on the master report. It may be because
the nested report was in the footer band, although the Autosize Height of
the nested report container was not checked. This property was not
available for the footer band in PB 8.

It doesn't make much sense to me, but I'm glad we found it.

Thanks again.

"Paul Horan[Sybase]" <phoran_remove@remove_sybase.com> wrote in message
news:49c275c1@forums-1-dub...
> "several" rows? Is it all the rows, or a subset? What is it about those
> rows that differentiates them from those that aren't removed?
>
> Some debugging you can do: if you do a RowCount() on that nested dw, does
> that return the right number? If it does, then they're present but not
> shown (for whatever reason), and if it does not, then they've been removed
> (either to the deleted or filter buffer).
>
> --
> Paul Horan[Sybase]
> paulhoran.pbdjmagazine.com
>
> "Mike Marston" <mikem@ksitech.com> wrote in message
> news:49c26fd9$1@forums-1-dub...
>> We have a nested report in the footer band of the master report. All
>> infomation is retrieved correctly, including all the rows in the nested
>> report. When the report is printed, several rows in the nested report
>> disappear and are not printed.
>>
>> While trying to debug this in the IDE we discovered that after retrieving
>> the data, ANY change to the master report in the design frame result in
>> the same disapperaring rows. Something as simple as checking the Print
>> Preview property or moving the nested report container 1 pixel causes the
>> problem.
>>
>> We are currently using PB 11.2 Build 8739. This report worked and still
>> works without a problem in PB 8.0.3.
>>
>> Any ideas?
>>
>> TIA,
>> Mike
>>
>
>


Mike Marston Posted on 2009-03-19 22:00:55.0Z
From: "Mike Marston" <mikem@ksitech.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <49c26fd9$1@forums-1-dub> <49c275c1@forums-1-dub>
Subject: Re: Disappearing rows in nested report
Lines: 43
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49c2c097@forums-1-dub>
Date: 19 Mar 2009 14:00:55 -0800
X-Trace: forums-1-dub 1237500055 10.22.241.152 (19 Mar 2009 14:00:55 -0800)
X-Original-Trace: 19 Mar 2009 14:00:55 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89013
Article PK: 418273

One more thing we just discover. The fix works on Win 2K and XP from the IDE
and the compiled app, but not from the compiled app on Vista. Go figure!

"Paul Horan[Sybase]" <phoran_remove@remove_sybase.com> wrote in message
news:49c275c1@forums-1-dub...
> "several" rows? Is it all the rows, or a subset? What is it about those
> rows that differentiates them from those that aren't removed?
>
> Some debugging you can do: if you do a RowCount() on that nested dw, does
> that return the right number? If it does, then they're present but not
> shown (for whatever reason), and if it does not, then they've been removed
> (either to the deleted or filter buffer).
>
> --
> Paul Horan[Sybase]
> paulhoran.pbdjmagazine.com
>
> "Mike Marston" <mikem@ksitech.com> wrote in message
> news:49c26fd9$1@forums-1-dub...
>> We have a nested report in the footer band of the master report. All
>> infomation is retrieved correctly, including all the rows in the nested
>> report. When the report is printed, several rows in the nested report
>> disappear and are not printed.
>>
>> While trying to debug this in the IDE we discovered that after retrieving
>> the data, ANY change to the master report in the design frame result in
>> the same disapperaring rows. Something as simple as checking the Print
>> Preview property or moving the nested report container 1 pixel causes the
>> problem.
>>
>> We are currently using PB 11.2 Build 8739. This report worked and still
>> works without a problem in PB 8.0.3.
>>
>> Any ideas?
>>
>> TIA,
>> Mike
>>
>
>