Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Old Problem

3 posts in DataWindow Last posting was on 2009-03-20 17:03:44.0Z
JHP Posted on 2009-03-20 16:42:42.0Z
Reply-To: "JHP" <JHP@goawayplease.com>
From: "JHP" <JHP@goawayplease.com>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Old Problem
Lines: 27
Organization: Personal
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49c3c782@forums-1-dub>
Date: 20 Mar 2009 08:42:42 -0800
X-Trace: forums-1-dub 1237567362 10.22.241.152 (20 Mar 2009 08:42:42 -0800)
X-Original-Trace: 20 Mar 2009 08:42:42 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89023
Article PK: 418275

I Posted the following in the General NG yesterday, but am still stuck!

PB 7.03
Sybase ASA 6.04

Computer HD died.
New HD - reloaded everything.
Restored all PB related files from backup.

The tables from the database painter show "dba".tablename".
The tables from the datawindow painter "Design - Data Source - Syntax View"
show just as tablename.

"Graphics View" reports table has no columns...

How am I able to fix this so that I can view the tables in "Graphics
View"?.. remove "dba" (owner) from the table name in the "Database Painter"
to match the datawindow schema?
All this was working prior to the rebuild / restore...

Without having to export the datawindow schema - modify it - import it back.

Or append "dba". at every instance manually?

Thank you for your expertise.


"Chris Keating [Sybase iAnywhere]" <keating_no Posted on 2009-03-20 16:47:17.0Z
From: "Chris Keating [Sybase iAnywhere]" <keating_no@spam_sybase.com>
User-Agent: Thunderbird 2.0.0.19 (Windows/20081209)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: Old Problem
References: <49c3c782@forums-1-dub>
In-Reply-To: <49c3c782@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49c3c895$1@forums-1-dub>
Date: 20 Mar 2009 08:47:17 -0800
X-Trace: forums-1-dub 1237567637 10.22.241.152 (20 Mar 2009 08:47:17 -0800)
X-Original-Trace: 20 Mar 2009 08:47:17 -0800, vip152.sybase.com
Lines: 31
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89024
Article PK: 418276

Are you missing the pbodb70.ini file? Or is it not in the path?

JHP wrote:
> I Posted the following in the General NG yesterday, but am still stuck!
>
> PB 7.03
> Sybase ASA 6.04
>
> Computer HD died.
> New HD - reloaded everything.
> Restored all PB related files from backup.
>
> The tables from the database painter show "dba".tablename".
> The tables from the datawindow painter "Design - Data Source - Syntax View"
> show just as tablename.
>
> "Graphics View" reports table has no columns...
>
> How am I able to fix this so that I can view the tables in "Graphics
> View"?.. remove "dba" (owner) from the table name in the "Database Painter"
> to match the datawindow schema?
> All this was working prior to the rebuild / restore...
>
> Without having to export the datawindow schema - modify it - import it back.
>
> Or append "dba". at every instance manually?
>
> Thank you for your expertise.
>
>


JHP Posted on 2009-03-20 17:03:44.0Z
Reply-To: "JHP" <JHP@goawayplease.com>
From: "JHP" <JHP@goawayplease.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <49c3c782@forums-1-dub> <49c3c895$1@forums-1-dub>
Subject: Re: Old Problem
Lines: 43
Organization: Personal
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49c3cc70$1@forums-1-dub>
Date: 20 Mar 2009 09:03:44 -0800
X-Trace: forums-1-dub 1237568624 10.22.241.152 (20 Mar 2009 09:03:44 -0800)
X-Original-Trace: 20 Mar 2009 09:03:44 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89026
Article PK: 418279

You seriously rock...

I wasn't missing it, but I remember (after being shown to the pbodb70.ini
file) about the PBQualifierIsOwner parameter...

All is right with the world again, thank you so much.

"Chris Keating [Sybase iAnywhere]" <keating_no@spam_sybase.com> wrote in
message news:49c3c895$1@forums-1-dub...
> Are you missing the pbodb70.ini file? Or is it not in the path?
>
>
> JHP wrote:
>> I Posted the following in the General NG yesterday, but am still stuck!
>>
>> PB 7.03
>> Sybase ASA 6.04
>>
>> Computer HD died.
>> New HD - reloaded everything.
>> Restored all PB related files from backup.
>>
>> The tables from the database painter show "dba".tablename".
>> The tables from the datawindow painter "Design - Data Source - Syntax
>> View"
>> show just as tablename.
>>
>> "Graphics View" reports table has no columns...
>>
>> How am I able to fix this so that I can view the tables in "Graphics
>> View"?.. remove "dba" (owner) from the table name in the "Database
>> Painter" to match the datawindow schema?
>> All this was working prior to the rebuild / restore...
>>
>> Without having to export the datawindow schema - modify it - import it
>> back.
>>
>> Or append "dba". at every instance manually?
>>
>> Thank you for your expertise.
>>