Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

RichText Datawindow Column

3 posts in DataWindow Last posting was on 2009-04-02 14:07:13.0Z
Jenifer Gaia Posted on 2009-04-02 13:37:35.0Z
From: "Jenifer Gaia" <jgaia@mmd.com>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: RichText Datawindow Column
Lines: 23
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49d4bf9f$1@forums-1-dub>
Date: 2 Apr 2009 05:37:35 -0800
X-Trace: forums-1-dub 1238679455 10.22.241.152 (2 Apr 2009 05:37:35 -0800)
X-Original-Trace: 2 Apr 2009 05:37:35 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89107
Article PK: 418361

I created a datawindow which has a single column called str_Text which is
type string and length 69999.

I dropped the column onto my datawindow detail section and defaulted the
value to
"How do you solve a problem like Maria?"

When I go to Properties->Edit Tab -> Style Type = Edit
Result: My defaulted value is displayed. Works as Expected.

When I modify the Style type to RichText
Result: My column appears empty. No text is defaulted.
Expected Results: I expected it to populate the column with data just like
any other Style Type.


When a StyleType is set to RichText, is there something else you need to do
to get the text to populate?


~J


ps <ps Posted on 2009-04-02 13:56:20.0Z
From: ps <ps@.>
User-Agent: Thunderbird 2.0.0.19 (Windows/20081209)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: RichText Datawindow Column
References: <49d4bf9f$1@forums-1-dub>
In-Reply-To: <49d4bf9f$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49d4c404$1@forums-1-dub>
Date: 2 Apr 2009 05:56:20 -0800
X-Trace: forums-1-dub 1238680580 10.22.241.152 (2 Apr 2009 05:56:20 -0800)
X-Original-Trace: 2 Apr 2009 05:56:20 -0800, vip152.sybase.com
Lines: 26
X-Authenticated-User: powerbuilder
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89108
Article PK: 418359

you need to set valid rtf as a default value ...

Jenifer Gaia wrote:
> I created a datawindow which has a single column called str_Text which is
> type string and length 69999.
>
> I dropped the column onto my datawindow detail section and defaulted the
> value to
> "How do you solve a problem like Maria?"
>
> When I go to Properties->Edit Tab -> Style Type = Edit
> Result: My defaulted value is displayed. Works as Expected.
>
> When I modify the Style type to RichText
> Result: My column appears empty. No text is defaulted.
> Expected Results: I expected it to populate the column with data just like
> any other Style Type.
>
>
> When a StyleType is set to RichText, is there something else you need to do
> to get the text to populate?
>
>
> ~J
>
>


Jenifer Gaia Posted on 2009-04-02 14:07:13.0Z
From: "Jenifer Gaia" <jgaia@mmd.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <49d4bf9f$1@forums-1-dub> <49d4c404$1@forums-1-dub>
Subject: Re: RichText Datawindow Column
Lines: 29
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49d4c691$1@forums-1-dub>
Date: 2 Apr 2009 06:07:13 -0800
X-Trace: forums-1-dub 1238681233 10.22.241.152 (2 Apr 2009 06:07:13 -0800)
X-Original-Trace: 2 Apr 2009 06:07:13 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89109
Article PK: 418360

Thanks!

"ps" <ps@.> wrote in message news:49d4c404$1@forums-1-dub...
> you need to set valid rtf as a default value ...
>
> Jenifer Gaia wrote:
>> I created a datawindow which has a single column called str_Text which is
>> type string and length 69999.
>>
>> I dropped the column onto my datawindow detail section and defaulted the
>> value to
>> "How do you solve a problem like Maria?"
>>
>> When I go to Properties->Edit Tab -> Style Type = Edit
>> Result: My defaulted value is displayed. Works as Expected.
>>
>> When I modify the Style type to RichText
>> Result: My column appears empty. No text is defaulted.
>> Expected Results: I expected it to populate the column with data just
>> like any other Style Type.
>>
>>
>> When a StyleType is set to RichText, is there something else you need to
>> do to get the text to populate?
>>
>>
>> ~J