Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Copy Paste Apostrophe in DW from word

2 posts in DataWindow Last posting was on 2009-04-14 20:25:13.0Z
Meena Posted on 2009-04-14 19:31:42.0Z
Sender: 2fdc.49e4e2ae.1804289383@sybase.com
From: Meena
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Copy Paste Apostrophe in DW from word
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <49e4e49e.2ffe.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 14 Apr 2009 12:31:42 -0700
X-Trace: forums-1-dub 1239737502 10.22.241.41 (14 Apr 2009 12:31:42 -0700)
X-Original-Trace: 14 Apr 2009 12:31:42 -0700, 10.22.241.41
Lines: 6
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89162
Article PK: 418414

Hi Guys
I am trying to copy paste from a word document. words having
apostrophe when pasted looks ok. but when we save them it
gets converted into upside down question mark.
when trying from a notepad it works perfectly fine.
any idea what could be the problem


Jason 'Bug' Fenter Posted on 2009-04-14 20:25:13.0Z
From: Jason 'Bug' Fenter <jason.fenter@teamsybase.com>
User-Agent: Thunderbird 2.0.0.21 (Windows/20090302)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: Copy Paste Apostrophe in DW from word
References: <49e4e49e.2ffe.1681692777@sybase.com>
In-Reply-To: <49e4e49e.2ffe.1681692777@sybase.com>
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49e4f129$1@forums-1-dub>
Date: 14 Apr 2009 13:25:13 -0700
X-Trace: forums-1-dub 1239740713 10.22.241.152 (14 Apr 2009 13:25:13 -0700)
X-Original-Trace: 14 Apr 2009 13:25:13 -0700, vip152.sybase.com
Lines: 14
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89164
Article PK: 418415

MS Word uses "smart quotes". It replaces apostrophes with Unicode
character 8217... ’ instead of '. You're most likely seeing a
translation issue between what's being pasted and what is put into the
database. I'd first check your DBMS collation.

Meena wrote:
> Hi Guys
> I am trying to copy paste from a word document. words having
> apostrophe when pasted looks ok. but when we save them it
> gets converted into upside down question mark.
> when trying from a notepad it works perfectly fine.
> any idea what could be the problem