Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Some of new rows has lost when call Setchanges to apply changes to second datawindow/datastore.

3 posts in DataWindow Last posting was on 2009-04-16 08:19:44.0Z
chau Posted on 2009-04-15 04:23:59.0Z
From: "chau" <chau@integratedaviationsoftware.com>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Some of new rows has lost when call Setchanges to apply changes to second datawindow/datastore.
Lines: 14
MIME-Version: 1.0
Content-Type: text/plain; format=flowed; charset="iso-8859-1"; reply-type=original
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Windows Mail 6.0.6001.18000
X-MimeOLE: Produced By Microsoft MimeOLE V6.0.6001.18049
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49e5615f@forums-1-dub>
Date: 14 Apr 2009 21:23:59 -0700
X-Trace: forums-1-dub 1239769439 10.22.241.152 (14 Apr 2009 21:23:59 -0700)
X-Original-Trace: 14 Apr 2009 21:23:59 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89166
Article PK: 418420

I have encountered a situation where a datawidnow has being retrieved and
there is at least one row retrieved, then i call GetFullState/Setfullstate
to copied data from first datawindow to the second datawindow, then i added
at least 5 new rows to the first datawindow and call GetChanges/SetChanges
to apply changes to second datawindow, what's i have noticed is the second
datawindow has lost some of the new rows that has being added to the first
datawindow. The problem only occurred only when the first datawindow has
pre-data retrieved, if there is no row after retrieved for first datawindow,
i can add many rows to first datawindow and call setchanges for second
datawidnow all the new rows are found in second datawidnow. Anyone know
anything about this problem, please help?!!!

Thanks


chau Posted on 2009-04-15 07:51:47.0Z
From: "chau" <chau@integratedaviationsoftware.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <49e5615f@forums-1-dub>
In-Reply-To: <49e5615f@forums-1-dub>
Subject: Re: Some of new rows has lost when call Setchanges to apply changes to second datawindow/datastore.
Lines: 24
MIME-Version: 1.0
Content-Type: text/plain; format=flowed; charset="iso-8859-1"; reply-type=response
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Windows Mail 6.0.6001.18000
X-MimeOLE: Produced By Microsoft MimeOLE V6.0.6001.18049
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49e59213@forums-1-dub>
Date: 15 Apr 2009 00:51:47 -0700
X-Trace: forums-1-dub 1239781907 10.22.241.152 (15 Apr 2009 00:51:47 -0700)
X-Original-Trace: 15 Apr 2009 00:51:47 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89168
Article PK: 418421

more information regrard the previous post:

if i call the setchange second times for second datawindow then all the new
added rows are found in second datawindow, however if i added at least 10
new rows i have to call setchanges repeatedly untill all the new rows has
being found.

"chau" <chau@integratedaviationsoftware.com> wrote in message
news:49e5615f@forums-1-dub...
>I have encountered a situation where a datawidnow has being retrieved and
>there is at least one row retrieved, then i call GetFullState/Setfullstate
>to copied data from first datawindow to the second datawindow, then i added
>at least 5 new rows to the first datawindow and call GetChanges/SetChanges
>to apply changes to second datawindow, what's i have noticed is the second
>datawindow has lost some of the new rows that has being added to the first
>datawindow. The problem only occurred only when the first datawindow has
>pre-data retrieved, if there is no row after retrieved for first
>datawindow, i can add many rows to first datawindow and call setchanges for
>second datawidnow all the new rows are found in second datawidnow. Anyone
>know anything about this problem, please help?!!!
>
> Thanks
>


chau Posted on 2009-04-16 08:19:44.0Z
From: "chau" <chau@integratedaviationsoftware.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <49e5615f@forums-1-dub> <49e59213@forums-1-dub>
In-Reply-To: <49e59213@forums-1-dub>
Subject: Re: Some of new rows has lost when call Setchanges to apply changes to second datawindow/datastore.
Lines: 30
MIME-Version: 1.0
Content-Type: text/plain; format=flowed; charset="iso-8859-1"; reply-type=response
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Windows Mail 6.0.6001.18000
X-MimeOLE: Produced By Microsoft MimeOLE V6.0.6001.18049
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49e6ea20$1@forums-1-dub>
Date: 16 Apr 2009 01:19:44 -0700
X-Trace: forums-1-dub 1239869984 10.22.241.152 (16 Apr 2009 01:19:44 -0700)
X-Original-Trace: 16 Apr 2009 01:19:44 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89173
Article PK: 418424

the prblem occured only when i added a new row before pre-existence row.

"chau" <chau@integratedaviationsoftware.com> wrote in message
news:49e59213@forums-1-dub...
> more information regrard the previous post:
>
> if i call the setchange second times for second datawindow then all the
> new added rows are found in second datawindow, however if i added at least
> 10 new rows i have to call setchanges repeatedly untill all the new rows
> has being found.
>
> "chau" <chau@integratedaviationsoftware.com> wrote in message
> news:49e5615f@forums-1-dub...
>>I have encountered a situation where a datawidnow has being retrieved and
>>there is at least one row retrieved, then i call GetFullState/Setfullstate
>>to copied data from first datawindow to the second datawindow, then i
>>added at least 5 new rows to the first datawindow and call
>>GetChanges/SetChanges to apply changes to second datawindow, what's i have
>>noticed is the second datawindow has lost some of the new rows that has
>>being added to the first datawindow. The problem only occurred only when
>>the first datawindow has pre-data retrieved, if there is no row after
>>retrieved for first datawindow, i can add many rows to first datawindow
>>and call setchanges for second datawidnow all the new rows are found in
>>second datawidnow. Anyone know anything about this problem, please
>>help?!!!
>>
>> Thanks
>>
>