Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Upgrade ADS 7.1 to 9.1 troubles

3 posts in Clipper Last posting was on 2009-04-17 19:31:31.0Z
Denis Lamothe Posted on 2009-04-17 15:00:47.0Z
From: "Denis Lamothe" <denis_lamothe@gentek.ca>
Newsgroups: advantage.clipper
Subject: Upgrade ADS 7.1 to 9.1 troubles
Date: Fri, 17 Apr 2009 11:00:47 -0400
Lines: 36
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: 216.208.97.186
Message-ID: <49e899c2@solutions.advantagedatabase.com>
X-Trace: 17 Apr 2009 09:01:22 -0700, 216.208.97.186
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!216.208.97.186
Xref: solutions.advantagedatabase.com Advantage.Clipper:4405
Article PK: 1107076

Hey folks.

We currently have in two different locations ADS 7.1 running on Netware 6.1
and things are fine. In both locations, we have a similar application
running, whose main difference is that in the first location the app. uses
DBFCDXAX as the driver and the second still uses DBFNTX. Again, thing are
working fine in both locations. As our Netware servers are now getting
outdated, we created for each location a Netware 6.1 VM server. Both of
these servers are in the test phase.

Now here's my problem.

In the second location, we upgraded ADS to version 9.1 on the VM server.
After the upgrade, we decided to switch the Clipper application from using
the standard DBFNTX to using DBFCDXAX and proceeded to make this change on
the VM server. In one of the modules, a database is opened multiple times
using different aliases. Since the driver switch, I can no longer open this
database multiple times. The application abends upon opening the database a
second time.

I believe this to be related to the new version of ADS.

In order to prove my theory since there were multiple changes done (new ADS
and new server), I used my first location's VM server, installed ADS 7.1 on
it and ran a copy of the production version of the software which uses the
DBFCDXAX driver and ran it. Everything is fine.

I then upgraded the server from 7.1 to 9.1 and reran the application, same
result as the other location. The application abends upon trying to open the
database a second time.

Any thoughts?

Thanks in advance


Mark Wilkins Posted on 2009-04-17 16:45:54.0Z
From: "Mark Wilkins" <mark@no.email>
Newsgroups: advantage.clipper
References: <49e899c2@solutions.advantagedatabase.com>
Subject: Re: Upgrade ADS 7.1 to 9.1 troubles
Date: Fri, 17 Apr 2009 10:45:54 -0600
Lines: 63
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: 10.24.38.228
Message-ID: <49e8b21b@solutions.advantagedatabase.com>
X-Trace: 17 Apr 2009 10:45:15 -0700, 10.24.38.228
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!10.24.38.228
Xref: solutions.advantagedatabase.com Advantage.Clipper:4406
Article PK: 1107078

Hi Denis,

The problem is probably due to an issue with the new proprietary exclusive
locking that was added in v9.1. The following KB item has some information
about it and explains why it was added as well as how to turn it off:
http://devzone.advantagedatabase.com/dz/content.aspx?Key=17&RefNo=081023-2093

This change also led to an unanticipated issue with the Clipper RDD that it
sounds like you are seeing. If you are using rights checking, then the RDD
attempts a low level file open on the table (from the client) to see if it
exists. This does not work once Advantage opens the table with the
exclusive locking. If you turn off rights checking (set rights checking
OFF) in your application, it should avoid the problem. Alternatively, you
can disable the exclusive locking as described in the KB item mentioned
above.

We are still looking at the best fix for this in the next update of
Advantage Database Server.

Mark Wilkins
Advantage R&D

"Denis Lamothe" <denis_lamothe@gentek.ca> wrote in message
news:49e899c2@solutions.advantagedatabase.com...
> Hey folks.
>
> We currently have in two different locations ADS 7.1 running on Netware
> 6.1 and things are fine. In both locations, we have a similar application
> running, whose main difference is that in the first location the app. uses
> DBFCDXAX as the driver and the second still uses DBFNTX. Again, thing are
> working fine in both locations. As our Netware servers are now getting
> outdated, we created for each location a Netware 6.1 VM server. Both of
> these servers are in the test phase.
>
> Now here's my problem.
>
> In the second location, we upgraded ADS to version 9.1 on the VM server.
> After the upgrade, we decided to switch the Clipper application from using
> the standard DBFNTX to using DBFCDXAX and proceeded to make this change on
> the VM server. In one of the modules, a database is opened multiple times
> using different aliases. Since the driver switch, I can no longer open
> this database multiple times. The application abends upon opening the
> database a second time.
>
> I believe this to be related to the new version of ADS.
>
> In order to prove my theory since there were multiple changes done (new
> ADS and new server), I used my first location's VM server, installed ADS
> 7.1 on it and ran a copy of the production version of the software which
> uses the DBFCDXAX driver and ran it. Everything is fine.
>
> I then upgraded the server from 7.1 to 9.1 and reran the application, same
> result as the other location. The application abends upon trying to open
> the database a second time.
>
> Any thoughts?
>
> Thanks in advance
>
>


Denis Lamothe Posted on 2009-04-17 19:31:31.0Z
From: "Denis Lamothe" <denis_lamothe@gentek.ca>
Newsgroups: advantage.clipper
References: <49e899c2@solutions.advantagedatabase.com> <49e8b21b@solutions.advantagedatabase.com>
Subject: Re: Upgrade ADS 7.1 to 9.1 troubles
Date: Fri, 17 Apr 2009 15:31:31 -0400
Lines: 74
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: 216.208.97.186
Message-ID: <49e8d93d@solutions.advantagedatabase.com>
X-Trace: 17 Apr 2009 13:32:13 -0700, 216.208.97.186
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!216.208.97.186
Xref: solutions.advantagedatabase.com Advantage.Clipper:4407
Article PK: 1107075

Thanks Mark, problem is solved. Tested both solutions and got the disired
result each time.

"Mark Wilkins" <mark@no.email> wrote in message
news:49e8b21b@solutions.advantagedatabase.com...
> Hi Denis,
>
> The problem is probably due to an issue with the new proprietary exclusive
> locking that was added in v9.1. The following KB item has some
> information about it and explains why it was added as well as how to turn
> it off:
> http://devzone.advantagedatabase.com/dz/content.aspx?Key=17&RefNo=081023-2093
>
> This change also led to an unanticipated issue with the Clipper RDD that
> it sounds like you are seeing. If you are using rights checking, then the
> RDD attempts a low level file open on the table (from the client) to see
> if it exists. This does not work once Advantage opens the table with the
> exclusive locking. If you turn off rights checking (set rights checking
> OFF) in your application, it should avoid the problem. Alternatively, you
> can disable the exclusive locking as described in the KB item mentioned
> above.
>
> We are still looking at the best fix for this in the next update of
> Advantage Database Server.
>
> Mark Wilkins
> Advantage R&D
>
>
> "Denis Lamothe" <denis_lamothe@gentek.ca> wrote in message
> news:49e899c2@solutions.advantagedatabase.com...
>> Hey folks.
>>
>> We currently have in two different locations ADS 7.1 running on Netware
>> 6.1 and things are fine. In both locations, we have a similar application
>> running, whose main difference is that in the first location the app.
>> uses DBFCDXAX as the driver and the second still uses DBFNTX. Again,
>> thing are working fine in both locations. As our Netware servers are now
>> getting outdated, we created for each location a Netware 6.1 VM server.
>> Both of these servers are in the test phase.
>>
>> Now here's my problem.
>>
>> In the second location, we upgraded ADS to version 9.1 on the VM server.
>> After the upgrade, we decided to switch the Clipper application from
>> using the standard DBFNTX to using DBFCDXAX and proceeded to make this
>> change on the VM server. In one of the modules, a database is opened
>> multiple times using different aliases. Since the driver switch, I can no
>> longer open this database multiple times. The application abends upon
>> opening the database a second time.
>>
>> I believe this to be related to the new version of ADS.
>>
>> In order to prove my theory since there were multiple changes done (new
>> ADS and new server), I used my first location's VM server, installed ADS
>> 7.1 on it and ran a copy of the production version of the software which
>> uses the DBFCDXAX driver and ran it. Everything is fine.
>>
>> I then upgraded the server from 7.1 to 9.1 and reran the application,
>> same result as the other location. The application abends upon trying to
>> open the database a second time.
>>
>> Any thoughts?
>>
>> Thanks in advance
>>
>>
>
>