Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Can't start the samples

6 posts in QAnywhere Last posting was on 2009-05-01 15:46:55.0Z
Jason 'Bug' Fenter Posted on 2009-04-28 15:53:37.0Z
From: Jason 'Bug' Fenter <jason.fenter@teamsybase.com>
User-Agent: Thunderbird 2.0.0.21 (Windows/20090302)
MIME-Version: 1.0
Newsgroups: ianywhere.public.sqlanywhere.qanywhere
Subject: Can't start the samples
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49f72681$1@forums-1-dub>
Date: 28 Apr 2009 08:53:37 -0700
X-Trace: forums-1-dub 1240934017 10.22.241.152 (28 Apr 2009 08:53:37 -0700)
X-Original-Trace: 28 Apr 2009 08:53:37 -0700, vip152.sybase.com
Lines: 13
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.sqlanywhere.qanywhere:300
Article PK: 18797

I have SQLA 10 and SQLA 11 installed. I'm trying to start the SQLA 10
samples for QAnywhere. MobiLink with messaging starts correctly, but the
QAnywhere agent for client1 fails. In the QAnywhere window, I see:

I. 2009-04-28 10:44:10. Client message store ID is client1
E. 2009-04-28 10:44:12. Failed to start QAnywhere Agent (DBMLSync)
E. 2009-04-28 10:44:23. Error registering with DBLSN code: -1
I. 2009-04-28 10:45:23. QAnywhere Agent stopped



I have no idea where to start looking for the cause for this error. Can
someone point me in the right direction?


Jason 'Bug' Fenter Posted on 2009-04-28 16:00:33.0Z
From: Jason 'Bug' Fenter <jason.fenter@teamsybase.com>
User-Agent: Thunderbird 2.0.0.21 (Windows/20090302)
MIME-Version: 1.0
Newsgroups: ianywhere.public.sqlanywhere.qanywhere
Subject: Re: Can't start the samples
References: <49f72681$1@forums-1-dub>
In-Reply-To: <49f72681$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49f72821$2@forums-1-dub>
Date: 28 Apr 2009 09:00:33 -0700
X-Trace: forums-1-dub 1240934433 10.22.241.152 (28 Apr 2009 09:00:33 -0700)
X-Original-Trace: 28 Apr 2009 09:00:33 -0700, vip152.sybase.com
Lines: 24
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.sqlanywhere.qanywhere:301
Article PK: 10508

Okay, I was wrong. MobiLink /isn't/ starting correctly. Error is:

E. 2009-04-28 10:32:56. <Main> [-10145] Unable to access the JRE at:
C:\Program Files\SQL Anywhere 10 Deploy\.\Sun\jre150

I'm trying to find an environment variable or setting or something that
points to my java installation. Pointers?

Jason 'Bug' Fenter wrote:
> I have SQLA 10 and SQLA 11 installed. I'm trying to start the SQLA 10
> samples for QAnywhere. MobiLink with messaging starts correctly, but the
> QAnywhere agent for client1 fails. In the QAnywhere window, I see:
>
> I. 2009-04-28 10:44:10. Client message store ID is client1
> E. 2009-04-28 10:44:12. Failed to start QAnywhere Agent (DBMLSync)
> E. 2009-04-28 10:44:23. Error registering with DBLSN code: -1
> I. 2009-04-28 10:45:23. QAnywhere Agent stopped
>
>
>
> I have no idea where to start looking for the cause for this error. Can
> someone point me in the right direction?


Jeff Albion [Sybase iAnywhere] Posted on 2009-04-29 20:08:05.0Z
From: "Jeff Albion [Sybase iAnywhere]" <firstname.lastname@ianywhere.com>
User-Agent: Thunderbird 2.0.0.21 (Windows/20090302)
MIME-Version: 1.0
Newsgroups: ianywhere.public.sqlanywhere.qanywhere
Subject: Re: Can't start the samples
References: <49f72681$1@forums-1-dub> <49f72821$2@forums-1-dub>
In-Reply-To: <49f72821$2@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49f8b3a5$1@forums-1-dub>
Date: 29 Apr 2009 13:08:05 -0700
X-Trace: forums-1-dub 1241035685 10.22.241.152 (29 Apr 2009 13:08:05 -0700)
X-Original-Trace: 29 Apr 2009 13:08:05 -0700, vip152.sybase.com
Lines: 59
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.sqlanywhere.qanywhere:302
Article PK: 18795

Jason,

1. Which version and build is this?

2. Does this path exist? ("C:\Program Files\SQL Anywhere 10
Deploy\Sun\jre150")

3. Is this a "default" install, or is this your own deployment?

4. How are you starting the MobiLink server? Is it a service? If a
service, is it the LOCAL SYSTEM account?

5. Can we see your environment variables that are set? (Start -> Run ->
"cmd", type "set"

6. As the documentation notes
(http://dcx.sybase.com/1101en/saerrors_en11/mlsrverrm10145.html ), you
can explicitly set a JRE path by adding "-jrepath" to the MobiLink
server's start-line inside the "-sl java()" argument:

http://dcx.sybase.com/1101en/mlserver_en11/sl-mobilink-ml-syncserver.html

Regards,

Jason 'Bug' Fenter wrote:
> Okay, I was wrong. MobiLink /isn't/ starting correctly. Error is:
>
> E. 2009-04-28 10:32:56. <Main> [-10145] Unable to access the JRE at:
> C:\Program Files\SQL Anywhere 10 Deploy\.\Sun\jre150
>
> I'm trying to find an environment variable or setting or something that
> points to my java installation. Pointers?
>
>
>
> Jason 'Bug' Fenter wrote:
>> I have SQLA 10 and SQLA 11 installed. I'm trying to start the SQLA 10
>> samples for QAnywhere. MobiLink with messaging starts correctly, but the
>> QAnywhere agent for client1 fails. In the QAnywhere window, I see:
>>
>> I. 2009-04-28 10:44:10. Client message store ID is client1
>> E. 2009-04-28 10:44:12. Failed to start QAnywhere Agent (DBMLSync)
>> E. 2009-04-28 10:44:23. Error registering with DBLSN code: -1
>> I. 2009-04-28 10:45:23. QAnywhere Agent stopped
>>
>>
>>
>> I have no idea where to start looking for the cause for this error. Can
>> someone point me in the right direction?

--
Jeff Albion, Sybase iAnywhere

iAnywhere Developer Community :
http://www.sybase.com/developer/library/sql-anywhere-techcorner
iAnywhere Documentation : http://www.ianywhere.com/developer/product_manuals
SQL Anywhere Patches and EBFs :
http://downloads.sybase.com/swd/summary.do?baseprod=144&client=ianywhere&timeframe=0
Report a Bug/Open a Case : http://case-express.sybase.com/cx/


Jason 'Bug' Fenter Posted on 2009-04-30 15:13:35.0Z
From: Jason 'Bug' Fenter <jason.fenter@teamsybase.com>
User-Agent: Thunderbird 2.0.0.21 (Windows/20090302)
MIME-Version: 1.0
Newsgroups: ianywhere.public.sqlanywhere.qanywhere
Subject: Re: Can't start the samples
References: <49f72681$1@forums-1-dub> <49f72821$2@forums-1-dub> <49f8b3a5$1@forums-1-dub>
In-Reply-To: <49f8b3a5$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49f9c01f$1@forums-1-dub>
Date: 30 Apr 2009 08:13:35 -0700
X-Trace: forums-1-dub 1241104415 10.22.241.152 (30 Apr 2009 08:13:35 -0700)
X-Original-Trace: 30 Apr 2009 08:13:35 -0700, vip152.sybase.com
Lines: 70
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.sqlanywhere.qanywhere:303
Article PK: 10513

Inline....

Jeff Albion [Sybase iAnywhere] wrote:
> Jason,
>
> 1. Which version and build is this?

SQL Anywhere MobiLink Server Version 10.0.1.3415


> 2. Does this path exist? ("C:\Program Files\SQL Anywhere 10
> Deploy\Sun\jre150")
No, nor does the directory specified.


> 3. Is this a "default" install, or is this your own deployment?
Default, but I've also "deployed" to my own machine.


> 4. How are you starting the MobiLink server? Is it a service? If a
> service, is it the LOCAL SYSTEM account?
Start > All Programs > Sybase > SQL Anywhere 10 > Mobilink > MobiLink
with Messaging Sample


> 5. Can we see your environment variables that are set? (Start -> Run ->
> "cmd", type "set"
Tedious to copy and paste, and I resolved it with #6. So, um, no? :)


> 6. As the documentation notes
> (http://dcx.sybase.com/1101en/saerrors_en11/mlsrverrm10145.html ), you
> can explicitly set a JRE path by adding "-jrepath" to the MobiLink
> server's start-line inside the "-sl java()" argument:
>
> http://dcx.sybase.com/1101en/mlserver_en11/sl-mobilink-ml-syncserver.html
That fixed it. I specified the directory to my jre6 installation and now
MobiLink is starting. Unfortunately, even with MobiLink working, I still
get the errors with the QAnywhere samples. (Identical message as stated
below.)



> Regards,
>
> Jason 'Bug' Fenter wrote:
>> Okay, I was wrong. MobiLink /isn't/ starting correctly. Error is:
>>
>> E. 2009-04-28 10:32:56. <Main> [-10145] Unable to access the JRE at:
>> C:\Program Files\SQL Anywhere 10 Deploy\.\Sun\jre150
>>
>> I'm trying to find an environment variable or setting or something that
>> points to my java installation. Pointers?
>>
>>
>>
>> Jason 'Bug' Fenter wrote:
>>> I have SQLA 10 and SQLA 11 installed. I'm trying to start the SQLA 10
>>> samples for QAnywhere. MobiLink with messaging starts correctly, but the
>>> QAnywhere agent for client1 fails. In the QAnywhere window, I see:
>>>
>>> I. 2009-04-28 10:44:10. Client message store ID is client1
>>> E. 2009-04-28 10:44:12. Failed to start QAnywhere Agent (DBMLSync)
>>> E. 2009-04-28 10:44:23. Error registering with DBLSN code: -1
>>> I. 2009-04-28 10:45:23. QAnywhere Agent stopped
>>>
>>>
>>>
>>> I have no idea where to start looking for the cause for this error. Can
>>> someone point me in the right direction?
>


Jeff Albion [Sybase iAnywhere] Posted on 2009-04-30 16:25:44.0Z
From: "Jeff Albion [Sybase iAnywhere]" <firstname.lastname@ianywhere.com>
User-Agent: Thunderbird 2.0.0.21 (Windows/20090302)
MIME-Version: 1.0
Newsgroups: ianywhere.public.sqlanywhere.qanywhere
Subject: Re: Can't start the samples
References: <49f72681$1@forums-1-dub> <49f72821$2@forums-1-dub> <49f8b3a5$1@forums-1-dub> <49f9c01f$1@forums-1-dub>
In-Reply-To: <49f9c01f$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49f9d108$1@forums-1-dub>
Date: 30 Apr 2009 09:25:44 -0700
X-Trace: forums-1-dub 1241108744 10.22.241.152 (30 Apr 2009 09:25:44 -0700)
X-Original-Trace: 30 Apr 2009 09:25:44 -0700, vip152.sybase.com
Lines: 48
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.sqlanywhere.qanywhere:304
Article PK: 18796

Jason,

Jason 'Bug' Fenter wrote:
>> 2. Does this path exist? ("C:\Program Files\SQL Anywhere 10
>> Deploy\Sun\jre150")
> No, nor does the directory specified.

>> 3. Is this a "default" install, or is this your own deployment?
> Default, but I've also "deployed" to my own machine.

I assume this is the "Deployed" version and the "Default" version lives
at "C:\Program Files\SQL Anywhere 10" ?

>> 5. Can we see your environment variables that are set? (Start -> Run ->
>> "cmd", type "set"
> Tedious to copy and paste, and I resolved it with #6. So, um, no? :)

> That fixed it. I specified the directory to my jre6 installation and now
> MobiLink is starting. Unfortunately, even with MobiLink working, I still
> get the errors with the QAnywhere samples. (Identical message as stated
> below.)
> I. 2009-04-28 10:44:10. Client message store ID is client1
> E. 2009-04-28 10:44:12. Failed to start QAnywhere Agent (DBMLSync)
> E. 2009-04-28 10:44:23. Error registering with DBLSN code: -1
> I. 2009-04-28 10:45:23. QAnywhere Agent stopped

It *sounds* like your %SQLANY10% environment variable is pointing to the
deployed version (that doesn't have the JRE deployed?), but the
engine/samples are likely assuming it to be pointing to the version
they're attempting to start. Saving posting the entire environment
variable listing, can you perhaps post the result of "echo %SQLANY10%"
from a Command Prompt?

What happens if you go to Control Panel -> System -> "Advanced" ->
Environment Variables... -> Change the value of "SQLANY10" to the
"Default" SQL Anywhere 10 path? Do they start-up successfully then?

Regards,

--
Jeff Albion, Sybase iAnywhere

iAnywhere Developer Community :
http://www.sybase.com/developer/library/sql-anywhere-techcorner
iAnywhere Documentation : http://www.ianywhere.com/developer/product_manuals
SQL Anywhere Patches and EBFs :
http://downloads.sybase.com/swd/summary.do?baseprod=144&client=ianywhere&timeframe=0
Report a Bug/Open a Case : http://case-express.sybase.com/cx/


Jason 'Bug' Fenter Posted on 2009-05-01 15:46:55.0Z
From: Jason 'Bug' Fenter <jason.fenter@teamsybase.com>
User-Agent: Thunderbird 2.0.0.21 (Windows/20090302)
MIME-Version: 1.0
Newsgroups: ianywhere.public.sqlanywhere.qanywhere
Subject: Re: Can't start the samples
References: <49f72681$1@forums-1-dub> <49f72821$2@forums-1-dub> <49f8b3a5$1@forums-1-dub> <49f9c01f$1@forums-1-dub> <49f9d108$1@forums-1-dub>
In-Reply-To: <49f9d108$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <49fb196f$1@forums-1-dub>
Date: 1 May 2009 08:46:55 -0700
X-Trace: forums-1-dub 1241192815 10.22.241.152 (1 May 2009 08:46:55 -0700)
X-Original-Trace: 1 May 2009 08:46:55 -0700, vip152.sybase.com
Lines: 45
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.sqlanywhere.qanywhere:305
Article PK: 10512

Yes, my SQLANY10 environment variable was set to the "deploy". Changing
it to the default installation fixed everything. Thanks Jeff!

Jeff Albion [Sybase iAnywhere] wrote:
> Jason,
>
> Jason 'Bug' Fenter wrote:
>>> 2. Does this path exist? ("C:\Program Files\SQL Anywhere 10
>>> Deploy\Sun\jre150")
>> No, nor does the directory specified.
>
>>> 3. Is this a "default" install, or is this your own deployment?
>> Default, but I've also "deployed" to my own machine.
>
> I assume this is the "Deployed" version and the "Default" version lives
> at "C:\Program Files\SQL Anywhere 10" ?
>
>>> 5. Can we see your environment variables that are set? (Start -> Run ->
>>> "cmd", type "set"
>> Tedious to copy and paste, and I resolved it with #6. So, um, no? :)
>
>> That fixed it. I specified the directory to my jre6 installation and now
>> MobiLink is starting. Unfortunately, even with MobiLink working, I still
>> get the errors with the QAnywhere samples. (Identical message as stated
>> below.)
>> I. 2009-04-28 10:44:10. Client message store ID is client1
>> E. 2009-04-28 10:44:12. Failed to start QAnywhere Agent (DBMLSync)
>> E. 2009-04-28 10:44:23. Error registering with DBLSN code: -1
>> I. 2009-04-28 10:45:23. QAnywhere Agent stopped
>
> It *sounds* like your %SQLANY10% environment variable is pointing to the
> deployed version (that doesn't have the JRE deployed?), but the
> engine/samples are likely assuming it to be pointing to the version
> they're attempting to start. Saving posting the entire environment
> variable listing, can you perhaps post the result of "echo %SQLANY10%"
> from a Command Prompt?
>
> What happens if you go to Control Panel -> System -> "Advanced" ->
> Environment Variables... -> Change the value of "SQLANY10" to the
> "Default" SQL Anywhere 10 path? Do they start-up successfully then?
>
> Regards,
>