Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Compile Errors on QAManager.Open()

2 posts in ,  QAnywhere .NET Winform Last posting was on 2009-05-06 20:06:00.0Z
Jason 'Bug' Fenter Posted on 2009-05-06 19:53:36.0Z
From: Jason 'Bug' Fenter <jason.fenter@teamsybase.com>
User-Agent: Thunderbird 2.0.0.21 (Windows/20090302)
MIME-Version: 1.0
Newsgroups: ianywhere.public.sqlanywhere.qanywhere,sybase.public.powerbuilder.net.winform
Subject: Compile Errors on QAManager.Open()
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4a01eac0$1@forums-1-dub>
Date: 6 May 2009 12:53:36 -0700
X-Trace: forums-1-dub 1241639616 10.22.241.152 (6 May 2009 12:53:36 -0700)
X-Original-Trace: 6 May 2009 12:53:36 -0700, vip152.sybase.com
Lines: 51
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.sqlanywhere.qanywhere:306 sybase.public.powerbuilder.net.winform:822
Article PK: 18801

I apologize for cross-posting, but the two groups are quite dissimilar.


I'm building a .NET Windows Forms app in PowerBuilder 11.5 and I'm
trying to get QAnywhere working. I can successfully instantiate a
QAManager object using:
----------
String ls_Null; SetNull (ls_Null)
iAnywhere.QAnywhere.Client.QAManager _QAManager

_QAManager =
iAnywhere.QAnywhere.Client.QAManagerFactory.Instance.CreateQAManager
(ls_Null)
----------


Unfortunately, every attempt of mine to open the manager fails. I've tried:
----------
iAnywhere.QAnywhere.Client.AcknowledgementMode AckMode
AckMode =
iAnywhere.QAnywhere.Client.AcknowledgementMode.IMPLICIT_ACKNOWLEDGEMENT

_QAManager.Open (AckMode)
----------

And with this, I receive the following error:
---------- Error messages: (2:41:34 PM)
c:\yada\qaclient2.pbl(qanywhere_manager).qanywhere_manager.initialize.11
C0051: No overload for method 'open' takes '1' arguments.
---------- Finished (2:41:34 PM)


I get the same error when I use:
----------
_QAManager.Open (1)
----------


I fail silently when I use:
----------
_QAManager.Open
(iAnywhere.QAnywhere.Client.AcknowledgementMode.IMPLICIT_ACKNOWLEDGEMENT)
----------



What confuses me is that all of the documentation that I see shows that
the Open method does, indeed, take one argument.

I'm using SQL Anywhere 10.0.1.3415 and PowerBuilder 11.5 build 3050. And
I'm using the QAnywhere assemblies for .NET Framework 2.0.


Jason 'Bug' Fenter Posted on 2009-05-06 20:06:00.0Z
From: Jason 'Bug' Fenter <jason.fenter@teamsybase.com>
User-Agent: Thunderbird 2.0.0.21 (Windows/20090302)
MIME-Version: 1.0
Newsgroups: ianywhere.public.sqlanywhere.qanywhere,sybase.public.powerbuilder.net.winform
Subject: Re: Compile Errors on QAManager.Open()
References: <4a01eac0$1@forums-1-dub>
In-Reply-To: <4a01eac0$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4a01eda8$1@forums-1-dub>
Date: 6 May 2009 13:06:00 -0700
X-Trace: forums-1-dub 1241640360 10.22.241.152 (6 May 2009 13:06:00 -0700)
X-Original-Trace: 6 May 2009 13:06:00 -0700, vip152.sybase.com
Lines: 60
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.sqlanywhere.qanywhere:307 sybase.public.powerbuilder.net.winform:823
Article PK: 18800

Nevermind! I was missing the exclamation mark after the enumeration.

_QAManager.Open
(iAnywhere.QAnywhere.Client.AcknowledgementMode.IMPLICIT_ACKNOWLEDGEMENT!)

Jason 'Bug' Fenter wrote:
> I apologize for cross-posting, but the two groups are quite dissimilar.
>
>
> I'm building a .NET Windows Forms app in PowerBuilder 11.5 and I'm
> trying to get QAnywhere working. I can successfully instantiate a
> QAManager object using:
> ----------
> String ls_Null; SetNull (ls_Null)
> iAnywhere.QAnywhere.Client.QAManager _QAManager
>
> _QAManager =
> iAnywhere.QAnywhere.Client.QAManagerFactory.Instance.CreateQAManager
> (ls_Null)
> ----------
>
>
> Unfortunately, every attempt of mine to open the manager fails. I've tried:
> ----------
> iAnywhere.QAnywhere.Client.AcknowledgementMode AckMode
> AckMode =
> iAnywhere.QAnywhere.Client.AcknowledgementMode.IMPLICIT_ACKNOWLEDGEMENT
>
> _QAManager.Open (AckMode)
> ----------
>
> And with this, I receive the following error:
> ---------- Error messages: (2:41:34 PM)
> c:\yada\qaclient2.pbl(qanywhere_manager).qanywhere_manager.initialize.11
> C0051: No overload for method 'open' takes '1' arguments.
> ---------- Finished (2:41:34 PM)
>
>
> I get the same error when I use:
> ----------
> _QAManager.Open (1)
> ----------
>
>
> I fail silently when I use:
> ----------
> _QAManager.Open
> (iAnywhere.QAnywhere.Client.AcknowledgementMode.IMPLICIT_ACKNOWLEDGEMENT)
> ----------
>
>
>
> What confuses me is that all of the documentation that I see shows that
> the Open method does, indeed, take one argument.
>
> I'm using SQL Anywhere 10.0.1.3415 and PowerBuilder 11.5 build 3050. And
> I'm using the QAnywhere assemblies for .NET Framework 2.0.