Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Problem installing Java classes

2 posts in General Discussion Last posting was on 2009-05-26 18:35:04.0Z
Jim Di Vincenzo Posted on 2009-05-21 16:59:29.0Z
Sender: 78c6.4a158663.846930886@sybase.com
From: Jim Di Vincenzo
Newsgroups: sybase.public.ase.general
Subject: Problem installing Java classes
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4a158871.78ed.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 21 May 2009 09:59:29 -0700
X-Trace: forums-1-dub 1242925169 10.22.241.41 (21 May 2009 09:59:29 -0700)
X-Original-Trace: 21 May 2009 09:59:29 -0700, 10.22.241.41
Lines: 29
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:27753
Article PK: 77038

Hi,

I am trying to install a jar file in ASE 15.0.3 (jdk1.6 on
Windows XP) and am having a problem. I have set up the java
environment, sp_configure "enable java" and "enable pci".
When I compile, and jar up the classes (using jar cf0...)
and I then issue the instjava command "instjava -update
-Setlildemo -Usa -P -f
"c:\JavaProjects\ETLFunctions\bin\etlfunctions.jar" I get
the following warning message "Server Message: ETLILDEMOVM -
Msg 10796, Level 10, State 1:
Warning! Expecting file
'com/sybase/etlfunctions/HexString.class' to contain Java
class 'com.sybase.etlfunctions.HexString'. Instead, class ''
was found. Installing the class under the correct name ''"

when I look at the sysxtypes table there is a null in
xtname.
when I try to call a function it tells me it cannot find it.


Am I missing something?

Thanks,

Jim

PS. I did not have any trouble getting this to work with
15.0.1 which only supported jdk 1.2


J Posted on 2009-05-26 18:35:04.0Z
From: jtotally_bogus@sbcglobal.net (J)
Newsgroups: sybase.public.ase.general
Subject: Re: Problem installing Java classes
Reply-To: J@bogusemailAddress.com
Message-ID: <4a1c3634.69483552@forums.sybase.com>
References: <4a158871.78ed.1681692777@sybase.com>
X-Newsreader: Forte Free Agent 1.21/32.243
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 26 May 2009 11:35:04 -0700
X-Trace: forums-1-dub 1243362904 10.22.241.152 (26 May 2009 11:35:04 -0700)
X-Original-Trace: 26 May 2009 11:35:04 -0700, vip152.sybase.com
Lines: 36
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:27796
Article PK: 77047

On 21 May 2009 09:59:29 -0700, Jim Di Vincenzo wrote:

On your setup did you run the "installpcidb" scripts?

Jay

>Hi,
>
>I am trying to install a jar file in ASE 15.0.3 (jdk1.6 on
>Windows XP) and am having a problem. I have set up the java
>environment, sp_configure "enable java" and "enable pci".
>When I compile, and jar up the classes (using jar cf0...)
>and I then issue the instjava command "instjava -update
>-Setlildemo -Usa -P -f
>"c:\JavaProjects\ETLFunctions\bin\etlfunctions.jar" I get
>the following warning message "Server Message: ETLILDEMOVM -
>Msg 10796, Level 10, State 1:
>Warning! Expecting file
>'com/sybase/etlfunctions/HexString.class' to contain Java
>class 'com.sybase.etlfunctions.HexString'. Instead, class ''
>was found. Installing the class under the correct name ''"
>
>when I look at the sysxtypes table there is a null in
>xtname.
>when I try to call a function it tells me it cannot find it.
>
>
>Am I missing something?
>
>Thanks,
>
>Jim
>
>PS. I did not have any trouble getting this to work with
>15.0.1 which only supported jdk 1.2