Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Connection to ASE15 from MS SQL Server 2005

2 posts in General Discussion Last posting was on 2009-06-23 18:34:02.0Z
George Brink Posted on 2009-06-23 18:06:13.0Z
From: George Brink <siberianowl@yahoo.com>
User-Agent: Thunderbird 2.0.0.21 (Windows/20090302)
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Connection to ASE15 from MS SQL Server 2005
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4a411995@forums-3-dub.sybase.com>
Date: 23 Jun 2009 11:06:13 -0700
X-Trace: forums-3-dub.sybase.com 1245780373 10.22.241.152 (23 Jun 2009 11:06:13 -0700)
X-Original-Trace: 23 Jun 2009 11:06:13 -0700, vip152.sybase.com
Lines: 20
Path: forums-1-dub!forums-master!forums-3-dub.sybase.com!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:27911
Article PK: 77159

Data is originated from ASE 15.0.3, it should be loaded into MS SQL
Server 2005 (do not know exact service pack number). Computer with MS
SQL Server has OpenClient from the same version as server (ASE 15.0.3
ESD#1).

Request on MSSQL:
SELECT *
FROM OPENROWSET('MSDASQL','DSN=myASE;UID=xxxxxxxxx;PWD=xxxxxxxxx',
'exec db.sis.test_sp')

fails with an error:

Msg 7357, Level 16, State 2, Line 3
Cannot process the object "exec db.sis.test_sp". The OLE DB provider
"MSDASQL" for linked server "(null)" indicates that either the object
has no columns or the current user does not have permissions on that object.

Of course procedure does have columns and user can run it. From Excel
and isql it works without any problems.
Any suggestions on what is going on with MSSQL?


J Posted on 2009-06-23 18:34:02.0Z
From: jtotally_bogus@sbcglobal.net (J)
Newsgroups: sybase.public.ase.general
Subject: Re: Connection to ASE15 from MS SQL Server 2005
Reply-To: J@bogusemailAddress.com
Message-ID: <4a411fc3.12431846@forums.sybase.com>
References: <4a411995@forums-3-dub.sybase.com>
X-Newsreader: Forte Free Agent 1.21/32.243
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 23 Jun 2009 11:34:02 -0700
X-Trace: forums-3-dub.sybase.com 1245782042 10.22.241.152 (23 Jun 2009 11:34:02 -0700)
X-Original-Trace: 23 Jun 2009 11:34:02 -0700, vip152.sybase.com
Lines: 29
Path: forums-1-dub!forums-master!forums-3-dub.sybase.com!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:27912
Article PK: 77160

On 23 Jun 2009 11:06:13 -0700, George Brink <siberianowl@yahoo.com>
wrote:

George, I would post this on sybase.public.connectivity.odbc as the
audience there is much more likely to understand the problem.

Jay

>Data is originated from ASE 15.0.3, it should be loaded into MS SQL
>Server 2005 (do not know exact service pack number). Computer with MS
>SQL Server has OpenClient from the same version as server (ASE 15.0.3
>ESD#1).
>
>Request on MSSQL:
>SELECT *
>FROM OPENROWSET('MSDASQL','DSN=myASE;UID=xxxxxxxxx;PWD=xxxxxxxxx',
> 'exec db.sis.test_sp')
>
>fails with an error:
>
>Msg 7357, Level 16, State 2, Line 3
>Cannot process the object "exec db.sis.test_sp". The OLE DB provider
>"MSDASQL" for linked server "(null)" indicates that either the object
>has no columns or the current user does not have permissions on that object.
>
>Of course procedure does have columns and user can run it. From Excel
>and isql it works without any problems.
>Any suggestions on what is going on with MSSQL?