Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

How do you get a blob column to display as a picture on the datawindow

2 posts in DataWindow Last posting was on 2009-06-25 17:41:32.0Z
Lisa Elmore Posted on 2009-06-23 19:10:14.0Z
Sender: 413b.4a3ff18b.1804289383@sybase.com
From: Lisa Elmore
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: How do you get a blob column to display as a picture on the datawindow
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4a412896.3b72.1681692777@sybase.com>
NNTP-Posting-Host: forums-3-dub.sybase.com
X-Original-NNTP-Posting-Host: forums-3-dub.sybase.com
Date: 23 Jun 2009 12:10:14 -0700
X-Trace: forums-3-dub.sybase.com 1245784214 10.22.241.188 (23 Jun 2009 12:10:14 -0700)
X-Original-Trace: 23 Jun 2009 12:10:14 -0700, forums-3-dub.sybase.com
Lines: 13
Path: forums-1-dub!forums-master!forums-3-dub.sybase.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89532
Article PK: 418722

I'm doing this in datawindow.net, but I figure the answer is
pretty close no matter if it's Powerbuilder or not. I have
posted a question in that newsgroup, but nobody's answering.
I am trying to get a column from the DB2 database to display
as a picture on my datawindow, but I keep having issues.
When I put what I think should be in the Key Clause
(:company is the retrieval argument for the datawindow)
COMPLOGO_COMPANYID = :company, I get an error SQLSTATE
42601 SQL0104N (An Unexpected taken "END OF STATEMENT" was
found following COMPLOGO_COMPANYID ...
"<row_value_constructor>"
When I just enter in a 1 instead of :company, it doesn't
give an error, but the picture is not displaying.


Annelize Posted on 2009-06-25 17:41:32.0Z
Sender: 1dd2.4a43b678.1804289383@sybase.com
From: Annelize
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: How do you get a blob column to display as a picture on the datawindow
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4a43b6cc.1e17.1681692777@sybase.com>
References: <4a412896.3b72.1681692777@sybase.com>
NNTP-Posting-Host: forums-3-dub.sybase.com
X-Original-NNTP-Posting-Host: forums-3-dub.sybase.com
Date: 25 Jun 2009 10:41:32 -0700
X-Trace: forums-3-dub.sybase.com 1245951692 10.22.241.188 (25 Jun 2009 10:41:32 -0700)
X-Original-Trace: 25 Jun 2009 10:41:32 -0700, forums-3-dub.sybase.com
Lines: 17
Path: forums-1-dub!forums-master!forums-3-dub.sybase.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89546
Article PK: 418735

Hi Lisa
Is your BLOB Ole wrapped? If it's not, then it will not
display correctly.

> I'm doing this in datawindow.net, but I figure the answer
> is pretty close no matter if it's Powerbuilder or not. I
> have posted a question in that newsgroup, but nobody's
> answering. I am trying to get a column from the DB2
> database to display as a picture on my datawindow, but I
> keep having issues. When I put what I think should be in
> the Key Clause (:company is the retrieval argument for the
> datawindow) COMPLOGO_COMPANYID = :company, I get an
> error SQLSTATE 42601 SQL0104N (An Unexpected taken "END OF
> STATEMENT" was found following COMPLOGO_COMPANYID ...
> "<row_value_constructor>"
> When I just enter in a 1 instead of :company, it doesn't
> give an error, but the picture is not displaying.