Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Afaria 6.0 with an SMS Modem connected to RS232

2 posts in General Last posting was on 2009-07-30 08:32:09.0Z
Kronawetter Posted on 2009-07-30 07:01:01.0Z
Sender: 31b6.4a7141d6.1804289383@sybase.com
From: Kronawetter
Newsgroups: ianywhere.public.afaria.general
Subject: Afaria 6.0 with an SMS Modem connected to RS232
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4a71452d.342d.1681692777@sybase.com>
MIME-Version: 1.0
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: quoted-printable
NNTP-Posting-Host: forums-3-dub.sybase.com
X-Original-NNTP-Posting-Host: forums-3-dub.sybase.com
Date: 30 Jul 2009 00:01:01 -0700
X-Trace: forums-3-dub.sybase.com 1248937261 10.22.241.188 (30 Jul 2009 00:01:01 -0700)
X-Original-Trace: 30 Jul 2009 00:01:01 -0700, forums-3-dub.sybase.com
Lines: 27
Path: forums-1-dub!forums-master!forums-3-dub.sybase.com!not-for-mail
Xref: forums-1-dub ianywhere.public.afaria.general:227
Article PK: 3158

Hello,
I´m using the Afaria Server 6.0 with an own SMS Modem.
The Modem is a Siemens TC35i and I´ve copied all
necessary files described in the manual to the Afaria folder
/bin/SMSGateway.

The TC35i is working well, I´ve checked it under
Windows when I have configured a new serial modem 9600b and
when I start a query command I got a feedback from the
Modem.

Afaria can also use this modem, I´ve configured it to
com1, set it to enabled and gateway port is at default
13000. Access phrase is test. When I run the Status test,
the modem is online and I can send SMS´s with Afaria.

Now to my problem:
When I connect a new SMS Modem from ConiuGo GPRS GSM Modem
dualband to the Server it does not work with Afaria.
I can run a query successfully in the Windows modem setup,
but Afaria has allways the status "offline" for this modem.
I restartet the Afaria Server but without success. When I
connect again the Siemens modem it works.

Does someone know why one RS232 modem works and the other
not?
Thanks for your help!


Kronawetter Posted on 2009-07-30 08:32:09.0Z
Sender: 31b6.4a7141d6.1804289383@sybase.com
From: Kronawetter
Newsgroups: ianywhere.public.afaria.general
Subject: Re: Afaria 6.0 with an SMS Modem connected to RS232
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4a715a89.44ad.1681692777@sybase.com>
References: <4a71452d.342d.1681692777@sybase.com>
MIME-Version: 1.0
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: quoted-printable
NNTP-Posting-Host: forums-3-dub.sybase.com
X-Original-NNTP-Posting-Host: forums-3-dub.sybase.com
Date: 30 Jul 2009 01:32:09 -0700
X-Trace: forums-3-dub.sybase.com 1248942729 10.22.241.188 (30 Jul 2009 01:32:09 -0700)
X-Original-Trace: 30 Jul 2009 01:32:09 -0700, forums-3-dub.sybase.com
Lines: 34
Path: forums-1-dub!forums-master!forums-3-dub.sybase.com!not-for-mail
Xref: forums-1-dub ianywhere.public.afaria.general:228
Article PK: 3159

FYI I found the problem:
The PIN of the SIM Card on the other SMS Modem was enabled.
I disabled the PIN on the SIM Card and now also the new SMS
Modem is working.

> Hello,
> I´m using the Afaria Server 6.0 with an own SMS
Modem.
> The Modem is a Siemens TC35i and I´ve copied all
> necessary files described in the manual to the Afaria
> folder /bin/SMSGateway.
>
> The TC35i is working well, I´ve checked it under
> Windows when I have configured a new serial modem 9600b
> and when I start a query command I got a feedback from the
> Modem.
>
> Afaria can also use this modem, I´ve configured it to
> com1, set it to enabled and gateway port is at default
> 13000. Access phrase is test. When I run the Status test,
> the modem is online and I can send SMS´s with Afaria.
>
> Now to my problem:
> When I connect a new SMS Modem from ConiuGo GPRS GSM Modem
> dualband to the Server it does not work with Afaria.
> I can run a query successfully in the Windows modem setup,
> but Afaria has allways the status "offline" for this
> modem. I restartet the Afaria Server but without success.
> When I connect again the Siemens modem it works.
>
> Does someone know why one RS232 modem works and the other
> not?
> Thanks for your help!