Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

autoselect on integer column does not work

9 posts in DataWindow Last posting was on 2009-09-04 14:05:40.0Z
Roz Posted on 2009-09-02 13:36:44.0Z
From: "Roz" <roz@brcf.org>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: autoselect on integer column does not work
Lines: 8
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.3790.4548
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.4325
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4a9e74ec@forums-1-dub>
Date: 2 Sep 2009 06:36:44 -0700
X-Trace: forums-1-dub 1251898604 10.22.241.152 (2 Sep 2009 06:36:44 -0700)
X-Original-Trace: 2 Sep 2009 06:36:44 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89878
Article PK: 419066

I have a grid window and when the user tabs into an integer column, the
default value of 0 does not autoselect even though the column is marked as
autoselect in the datawindow painter. The user has to delete the 0 and then
type a new integer value.

Any help?


"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel Posted on 2009-09-02 13:51:47.0Z
From: "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4a9e74ec@forums-1-dub>
Subject: Re: autoselect on integer column does not work
Lines: 20
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4a9e7873@forums-1-dub>
Date: 2 Sep 2009 06:51:47 -0700
X-Trace: forums-1-dub 1251899507 10.22.241.152 (2 Sep 2009 06:51:47 -0700)
X-Original-Trace: 2 Sep 2009 06:51:47 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89879
Article PK: 419069

What version of PB? It's working for me in 11.5.1 on a long column.
The brute force way would be to use the ItemFocusChanged event, check for
that column, and call SelectText.

--
Report Bugs: http://case-express.sybase.com/cx/welcome.do
Product Enhancement Requests:
http://my.isug.com/cgi-bin/1/c/submit_enhancement

"Roz" <roz@brcf.org> wrote in message news:4a9e74ec@forums-1-dub...
>I have a grid window and when the user tabs into an integer column, the
>default value of 0 does not autoselect even though the column is marked as
>autoselect in the datawindow painter. The user has to delete the 0 and
>then type a new integer value.
>
> Any help?
>


Roz Posted on 2009-09-03 14:40:15.0Z
From: "Roz" <roz@brcf.org>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4a9e74ec@forums-1-dub> <4a9e7873@forums-1-dub>
Subject: Re: autoselect on integer column does not work
Lines: 25
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.3790.4548
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.4325
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4a9fd54f@forums-1-dub>
Date: 3 Sep 2009 07:40:15 -0700
X-Trace: forums-1-dub 1251988815 10.22.241.152 (3 Sep 2009 07:40:15 -0700)
X-Original-Trace: 3 Sep 2009 07:40:15 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89887
Article PK: 419074

Version 11.1 build 8123

"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com> wrote in message
news:4a9e7873@forums-1-dub...
> What version of PB? It's working for me in 11.5.1 on a long column.
> The brute force way would be to use the ItemFocusChanged event, check for
> that column, and call SelectText.
>
> --
> Report Bugs: http://case-express.sybase.com/cx/welcome.do
> Product Enhancement Requests:
> http://my.isug.com/cgi-bin/1/c/submit_enhancement
>
>
> "Roz" <roz@brcf.org> wrote in message news:4a9e74ec@forums-1-dub...
>>I have a grid window and when the user tabs into an integer column, the
>>default value of 0 does not autoselect even though the column is marked as
>>autoselect in the datawindow painter. The user has to delete the 0 and
>>then type a new integer value.
>>
>> Any help?
>>
>
>


"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel Posted on 2009-09-03 15:03:58.0Z
From: "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4a9e74ec@forums-1-dub> <4a9e7873@forums-1-dub> <4a9fd54f@forums-1-dub>
Subject: Re: autoselect on integer column does not work
Lines: 37
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4a9fdade@forums-1-dub>
Date: 3 Sep 2009 08:03:58 -0700
X-Trace: forums-1-dub 1251990238 10.22.241.152 (3 Sep 2009 08:03:58 -0700)
X-Original-Trace: 3 Sep 2009 08:03:58 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89888
Article PK: 419075

I'm OK on that build also, same DW. Could there be any code unselecting it
or setting a value?

--
Report Bugs: http://case-express.sybase.com/cx/welcome.do
Product Enhancement Requests:
http://my.isug.com/cgi-bin/1/c/submit_enhancement

"Roz" <roz@brcf.org> wrote in message news:4a9fd54f@forums-1-dub...
> Version 11.1 build 8123
> "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com> wrote in message
> news:4a9e7873@forums-1-dub...
>> What version of PB? It's working for me in 11.5.1 on a long column.
>> The brute force way would be to use the ItemFocusChanged event, check for
>> that column, and call SelectText.
>>
>> --
>> Report Bugs: http://case-express.sybase.com/cx/welcome.do
>> Product Enhancement Requests:
>> http://my.isug.com/cgi-bin/1/c/submit_enhancement
>>
>>
>> "Roz" <roz@brcf.org> wrote in message news:4a9e74ec@forums-1-dub...
>>>I have a grid window and when the user tabs into an integer column, the
>>>default value of 0 does not autoselect even though the column is marked
>>>as autoselect in the datawindow painter. The user has to delete the 0
>>>and then type a new integer value.
>>>
>>> Any help?
>>>
>>
>>
>
>


Roz Posted on 2009-09-03 19:47:09.0Z
From: "Roz" <roz@brcf.org>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4a9e74ec@forums-1-dub> <4a9e7873@forums-1-dub> <4a9fd54f@forums-1-dub> <4a9fdade@forums-1-dub>
Subject: Re: autoselect on integer column does not work
Lines: 46
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.3790.4548
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.4325
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4aa01d3d$1@forums-1-dub>
Date: 3 Sep 2009 12:47:09 -0700
X-Trace: forums-1-dub 1252007229 10.22.241.152 (3 Sep 2009 12:47:09 -0700)
X-Original-Trace: 3 Sep 2009 12:47:09 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89894
Article PK: 419079

I do set that value to 0 in an itemchanged event for a column more to the
left. But why would that effect the autoselect when I tab into the integer
column more to the right?

"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com> wrote in message
news:4a9fdade@forums-1-dub...
> I'm OK on that build also, same DW. Could there be any code unselecting it
> or setting a value?
>
> --
> Report Bugs: http://case-express.sybase.com/cx/welcome.do
> Product Enhancement Requests:
> http://my.isug.com/cgi-bin/1/c/submit_enhancement
>
>
> "Roz" <roz@brcf.org> wrote in message news:4a9fd54f@forums-1-dub...
>> Version 11.1 build 8123
>> "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com> wrote in message
>> news:4a9e7873@forums-1-dub...
>>> What version of PB? It's working for me in 11.5.1 on a long column.
>>> The brute force way would be to use the ItemFocusChanged event, check
>>> for that column, and call SelectText.
>>>
>>> --
>>> Report Bugs: http://case-express.sybase.com/cx/welcome.do
>>> Product Enhancement Requests:
>>> http://my.isug.com/cgi-bin/1/c/submit_enhancement
>>>
>>>
>>> "Roz" <roz@brcf.org> wrote in message news:4a9e74ec@forums-1-dub...
>>>>I have a grid window and when the user tabs into an integer column, the
>>>>default value of 0 does not autoselect even though the column is marked
>>>>as autoselect in the datawindow painter. The user has to delete the 0
>>>>and then type a new integer value.
>>>>
>>>> Any help?
>>>>
>>>
>>>
>>
>>
>
>


"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel Posted on 2009-09-03 20:47:05.0Z
From: "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4a9e74ec@forums-1-dub> <4a9e7873@forums-1-dub> <4a9fd54f@forums-1-dub> <4a9fdade@forums-1-dub> <4aa01d3d$1@forums-1-dub>
Subject: Re: autoselect on integer column does not work
Lines: 57
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4aa02b49@forums-1-dub>
Date: 3 Sep 2009 13:47:05 -0700
X-Trace: forums-1-dub 1252010825 10.22.241.152 (3 Sep 2009 13:47:05 -0700)
X-Original-Trace: 3 Sep 2009 13:47:05 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89896
Article PK: 419083

I wouldn't expect it to either. On a hunch, try posting the SetItem.

--
Report Bugs to Sybase: http://case-express.sybase.com/cx/welcome.do
Product Enhancement Requests:
http://my.isug.com/cgi-bin/1/c/submit_enhancement

"Roz" <roz@brcf.org> wrote in message news:4aa01d3d$1@forums-1-dub...
>I do set that value to 0 in an itemchanged event for a column more to the
>left. But why would that effect the autoselect when I tab into the integer
>column more to the right?
>
>
> "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com> wrote in message
> news:4a9fdade@forums-1-dub...
>> I'm OK on that build also, same DW. Could there be any code unselecting
>> it or setting a value?
>>
>> --
>> Report Bugs: http://case-express.sybase.com/cx/welcome.do
>> Product Enhancement Requests:
>> http://my.isug.com/cgi-bin/1/c/submit_enhancement
>>
>>
>> "Roz" <roz@brcf.org> wrote in message news:4a9fd54f@forums-1-dub...
>>> Version 11.1 build 8123
>>> "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com> wrote in message
>>> news:4a9e7873@forums-1-dub...
>>>> What version of PB? It's working for me in 11.5.1 on a long column.
>>>> The brute force way would be to use the ItemFocusChanged event, check
>>>> for that column, and call SelectText.
>>>>
>>>> --
>>>> Report Bugs: http://case-express.sybase.com/cx/welcome.do
>>>> Product Enhancement Requests:
>>>> http://my.isug.com/cgi-bin/1/c/submit_enhancement
>>>>
>>>>
>>>> "Roz" <roz@brcf.org> wrote in message news:4a9e74ec@forums-1-dub...
>>>>>I have a grid window and when the user tabs into an integer column, the
>>>>>default value of 0 does not autoselect even though the column is marked
>>>>>as autoselect in the datawindow painter. The user has to delete the 0
>>>>>and then type a new integer value.
>>>>>
>>>>> Any help?
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>


Wheeley Posted on 2009-09-03 21:51:45.0Z
From: Wheeley <wheeley@ix.netcom.com>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: autoselect on integer column does not work
Message-ID: <uee0a59tslc3s5pobjfilv2gp44ndjqlt0@4ax.com>
References: <4a9e74ec@forums-1-dub> <4a9e7873@forums-1-dub> <4a9fd54f@forums-1-dub> <4a9fdade@forums-1-dub> <4aa01d3d$1@forums-1-dub>
X-Newsreader: Forte Agent 5.00/32.1171
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 3 Sep 2009 14:51:45 -0700
X-Trace: forums-1-dub 1252014705 10.22.241.152 (3 Sep 2009 14:51:45 -0700)
X-Original-Trace: 3 Sep 2009 14:51:45 -0700, vip152.sybase.com
Lines: 53
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89899
Article PK: 419087

On 3 Sep 2009 12:47:09 -0700, "Roz" <roz@brcf.org> wrote:

What column alignment do you have? Left or right justified? I have
noticed issues in the past when a column is right justified. Also do
you have an editmask on the column?

Wheeley

>I do set that value to 0 in an itemchanged event for a column more to the
>left. But why would that effect the autoselect when I tab into the integer
>column more to the right?
>
>
>"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com> wrote in message
>news:4a9fdade@forums-1-dub...
>> I'm OK on that build also, same DW. Could there be any code unselecting it
>> or setting a value?
>>
>> --
>> Report Bugs: http://case-express.sybase.com/cx/welcome.do
>> Product Enhancement Requests:
>> http://my.isug.com/cgi-bin/1/c/submit_enhancement
>>
>>
>> "Roz" <roz@brcf.org> wrote in message news:4a9fd54f@forums-1-dub...
>>> Version 11.1 build 8123
>>> "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com> wrote in message
>>> news:4a9e7873@forums-1-dub...
>>>> What version of PB? It's working for me in 11.5.1 on a long column.
>>>> The brute force way would be to use the ItemFocusChanged event, check
>>>> for that column, and call SelectText.
>>>>
>>>> --
>>>> Report Bugs: http://case-express.sybase.com/cx/welcome.do
>>>> Product Enhancement Requests:
>>>> http://my.isug.com/cgi-bin/1/c/submit_enhancement
>>>>
>>>>
>>>> "Roz" <roz@brcf.org> wrote in message news:4a9e74ec@forums-1-dub...
>>>>>I have a grid window and when the user tabs into an integer column, the
>>>>>default value of 0 does not autoselect even though the column is marked
>>>>>as autoselect in the datawindow painter. The user has to delete the 0
>>>>>and then type a new integer value.
>>>>>
>>>>> Any help?
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>


Roz Posted on 2009-09-04 12:44:26.0Z
From: "Roz" <roz@brcf.org>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4a9e74ec@forums-1-dub> <4a9e7873@forums-1-dub> <4a9fd54f@forums-1-dub> <4a9fdade@forums-1-dub> <4aa01d3d$1@forums-1-dub> <uee0a59tslc3s5pobjfilv2gp44ndjqlt0@4ax.com>
Subject: Re: autoselect on integer column does not work
Lines: 63
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.3790.4548
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.4325
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4aa10baa$1@forums-1-dub>
Date: 4 Sep 2009 05:44:26 -0700
X-Trace: forums-1-dub 1252068266 10.22.241.152 (4 Sep 2009 05:44:26 -0700)
X-Original-Trace: 4 Sep 2009 05:44:26 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89901
Article PK: 419089

No edit mask, centered

"Wheeley" <wheeley@ix.netcom.com> wrote in message
news:uee0a59tslc3s5pobjfilv2gp44ndjqlt0@4ax.com...
> On 3 Sep 2009 12:47:09 -0700, "Roz" <roz@brcf.org> wrote:
>
> What column alignment do you have? Left or right justified? I have
> noticed issues in the past when a column is right justified. Also do
> you have an editmask on the column?
>
> Wheeley
>
>>I do set that value to 0 in an itemchanged event for a column more to the
>>left. But why would that effect the autoselect when I tab into the
>>integer
>>column more to the right?
>>
>>
>>"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com> wrote in message
>>news:4a9fdade@forums-1-dub...
>>> I'm OK on that build also, same DW. Could there be any code unselecting
>>> it
>>> or setting a value?
>>>
>>> --
>>> Report Bugs: http://case-express.sybase.com/cx/welcome.do
>>> Product Enhancement Requests:
>>> http://my.isug.com/cgi-bin/1/c/submit_enhancement
>>>
>>>
>>> "Roz" <roz@brcf.org> wrote in message news:4a9fd54f@forums-1-dub...
>>>> Version 11.1 build 8123
>>>> "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com> wrote in
>>>> message
>>>> news:4a9e7873@forums-1-dub...
>>>>> What version of PB? It's working for me in 11.5.1 on a long column.
>>>>> The brute force way would be to use the ItemFocusChanged event, check
>>>>> for that column, and call SelectText.
>>>>>
>>>>> --
>>>>> Report Bugs: http://case-express.sybase.com/cx/welcome.do
>>>>> Product Enhancement Requests:
>>>>> http://my.isug.com/cgi-bin/1/c/submit_enhancement
>>>>>
>>>>>
>>>>> "Roz" <roz@brcf.org> wrote in message news:4a9e74ec@forums-1-dub...
>>>>>>I have a grid window and when the user tabs into an integer column,
>>>>>>the
>>>>>>default value of 0 does not autoselect even though the column is
>>>>>>marked
>>>>>>as autoselect in the datawindow painter. The user has to delete the 0
>>>>>>and then type a new integer value.
>>>>>>
>>>>>> Any help?
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>


Roz Posted on 2009-09-04 14:05:40.0Z
From: "Roz" <roz@brcf.org>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4a9e74ec@forums-1-dub> <4a9e7873@forums-1-dub> <4a9fd54f@forums-1-dub>
Subject: Re: autoselect on integer column does not work
Lines: 33
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.3790.4548
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.4325
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4aa11eb4$1@forums-1-dub>
Date: 4 Sep 2009 07:05:40 -0700
X-Trace: forums-1-dub 1252073140 10.22.241.152 (4 Sep 2009 07:05:40 -0700)
X-Original-Trace: 4 Sep 2009 07:05:40 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89902
Article PK: 419090

Turns out that sometime I set the "cell" in the itemchanged event of the
cell just to the left of the integer cell. In a ue_dw_post_itemchanged
event I set the column to the cell I want and do a selecttext. Works fine.

Thanks all..

"Roz" <roz@brcf.org> wrote in message news:4a9fd54f@forums-1-dub...
> Version 11.1 build 8123
> "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com> wrote in message
> news:4a9e7873@forums-1-dub...
>> What version of PB? It's working for me in 11.5.1 on a long column.
>> The brute force way would be to use the ItemFocusChanged event, check for
>> that column, and call SelectText.
>>
>> --
>> Report Bugs: http://case-express.sybase.com/cx/welcome.do
>> Product Enhancement Requests:
>> http://my.isug.com/cgi-bin/1/c/submit_enhancement
>>
>>
>> "Roz" <roz@brcf.org> wrote in message news:4a9e74ec@forums-1-dub...
>>>I have a grid window and when the user tabs into an integer column, the
>>>default value of 0 does not autoselect even though the column is marked
>>>as autoselect in the datawindow painter. The user has to delete the 0
>>>and then type a new integer value.
>>>
>>> Any help?
>>>
>>
>>
>
>