Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

AppName in SQLCA.DBParm

2 posts in General Discussion (Chinese) Last posting was on 2010-01-08 19:52:12.0Z
David Posted on 2009-09-02 16:08:33.0Z
Sender: 584b.4a9e9497.1804289383@sybase.com
From: David
Newsgroups: sybase.public.chinese.powerbuilder.general
Subject: AppName in SQLCA.DBParm
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4a9e9881.58fa.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 2 Sep 2009 09:08:33 -0700
X-Trace: forums-1-dub 1251907713 10.22.241.41 (2 Sep 2009 09:08:33 -0700)
X-Original-Trace: 2 Sep 2009 09:08:33 -0700, 10.22.241.41
Lines: 17
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.chinese.powerbuilder.general:488
Article PK: 104512

Hi,

I'd like to pass AppName value to SQL Server connection in
order to query the MASTER.DBO.SYSPROCESSES table.
I've specified a value before connecting SQLCA but no
success : SQL SERVER see always program_name as
"PowerBuilder"

Here is the connecting string of my SQLCA :

APPNAME='myapp',PROVIDER='SQLOLEDB',DATASOURCE='srvxxx',PROVIDERSTRING='database=mydbname'

Is there a probleme with PB 10 ? does it set default value
always to "PowerBuilder" ? can't we force it ?

Thanks for your help
David


Luis Posted on 2010-01-08 19:52:12.0Z
From: "Luis" <luis.obradovich@us.ing.com>
Newsgroups: sybase.public.chinese.powerbuilder.general
Organization: 65.90.232.2
References: <4a9e9881.58fa.1681692777@sybase.com>
X-Newsreader: AspNNTP 1.50 (JodoHost)
Subject: Re: AppName in SQLCA.DBParm
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b478cec$1@forums-1-dub>
Date: 8 Jan 2010 11:52:12 -0800
X-Trace: forums-1-dub 1262980332 10.22.241.152 (8 Jan 2010 11:52:12 -0800)
X-Original-Trace: 8 Jan 2010 11:52:12 -0800, vip152.sybase.com
Lines: 26
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.chinese.powerbuilder.general:500
Article PK: 104523

On 2 Sep 2009 09:08:33 -0700,
in sybase.public.chinese.powerbuilder.general

<David> wrote:
>Hi,
>
>I'd like to pass AppName value to SQL Server connection in
>order to query the MASTER.DBO.SYSPROCESSES table.
>I've specified a value before connecting SQLCA but no
>success : SQL SERVER see always program_name as
>"PowerBuilder"
>
>Here is the connecting string of my SQLCA :
>
>APPNAME='myapp',PROVIDER='SQLOLEDB',DATASOURCE='srvxxx',PROVIDERSTRING='databas
e=mydbname'
>
>Is there a probleme with PB 10 ? does it set default value
>always to "PowerBuilder" ? can't we force it ?
>
>Thanks for your help
>David

We are using pb 5 believe it or not an we pass the appname and a hidden
character in the string to inforce security and works for us. I've asked the DBA
if they have to configured Sybase to receive it but they don't do anything.
Sorry.