Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Why SA11 won't upgrade some ASA9 Databases. Solution Found!

3 posts in General Discussion (old) Last posting was on 2009-09-23 18:41:38.0Z
Glenn Barber Posted on 2009-09-23 04:19:39.0Z
From: "Glenn Barber" <gabarber_nocanspam@graymatterllc.com>
Newsgroups: sybase.public.sqlanywhere
Subject: Why SA11 won't upgrade some ASA9 Databases. Solution Found!
Lines: 17
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4ab9a1db$1@forums-1-dub>
Date: 22 Sep 2009 21:19:39 -0700
X-Trace: forums-1-dub 1253679579 10.22.241.152 (22 Sep 2009 21:19:39 -0700)
X-Original-Trace: 22 Sep 2009 21:19:39 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sqlanywhere:297
Article PK: 866730

I have been having issues upgrading customers ASA9 databases to SA11. In
many cases the instructions on how to upgrade the the Version 9 databases
failed with the database unable to start with the V11 dnunload.

After working with support for a hour or so we located the issue. We were
trying to upgrade the databases using the SQL Central Image Database Backups
from V9. In Version 9 these backsups look on disk and behave exactly like
the original.

However the V11 dbunload utility will not start them. The solution is to
startup ASA9 and startup the database file then stop it. Then the file can
be properly started and unloaded using the V11 dbunload.

This did not seem to be a problem in the V10 upgrade.


Volker Barth <No_VBarth Posted on 2009-09-23 08:51:54.0Z
From: Volker Barth <No_VBarth@Spam_GLOBAL-FINANZ.de>
User-Agent: Thunderbird 2.0.0.23 (Windows/20090812)
MIME-Version: 1.0
Newsgroups: sybase.public.sqlanywhere
Subject: Re: Why SA11 won't upgrade some ASA9 Databases. Solution Found!
References: <4ab9a1db$1@forums-1-dub>
In-Reply-To: <4ab9a1db$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4ab9e1aa$1@forums-1-dub>
Date: 23 Sep 2009 01:51:54 -0700
X-Trace: forums-1-dub 1253695914 10.22.241.152 (23 Sep 2009 01:51:54 -0700)
X-Original-Trace: 23 Sep 2009 01:51:54 -0700, vip152.sybase.com
Lines: 49
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sqlanywhere:298
Article PK: 866731

Glenn,

AFAIK there has been an issue with upgrading V9 (and older) databases to
V10/V11 when these databases come from a backup.

In case of a backup, an automatic recovery may be neccessary to apply
outstanding transactions that are part of the backup's transaction log.
The original V10/V11 upgrade process is not able to do automatic
recovery on a pre-V10 database, and so the upgrade fails.

A workaround is to upgrade a "clean database", e.g. by shutting down the
database and then use a copy of the original files to upgrade. That's
exactly what you have done:)


I think the bugfix is reported here:

================(Build #2268 - Engineering Case 578153)================

If a database created with a version 9 or earlier server was backed up
via the Backup utility (dbbackup), or the BACKUP DATABASE statement, the
backup copy could not have been unloaded using the Unload utility from
version 10 or later. This has been fixed.


HTH
Volker

Glenn Barber wrote:
> I have been having issues upgrading customers ASA9 databases to SA11. In
> many cases the instructions on how to upgrade the the Version 9 databases
> failed with the database unable to start with the V11 dnunload.
>
> After working with support for a hour or so we located the issue. We were
> trying to upgrade the databases using the SQL Central Image Database Backups
> from V9. In Version 9 these backsups look on disk and behave exactly like
> the original.
>
> However the V11 dbunload utility will not start them. The solution is to
> startup ASA9 and startup the database file then stop it. Then the file can
> be properly started and unloaded using the V11 dbunload.
>
> This did not seem to be a problem in the V10 upgrade.
>
>
>


Glenn Barber Posted on 2009-09-23 18:41:38.0Z
From: "Glenn Barber" <gabarber_nocanspam@graymatterllc.com>
Newsgroups: sybase.public.sqlanywhere
References: <4ab9a1db$1@forums-1-dub> <4ab9e1aa$1@forums-1-dub>
Subject: Re: Why SA11 won't upgrade some ASA9 Databases. Solution Found!
Lines: 59
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4aba6be2$1@forums-1-dub>
Date: 23 Sep 2009 11:41:38 -0700
X-Trace: forums-1-dub 1253731298 10.22.241.152 (23 Sep 2009 11:41:38 -0700)
X-Original-Trace: 23 Sep 2009 11:41:38 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sqlanywhere:299
Article PK: 866732

It was interesting that yesterday iAnywhere support seemed not to be aware
of this issue. We spent at least an hour experimenting until we discovered
the problem.

Thanks for the confirmation.

"Volker Barth" <No_VBarth@Spam_GLOBAL-FINANZ.de> wrote in message
news:4ab9e1aa$1@forums-1-dub...
> Glenn,
>
> AFAIK there has been an issue with upgrading V9 (and older) databases to
> V10/V11 when these databases come from a backup.
>
> In case of a backup, an automatic recovery may be neccessary to apply
> outstanding transactions that are part of the backup's transaction log.
> The original V10/V11 upgrade process is not able to do automatic recovery
> on a pre-V10 database, and so the upgrade fails.
>
> A workaround is to upgrade a "clean database", e.g. by shutting down the
> database and then use a copy of the original files to upgrade. That's
> exactly what you have done:)
>
>
> I think the bugfix is reported here:
>
> ================(Build #2268 - Engineering Case 578153)================
>
> If a database created with a version 9 or earlier server was backed up via
> the Backup utility (dbbackup), or the BACKUP DATABASE statement, the
> backup copy could not have been unloaded using the Unload utility from
> version 10 or later. This has been fixed.
>
>
> HTH
> Volker
>
>
>
>
> Glenn Barber wrote:
>> I have been having issues upgrading customers ASA9 databases to SA11. In
>> many cases the instructions on how to upgrade the the Version 9 databases
>> failed with the database unable to start with the V11 dnunload.
>>
>> After working with support for a hour or so we located the issue. We
>> were trying to upgrade the databases using the SQL Central Image Database
>> Backups from V9. In Version 9 these backsups look on disk and behave
>> exactly like the original.
>>
>> However the V11 dbunload utility will not start them. The solution is to
>> startup ASA9 and startup the database file then stop it. Then the file
>> can be properly started and unloaded using the V11 dbunload.
>>
>> This did not seem to be a problem in the V10 upgrade.
>>
>>