Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

number of open partitions Missing and causing upgrade to fail

7 posts in General Discussion Last posting was on 2009-10-08 01:41:50.0Z
Jim Dawks Posted on 2009-10-06 09:14:01.0Z
Sender: 67b5.4acaa132.1804289383@sybase.com
From: Jim Dawks
Newsgroups: sybase.public.ase.general
Subject: number of open partitions Missing and causing upgrade to fail
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4acb0a59.779e.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 6 Oct 2009 02:14:01 -0700
X-Trace: forums-1-dub 1254820441 10.22.241.41 (6 Oct 2009 02:14:01 -0700)
X-Original-Trace: 6 Oct 2009 02:14:01 -0700, 10.22.241.41
Lines: 118
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28407
Article PK: 77650

Hello. I am trying to upgrade a linux ASE 12.5.3 to ASE
15.03

I am getting no problems with the preupgrade.

The upgrade though is failling due to the following related
matter.

2> sp_countmetadata "number of open partitions"
3> go
Configuration option doesn't exist.
(return status = 1)
1> sp_configure "number"
2> go
Msg 17411, Level 16, State 1:
Server 'sybase', Procedure 'sp_configure', Line 209:
Configuration option is not unique.

Parameter Name Default Memory Used
Config Value
Run Value Unit Type
------------------------------ ----------- -----------
------------
----------- -------------------- ----------
global cache partition number 1 0
1
1 number static
max number network listeners 5 863
5
5 number dynamic
number of alarms 40 4
40
40 number dynamic
number of aux scan descriptors 200 #290
256
256 number dynamic
number of ccbs 0 0
0
0 number static
number of checkpoint tasks 1 0
1
1 number dynamic
number of devices 10 #10
10
10 number dynamic
number of dtx participants 500 146
500
500 number dynamic
number of dump threads 1 0
1
1 number dynamic
number of engines at startup 1 0
1
1 number static
number of histogram steps 20 0
20
20 number dynamic
number of index trips 0 0
0
0 number dynamic
number of java sockets 0 0
0
0 number dynamic
number of large i/o buffers 6 24616
6
6 number dynamic
number of locks 5000 1456
10000
10000 number dynamic
number of mailboxes 30 6
30
30 number dynamic
number of messages 64 6
64
64 number dynamic
number of oam trips 0 0
0
0 number dynamic
number of open databases 12 1584
12
12 number dynamic
number of open indexes 500 592
500
500 number dynamic
number of open objects 500 719
500
500 number dynamic
number of pre-allocated extent 2 0
2
2 number dynamic
number of remote connections 20 33
20
20 number static
number of remote logins 20 22
20
20 number static
number of remote sites 10 1727
10
10 number static
number of sort buffers 500 0
500
500 number dynamic
number of user connections 25 4312
25
25 number dynamic
number of worker processes 0 0
0
0 number dynamic
syb_sendmsg port number 0 0
0

I ask a two fold question as to why this is missing and how
do I add it in(and possible other missing configuration
parts) so as to satisfy the upgrade procedure.

Thank you considerably for the time vested,

Jim


Jim Dawks Posted on 2009-10-06 10:07:43.0Z
Sender: 67b5.4acaa132.1804289383@sybase.com
From: Jim Dawks
Newsgroups: sybase.public.ase.general
Subject: Re: number of open partitions Missing and causing upgrade to fail
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4acb16ef.7a2c.1681692777@sybase.com>
References: <4acb0a59.779e.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 6 Oct 2009 03:07:43 -0700
X-Trace: forums-1-dub 1254823663 10.22.241.41 (6 Oct 2009 03:07:43 -0700)
X-Original-Trace: 6 Oct 2009 03:07:43 -0700, 10.22.241.41
Lines: 274
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28408
Article PK: 77651


> Hello. I am trying to upgrade a linux ASE 12.5.3 to ASE
> 15.03
>
> I am getting no problems with the preupgrade.
>
> The upgrade though is failling due to the following
> related matter.
>
> 2> sp_countmetadata "number of open partitions"
> 3> go
> Configuration option doesn't exist.
> (return status = 1)
> 1> sp_configure "number"
> 2> go
> Msg 17411, Level 16, State 1:
> Server 'sybase', Procedure 'sp_configure', Line 209:
> Configuration option is not unique.
>
> Parameter Name Default Memory Used
> Config Value
> Run Value Unit Type
> ------------------------------ ----------- -----------
> ------------
> ----------- -------------------- ----------
> global cache partition number 1 0
>
> 1
> 1 number static
> max number network listeners 5 863
>
> 5
> 5 number dynamic
> number of alarms 40 4
>
> 40
> 40 number dynamic
> number of aux scan descriptors 200 #290
>
> 256
> 256 number dynamic
> number of ccbs 0 0
>
> 0
> 0 number static
> number of checkpoint tasks 1 0
>
> 1
> 1 number dynamic
> number of devices 10 #10
>
> 10
> 10 number dynamic
> number of dtx participants 500 146
>
> 500
> 500 number dynamic
> number of dump threads 1 0
>
> 1
> 1 number dynamic
> number of engines at startup 1 0
>
> 1
> 1 number static
> number of histogram steps 20 0
>
> 20
> 20 number dynamic
> number of index trips 0 0
>
> 0
> 0 number dynamic
> number of java sockets 0 0
>
> 0
> 0 number dynamic
> number of large i/o buffers 6 24616
>
> 6
> 6 number dynamic
> number of locks 5000 1456
>
> 10000
> 10000 number dynamic
> number of mailboxes 30 6
>
> 30
> 30 number dynamic
> number of messages 64 6
>
> 64
> 64 number dynamic
> number of oam trips 0 0
>
> 0
> 0 number dynamic
> number of open databases 12 1584
>
> 12
> 12 number dynamic
> number of open indexes 500 592
>
> 500
> 500 number dynamic
> number of open objects 500 719
>
> 500
> 500 number dynamic
> number of pre-allocated extent 2 0
>
> 2
> 2 number dynamic
> number of remote connections 20 33
>
> 20
> 20 number static
> number of remote logins 20 22
>
> 20
> 20 number static
> number of remote sites 10 1727
>
> 10
> 10 number static
> number of sort buffers 500 0
>
> 500
> 500 number dynamic
> number of user connections 25 4312
>
> 25
> 25 number dynamic
> number of worker processes 0 0
>
> 0
> 0 number dynamic
> syb_sendmsg port number 0 0
>
> 0
>
> I ask a two fold question as to why this is missing and
> how do I add it in(and possible other missing
> configuration parts) so as to satisfy the upgrade
> procedure.
>
> Thank you considerably for the time vested,
>
> Jim

I hope this further bit can help...
Does atleast explain why it's deleting my line from my .cfg
thx

Name Num_free Num_active Pct_act
Max_Used
Num_Reuse
------------------------- ----------- ----------- -------
-----------
-----------
additional network memory 601244 157056 20.71
157056
0
audit queue size 100 0 0.00
0
0
disk i/o structures 256 0 0.00
149
0
heap memory per user 4096 0 0.00
0
0
max cis remote connection 100 0 0.00
0
0
max memory 22325 41675 65.12
41675
0
max number network listen 4 1 20.00
1
0
max online engines 0 1 100.00
1
0
memory per worker process 1024 0 0.00
0
0
number of alarms 30 10 25.00
10
0
number of aux scan descri 256 0 0.00
0
0
number of devices 8 2 20.00
2
0
number of dtx participant 500 0 0.00
0
0
number of java sockets 50 0 0.00
0
0
number of large i/o buffe 6 0 0.00
1
0
number of locks 9905 95 0.95
107
0
number of mailboxes 29 1 3.33
1
0
number of messages 64 0 0.00
0
0
number of open databases 6 6 50.00
6
0
number of open indexes 495 5 1.00
5
0
number of open objects 494 6 1.20
6
0
number of remote connecti 20 0 0.00
1
0
number of remote logins 20 0 0.00
0
0
number of remote sites 10 0 0.00
1
0
number of sort buffers 500 0 0.00
0
0
number of user connection 24 1 4.00
1
0
number of worker processe 0 0 0.00
0
0
partition groups 1024 0 0.00
0
0
permission cache entries 15 0 0.00
0
0
procedure cache size 11680 320 2.67
448
0
size of global fixed heap 150 0 0.00
0
0
size of process object he 1500 0 0.00
0
0
size of shared class heap 1536 0 0.00
0
0
size of unilib cache 118874 512 0.43
512
0
txn to pss ratio 400 0 0.00
0
0
(return status = 0)


00:00000:00000:2009/10/06 08:48:14.64 server Warning:
Unknown parameter ' number of open partitions =
DEFAULT
' found on line '45' of configuration file
'/home/sybase/ASE-12_5/sybase.cfg'. This parameter is
ignored. Edit the configuration file to remove or correct
this parameter.


"Mark A. Parsons" <iron_horse Posted on 2009-10-06 13:53:05.0Z
From: "Mark A. Parsons" <iron_horse@no_spamola.compuserve.com>
User-Agent: Thunderbird 1.5.0.10 (Windows/20070221)
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: number of open partitions Missing and causing upgrade to fail
References: <4acb0a59.779e.1681692777@sybase.com>
In-Reply-To: <4acb0a59.779e.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Antivirus: avast! (VPS 091004-0, 10/04/2009), Outbound message
X-Antivirus-Status: Clean
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4acb4bc1$1@forums-1-dub>
Date: 6 Oct 2009 06:53:05 -0700
X-Trace: forums-1-dub 1254837185 10.22.241.152 (6 Oct 2009 06:53:05 -0700)
X-Original-Trace: 6 Oct 2009 06:53:05 -0700, vip152.sybase.com
Lines: 131
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28410
Article PK: 77654

Sounds like some part of the upgrade process failed. I'd suggest you go back through the upgrade logs to see where the
problem occurred. (See the ASE errorlog, and $SYBASE/ASE-15_0/init/logs/log* files.)

While you could patch the system by adding the appropriate 'number of open partitions' entries to your *.cfg file as
well as the sysconfigures/syscurconfigs tables, this wouldn't address any other issues that may result from the failed
upgrade.

It may be possible to re-run the upgrade process, but that'll depend on the reason for the failure. See the ASE Install
guide, chapter on Troubleshooting, sub-section on Recovering from a failed upgrade. Alternatively, contact Sybase
TechSupport.

Jim Dawks wrote:
> Hello. I am trying to upgrade a linux ASE 12.5.3 to ASE
> 15.03
>
> I am getting no problems with the preupgrade.
>
> The upgrade though is failling due to the following related
> matter.
>
> 2> sp_countmetadata "number of open partitions"
> 3> go
> Configuration option doesn't exist.
> (return status = 1)
> 1> sp_configure "number"
> 2> go
> Msg 17411, Level 16, State 1:
> Server 'sybase', Procedure 'sp_configure', Line 209:
> Configuration option is not unique.
>
> Parameter Name Default Memory Used
> Config Value
> Run Value Unit Type
> ------------------------------ ----------- -----------
> ------------
> ----------- -------------------- ----------
> global cache partition number 1 0
> 1
> 1 number static
> max number network listeners 5 863
> 5
> 5 number dynamic
> number of alarms 40 4
> 40
> 40 number dynamic
> number of aux scan descriptors 200 #290
> 256
> 256 number dynamic
> number of ccbs 0 0
> 0
> 0 number static
> number of checkpoint tasks 1 0
> 1
> 1 number dynamic
> number of devices 10 #10
> 10
> 10 number dynamic
> number of dtx participants 500 146
> 500
> 500 number dynamic
> number of dump threads 1 0
> 1
> 1 number dynamic
> number of engines at startup 1 0
> 1
> 1 number static
> number of histogram steps 20 0
> 20
> 20 number dynamic
> number of index trips 0 0
> 0
> 0 number dynamic
> number of java sockets 0 0
> 0
> 0 number dynamic
> number of large i/o buffers 6 24616
> 6
> 6 number dynamic
> number of locks 5000 1456
> 10000
> 10000 number dynamic
> number of mailboxes 30 6
> 30
> 30 number dynamic
> number of messages 64 6
> 64
> 64 number dynamic
> number of oam trips 0 0
> 0
> 0 number dynamic
> number of open databases 12 1584
> 12
> 12 number dynamic
> number of open indexes 500 592
> 500
> 500 number dynamic
> number of open objects 500 719
> 500
> 500 number dynamic
> number of pre-allocated extent 2 0
> 2
> 2 number dynamic
> number of remote connections 20 33
> 20
> 20 number static
> number of remote logins 20 22
> 20
> 20 number static
> number of remote sites 10 1727
> 10
> 10 number static
> number of sort buffers 500 0
> 500
> 500 number dynamic
> number of user connections 25 4312
> 25
> 25 number dynamic
> number of worker processes 0 0
> 0
> 0 number dynamic
> syb_sendmsg port number 0 0
> 0
>
> I ask a two fold question as to why this is missing and how
> do I add it in(and possible other missing configuration
> parts) so as to satisfy the upgrade procedure.
>
> Thank you considerably for the time vested,
>
> Jim


Jim Dawks Posted on 2009-10-07 11:58:38.0Z
Sender: 67b5.4acaa132.1804289383@sybase.com
From: Jim Dawks
Newsgroups: sybase.public.ase.general
Subject: Re: number of open partitions Missing and causing upgrade to fail
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4acc826e.3d2e.1681692777@sybase.com>
References: <4acb0a59.779e.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 7 Oct 2009 04:58:38 -0700
X-Trace: forums-1-dub 1254916718 10.22.241.41 (7 Oct 2009 04:58:38 -0700)
X-Original-Trace: 7 Oct 2009 04:58:38 -0700, 10.22.241.41
Lines: 11
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28418
Article PK: 77661

The error during the upgrade is:

*** Error 20: upgrade: no row returned from
syscurconfigs for config number 408
*** Error 41: Could not obtain configured value for
'number of open partitions' from syscurconfigs.

That is specifically the issue and thus far the sole issue
we are experiencing.

Jim


Sherlock, Kevin [TeamSybase] Posted on 2009-10-07 20:19:45.0Z
From: "Sherlock, Kevin [TeamSybase]" <kevin.sherlock@teamsybase.com>
Newsgroups: sybase.public.ase.general
References: <4acb0a59.779e.1681692777@sybase.com> <4acc826e.3d2e.1681692777@sybase.com>
Subject: Re: number of open partitions Missing and causing upgrade to fail
Lines: 19
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4accf7e1@forums-1-dub>
Date: 7 Oct 2009 13:19:45 -0700
X-Trace: forums-1-dub 1254946785 10.22.241.152 (7 Oct 2009 13:19:45 -0700)
X-Original-Trace: 7 Oct 2009 13:19:45 -0700, vip152.sybase.com
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28429
Article PK: 77672

more than likely, somewhere along the way, the
$SYBASE/$SYBASE_ASE/scripts/installmaster wasn't run after an upgrade/EBF
patch. Do you have a historical record of what versions of ASE you've
upgraded in place to in the past?

<Jim Dawks> wrote in message news:4acc826e.3d2e.1681692777@sybase.com...
> The error during the upgrade is:
>
> *** Error 20: upgrade: no row returned from
> syscurconfigs for config number 408
> *** Error 41: Could not obtain configured value for
> 'number of open partitions' from syscurconfigs.
>
> That is specifically the issue and thus far the sole issue
> we are experiencing.
>
> Jim


Sherlock, Kevin [TeamSybase] Posted on 2009-10-07 20:25:01.0Z
From: "Sherlock, Kevin [TeamSybase]" <kevin.sherlock@teamsybase.com>
Newsgroups: sybase.public.ase.general
References: <4acb0a59.779e.1681692777@sybase.com> <4acc826e.3d2e.1681692777@sybase.com> <4accf7e1@forums-1-dub>
Subject: Re: number of open partitions Missing and causing upgrade to fail
Lines: 27
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4accf91d$1@forums-1-dub>
Date: 7 Oct 2009 13:25:01 -0700
X-Trace: forums-1-dub 1254947101 10.22.241.152 (7 Oct 2009 13:25:01 -0700)
X-Original-Trace: 7 Oct 2009 13:25:01 -0700, vip152.sybase.com
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28430
Article PK: 77673

never mind. I now note that you opened a new thread named "Old Releases
Needed!". Fixing an ASE that didn't get upgraded correctly can get messy,
but I'll leave the advice on this to those helping you in that thread.

"Sherlock, Kevin [TeamSybase]" <kevin.sherlock@teamsybase.com> wrote in
message news:4accf7e1@forums-1-dub...
> more than likely, somewhere along the way, the
> $SYBASE/$SYBASE_ASE/scripts/installmaster wasn't run after an upgrade/EBF
> patch. Do you have a historical record of what versions of ASE you've
> upgraded in place to in the past?
>
> <Jim Dawks> wrote in message news:4acc826e.3d2e.1681692777@sybase.com...
>> The error during the upgrade is:
>>
>> *** Error 20: upgrade: no row returned from
>> syscurconfigs for config number 408
>> *** Error 41: Could not obtain configured value for
>> 'number of open partitions' from syscurconfigs.
>>
>> That is specifically the issue and thus far the sole issue
>> we are experiencing.
>>
>> Jim
>
>


Vivek Kak Posted on 2009-10-08 01:41:50.0Z
Sender: 3082.4acc3ff7.1804289383@sybase.com
From: Vivek Kak
Newsgroups: sybase.public.ase.general
Subject: Re: number of open partitions Missing and causing upgrade to fail
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4acd435e.5dbc.1681692777@sybase.com>
References: <4accf91d$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 7 Oct 2009 18:41:50 -0700
X-Trace: forums-1-dub 1254966110 10.22.241.41 (7 Oct 2009 18:41:50 -0700)
X-Original-Trace: 7 Oct 2009 18:41:50 -0700, 10.22.241.41
Lines: 73
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28435
Article PK: 77678

Hi Jim,

I also ran across the same issue when upgrading from 12.5.4
ESD#8 (HP Itanium) to 15.0.2 ESD#6. Though my upgrade
process did run across some issues like failed attempt to
insert rows for 15 specific roles.

While doing inplace upgrade , I got msg "beginning upgrade
step [ID 245]: Update system roles in system tables. ***
Adaptive Server message 12587, state 1, severity 20: ***
Initialization of sysroles and sysusers in database failed
due to missing system role 'webservices_role' in
master..syssrvroles."

This was happening for all databases including master.
However, after installmaster is run as part of inplace
upgrade, the role is added syssrvroles and we see that entry
for the role is present. After inplace upgrade utility is
complete, I observed the verion of sybase as 15.0.2 ESD#6.

But on further checks observed that config parameters
specific to ASE 15 were missing.

When I opened case with Sybase Tech Support, they
acknowledged that this was a bug in previous versions and
looks like this has creeped up again.

For me the resolution was to bcp in the sysconfigures from a
good 15.0.2 ESD#6 instance with -b1 option.

But before this you need to make sure that your all
databases individually are upgraded to version 15 and it is
issue only with missing config parameters.

You can check the upgrade version of each database by
executing the below queries:
dbcc traceon(3604)
dbcc dbtable("dbname")
go

You should see the following for user db's

dbt_dbinfobuf.dbi_logvers=7
dbt_dbinfobuf.dbi_upgdvers=35 ... .
dbi_upgd_minor=1554
And for master dbi_upgd_minor=1560

But those values are specific to ASE 15.0.2 ESD#6. I do not
have a 15.0.3 instance available right now.

In the meantime, I suggest to open a case with Sybase Tech
support.


HTH,
Vivek

> > <Jim Dawks> wrote in message
> news:4acc826e.3d2e.1681692777@sybase.com... >> The error
> during the upgrade is: >>
> >> *** Error 20: upgrade: no row returned from
> >> syscurconfigs for config number 408
> >> *** Error 41: Could not obtain configured value for
> >> 'number of open partitions' from syscurconfigs.
> >>
> >> That is specifically the issue and thus far the sole
> issue >> we are experiencing.
> >>
> >> Jim
> >
> >
>
>