Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Can't pass a varchar into a proc on ASE 12.5.4

2 posts in General Discussion Last posting was on 2009-11-04 16:14:56.0Z
Liezl Posted on 2009-11-04 15:39:04.0Z
Sender: 4650.4af1981d.846930886@sybase.com
From: Liezl
Newsgroups: sybase.public.ase.general
Subject: Can't pass a varchar into a proc on ASE 12.5.4
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4af1a018.4764.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 4 Nov 2009 07:39:04 -0800
X-Trace: forums-1-dub 1257349144 10.22.241.41 (4 Nov 2009 07:39:04 -0800)
X-Original-Trace: 4 Nov 2009 07:39:04 -0800, 10.22.241.41
Lines: 12
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28605
Article PK: 77847

Using Sybase 12.5.4 and have written a query using Windows
Reporting Services 2000. The problem that I am getting is
that I am unable to pass strings into stored procs that are
residing on my server. I get "An error has occured during
report processing. Query Execution failed for data set
'trader'. The given type name was unrecognized.

It also doesn't work from the Windows Reporting Service
through ODBC. However it works from an ISQL session through
ODBC.
Any ideas...


J Posted on 2009-11-04 16:14:56.0Z
From: jtotally_bogus@sbcglobal.net (J)
Newsgroups: sybase.public.ase.general
Subject: Re: Can't pass a varchar into a proc on ASE 12.5.4
Reply-To: J@bogusemailAddress.com
Message-ID: <4af1a696.1081054@forums.sybase.com>
References: <4af1a018.4764.1681692777@sybase.com>
X-Newsreader: Forte Free Agent 1.21/32.243
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 4 Nov 2009 08:14:56 -0800
X-Trace: forums-1-dub 1257351296 10.22.241.152 (4 Nov 2009 08:14:56 -0800)
X-Original-Trace: 4 Nov 2009 08:14:56 -0800, vip152.sybase.com
Lines: 22
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28606
Article PK: 77848

On 4 Nov 2009 07:39:04 -0800, Liezl wrote:

You may have to setup a trace (Ribo or sniffer) between the client and
the ASE to see the actual dialog and error. The Reporting tool is not
telling you enough about what it is sending and receiving to
troubleshoot.

Jay

>
>Using Sybase 12.5.4 and have written a query using Windows
>Reporting Services 2000. The problem that I am getting is
>that I am unable to pass strings into stored procs that are
>residing on my server. I get "An error has occured during
>report processing. Query Execution failed for data set
>'trader'. The given type name was unrecognized.
>
>It also doesn't work from the Windows Reporting Service
>through ODBC. However it works from an ISQL session through
>ODBC.
>Any ideas...