Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Print problem

4 posts in DataWindow Last posting was on 2009-11-11 11:49:36.0Z
Luka Posted on 2009-11-11 09:18:08.0Z
From: "Luka" <galacticus@net.hr>
Newsgroups: sybase.public.powerbuilder.datawindow
Organization: 93.142.157.178
X-Newsreader: AspNNTP 1.50 (JodoHost)
Subject: Print problem
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4afa8150$1@forums-1-dub>
Date: 11 Nov 2009 01:18:08 -0800
X-Trace: forums-1-dub 1257931088 10.22.241.152 (11 Nov 2009 01:18:08 -0800)
X-Original-Trace: 11 Nov 2009 01:18:08 -0800, vip152.sybase.com
Lines: 30
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90238
Article PK: 409843

Hy to all!

I am using PB build 9.0.3
I have an issue with nested(composite) report which includes two dw,
header and detail.
Left and right print margins on nested report and on two dw that are
used are set on 55.

Dw_detail is a crosstab type of datawindow, and automaticly, his first
column x cord is set to 9.
The border on all columns is set to Box

When I display nested report in my application, it displays properly
with all margins..
When I decide to print the report the left border (left line of the
box border) of the first column is not shown.

tried to add a dummy dw on nested report on the left of dw_detail.
In the application it is visible that the dw_detail is now slightly
moved to the right and margines are visible.
On print the left margin of the first column is still missing.
I tried adding a line thru the whole dw_detail. If the line passes the
print margins, part of the line is printed on next page but the left
margin of the first column is present on printed paper.
If the line does not pass the print margins, the left margin of the
first column is not present on printed paper.

Thanks for your help!
---== Posted via the PFCGuide Web Newsreader ==---
http://www.pfcguide.com/_newsgroups/group_list.asp


Ivaylo Ivanov Posted on 2009-11-11 10:31:25.0Z
From: "Ivaylo Ivanov" <n0_S_p_a_m_i.ivanov@isy-dc.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4afa8150$1@forums-1-dub>
Subject: Re: Print problem
Lines: 45
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4afa927d@forums-1-dub>
Date: 11 Nov 2009 02:31:25 -0800
X-Trace: forums-1-dub 1257935485 10.22.241.152 (11 Nov 2009 02:31:25 -0800)
X-Original-Trace: 11 Nov 2009 02:31:25 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90239
Article PK: 409842

You didn't mention what measurement Units you're using for your printable DW
objects - are they "PowerBuilder"?
If yes, try to switch to something like "1/1000 inch" or "1/1000
centimeter", because PB units are screen-dependent.

Also, I would suggest you to always leave some gap at the page ends by
moving/resizing nested DWs within the composite one, if you want to have a
properly fitted page output with different printer models.

Regards,
Ivaylo

"Luka" <galacticus@net.hr> wrote in message news:4afa8150$1@forums-1-dub...
> Hy to all!
>
> I am using PB build 9.0.3
> I have an issue with nested(composite) report which includes two dw,
> header and detail.
> Left and right print margins on nested report and on two dw that are
> used are set on 55.
>
> Dw_detail is a crosstab type of datawindow, and automaticly, his first
> column x cord is set to 9.
> The border on all columns is set to Box
>
> When I display nested report in my application, it displays properly
> with all margins..
> When I decide to print the report the left border (left line of the
> box border) of the first column is not shown.
>
> tried to add a dummy dw on nested report on the left of dw_detail.
> In the application it is visible that the dw_detail is now slightly
> moved to the right and margines are visible.
> On print the left margin of the first column is still missing.
> I tried adding a line thru the whole dw_detail. If the line passes the
> print margins, part of the line is printed on next page but the left
> margin of the first column is present on printed paper.
> If the line does not pass the print margins, the left margin of the
> first column is not present on printed paper.
>
> Thanks for your help!
> ---== Posted via the PFCGuide Web Newsreader ==---
> http://www.pfcguide.com/_newsgroups/group_list.asp


galac Posted on 2009-11-11 10:51:07.0Z
From: galac <svijetmagneta@gmail.com>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: Print problem
Date: Wed, 11 Nov 2009 02:51:07 -0800 (PST)
Organization: http://groups.google.com
Lines: 11
Message-ID: <03eb8867-cef7-40b3-bb37-6293536133b1@v25g2000yqk.googlegroups.com>
References: <4afa8150$1@forums-1-dub> <4afa927d@forums-1-dub>
NNTP-Posting-Host: 93.142.157.178
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
X-Trace: posting.google.com 1257936667 23657 127.0.0.1 (11 Nov 2009 10:51:07 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Wed, 11 Nov 2009 10:51:07 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: v25g2000yqk.googlegroups.com; posting-host=93.142.157.178; posting-account=1m0bdgoAAAASoSDowGNtjvZRcLe2HuF7
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3,gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!nntp1.phx1.gblx.net!nntp.gblx.net!nntp.gblx.net!newsfeed.news2me.com!nx02.iad01.newshosting.com!newshosting.com!69.16.185.16.MISMATCH!npeer02.iad.highwinds-media.com!news.highwinds-media.com!feed-me.highwinds-media.com!postnews.google.com!v25g2000yqk.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90241
Article PK: 409847

I am using "PowerBuilder" units.
I tried to switch to "1/1000 inch" or "1/1000
centimeter" but it didn't help.

I do always leave some gap, that is not a problem.
I had issues with PB when the DW is missing some column or it is
presented on two pages. That is easy to solve and it is not an isssue
here.
I have never seen that the left border of first column is missing :)

Thanks anyway


Ivaylo Ivanov Posted on 2009-11-11 11:49:36.0Z
From: "Ivaylo Ivanov" <n0_S_p_a_m_i.ivanov@isy-dc.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4afa8150$1@forums-1-dub> <4afa927d@forums-1-dub> <03eb8867-cef7-40b3-bb37-6293536133b1@v25g2000yqk.googlegroups.com>
Subject: Re: Print problem
Lines: 20
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4afaa4d0$1@forums-1-dub>
Date: 11 Nov 2009 03:49:36 -0800
X-Trace: forums-1-dub 1257940176 10.22.241.152 (11 Nov 2009 03:49:36 -0800)
X-Original-Trace: 11 Nov 2009 03:49:36 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90243
Article PK: 409848

Have you tried with another printer? :-)
Or perhaps some printer driver setting?

Ivaylo

"galac" <svijetmagneta@gmail.com> wrote in message
news:03eb8867-cef7-40b3-bb37-6293536133b1@v25g2000yqk.googlegroups.com...
>I am using "PowerBuilder" units.
> I tried to switch to "1/1000 inch" or "1/1000
> centimeter" but it didn't help.
>
> I do always leave some gap, that is not a problem.
> I had issues with PB when the DW is missing some column or it is
> presented on two pages. That is easy to solve and it is not an isssue
> here.
> I have never seen that the left border of first column is missing :)
>
> Thanks anyway