Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

APB6.2 datetime field bug?

4 posts in Appeon (partner product) Last posting was on 2009-11-30 02:45:37.0Z
jason Posted on 2009-11-23 21:13:44.0Z
Sender: 19f.4b0af821.1804289383@sybase.com
From: Jason
Newsgroups: sybase.public.appeon
Subject: APB6.2 datetime field bug?
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4b0afb08.226.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 23 Nov 2009 13:13:44 -0800
X-Trace: forums-1-dub 1259010824 10.22.241.41 (23 Nov 2009 13:13:44 -0800)
X-Original-Trace: 23 Nov 2009 13:13:44 -0800, 10.22.241.41
Lines: 16
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:2436
Article PK: 13434

I am using Appeon 6.2 and found there is a bug in datetime
field in datawindow. It has two issues:

1. I use SetItem() to assign now() value in a datetime field
in datawindow. It works fine in PB but it doesn't not work
in APB 6.2. APB doesn't receives the value.

2. I use Editmask for a datetime field. In APB 6.2, I cannot
key in value in the mask MMM DD YYYY. I can key in valuse in
the mask YYYY MM DD but I have to press twice in the
begining YYYY. User will get confused doing so.

Is this the bug? Or can I have a solution?

Many thanks,
Jason


Steven Posted on 2009-11-24 09:34:30.0Z
Sender: 1d52.4b0ba677.1804289383@sybase.com
From: Steven
Newsgroups: sybase.public.appeon
Subject: Re: APB6.2 datetime field bug?
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4b0ba8a6.1d87.1681692777@sybase.com>
References: <4b0afb08.226.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 24 Nov 2009 01:34:30 -0800
X-Trace: forums-1-dub 1259055270 10.22.241.41 (24 Nov 2009 01:34:30 -0800)
X-Original-Trace: 24 Nov 2009 01:34:30 -0800, 10.22.241.41
Lines: 12
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:2437
Article PK: 21692

Hi Jason,

We have reproduced the first issue.
And we can't reproduce the second issue, could you send me
the datawindows srd and the screenshot of the settings in
Control Panel | Regional and language options | Regional
Options | Customize | date and time so that we could
reproduce the error?
And what's your location?

Regards,
Steven