Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

dropdowndatawindow acting strange displaying random values

5 posts in DataWindow Last posting was on 2009-11-30 16:09:39.0Z
GW Posted on 2009-11-29 07:54:28.0Z
From: "GW" <gw@gw>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: dropdowndatawindow acting strange displaying random values
Lines: 18
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b1228b4@forums-1-dub>
Date: 28 Nov 2009 23:54:28 -0800
X-Trace: forums-1-dub 1259481268 10.22.241.152 (28 Nov 2009 23:54:28 -0800)
X-Original-Trace: 28 Nov 2009 23:54:28 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90362
Article PK: 409967

Hi all

Can't seem to figure out what's going on here. I have a dddw, the data value
is the table key and the display value is a computed field concatenating 3
columns. For some reason sometimes it will display the data as expected
whereas more often than not it only displays the id instead.

There are no nulls present. It does the same thing in the IDE and compiled.
I've even changed the display value to one of the 3 columns as a test and it
still does the same thing.... so it's not the computed field.

Can anyone tell me what to look for here?

TIA

10.5.2 7611


fisher <fisher_NO Posted on 2009-11-29 08:20:23.0Z
From: fisher <fisher_NO@SPAM_star.wckp.lodz.pl_PLEASE>
User-Agent: Thunderbird 2.0.0.23 (Windows/20090812)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: dropdowndatawindow acting strange displaying random values
References: <4b1228b4@forums-1-dub>
In-Reply-To: <4b1228b4@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-2; format=flowed
Content-Transfer-Encoding: 7bit
X-Antivirus: avast! (VPS 091125-1, 11/25/2009), Outbound message
X-Antivirus-Status: Clean
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b122ec7$1@forums-1-dub>
Date: 29 Nov 2009 00:20:23 -0800
X-Trace: forums-1-dub 1259482823 10.22.241.152 (29 Nov 2009 00:20:23 -0800)
X-Original-Trace: 29 Nov 2009 00:20:23 -0800, vip152.sybase.com
Lines: 29
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90363
Article PK: 409968


GW wrote:
> Hi all
>
> Can't seem to figure out what's going on here. I have a dddw, the data value
> is the table key and the display value is a computed field concatenating 3
> columns. For some reason sometimes it will display the data as expected
> whereas more often than not it only displays the id instead.
>
> There are no nulls present. It does the same thing in the IDE and compiled.
> I've even changed the display value to one of the 3 columns as a test and it
> still does the same thing.... so it's not the computed field.
>
> Can anyone tell me what to look for here?
>
> TIA
>
> 10.5.2 7611
>
>

It usually happens when value in column has no related id in dddw.

check it like this:

select distinct <id_column> from <detail_table>
minus
select id_column from <dddw_dource_table>

dw engine does a lookup, when it cannot find a given value in dddw
source it displays original value.


GW Posted on 2009-11-30 05:03:02.0Z
From: "GW" <gw@gw>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4b1228b4@forums-1-dub> <4b122ec7$1@forums-1-dub>
Subject: Re: dropdowndatawindow acting strange displaying random values
Lines: 37
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b135206$1@forums-1-dub>
Date: 29 Nov 2009 21:03:02 -0800
X-Trace: forums-1-dub 1259557382 10.22.241.152 (29 Nov 2009 21:03:02 -0800)
X-Original-Trace: 29 Nov 2009 21:03:02 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90365
Article PK: 409970

....the data looks fine between both tables

"fisher" <fisher_NO@SPAM_star.wckp.lodz.pl_PLEASE> wrote in message
news:4b122ec7$1@forums-1-dub...
> GW wrote:
>> Hi all
>>
>> Can't seem to figure out what's going on here. I have a dddw, the data
>> value is the table key and the display value is a computed field
>> concatenating 3 columns. For some reason sometimes it will display the
>> data as expected whereas more often than not it only displays the id
>> instead.
>>
>> There are no nulls present. It does the same thing in the IDE and
>> compiled. I've even changed the display value to one of the 3 columns as
>> a test and it still does the same thing.... so it's not the computed
>> field.
>>
>> Can anyone tell me what to look for here?
>>
>> TIA
>>
>> 10.5.2 7611
> It usually happens when value in column has no related id in dddw.
>
> check it like this:
>
> select distinct <id_column> from <detail_table>
> minus
> select id_column from <dddw_dource_table>
>
> dw engine does a lookup, when it cannot find a given value in dddw source
> it displays original value.
>


fisher <fisher_NO Posted on 2009-11-30 06:08:11.0Z
From: fisher <fisher_NO@SPAM_star.wckp.lodz.pl_PLEASE>
User-Agent: Thunderbird 2.0.0.23 (Windows/20090812)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: dropdowndatawindow acting strange displaying random values
References: <4b1228b4@forums-1-dub> <4b122ec7$1@forums-1-dub> <4b135206$1@forums-1-dub>
In-Reply-To: <4b135206$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-2; format=flowed
Content-Transfer-Encoding: 7bit
X-Antivirus: avast! (VPS 091125-1, 11/25/2009), Outbound message
X-Antivirus-Status: Clean
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b13614b$1@forums-1-dub>
Date: 29 Nov 2009 22:08:11 -0800
X-Trace: forums-1-dub 1259561291 10.22.241.152 (29 Nov 2009 22:08:11 -0800)
X-Original-Trace: 29 Nov 2009 22:08:11 -0800, vip152.sybase.com
Lines: 39
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90366
Article PK: 409971


GW wrote:
> .....the data looks fine between both tables
>
>
> "fisher" <fisher_NO@SPAM_star.wckp.lodz.pl_PLEASE> wrote in message
> news:4b122ec7$1@forums-1-dub...
>> GW wrote:
>>> Hi all
>>>
>>> Can't seem to figure out what's going on here. I have a dddw, the data
>>> value is the table key and the display value is a computed field
>>> concatenating 3 columns. For some reason sometimes it will display the
>>> data as expected whereas more often than not it only displays the id
>>> instead.
>>>
>>> There are no nulls present. It does the same thing in the IDE and
>>> compiled. I've even changed the display value to one of the 3 columns as
>>> a test and it still does the same thing.... so it's not the computed
>>> field.
>>>
>>> Can anyone tell me what to look for here?
>>>
>>> TIA
>>>
>>> 10.5.2 7611
>> It usually happens when value in column has no related id in dddw.
>>
>> check it like this:
>>
>> select distinct <id_column> from <detail_table>
>> minus
>> select id_column from <dddw_dource_table>
>>
>> dw engine does a lookup, when it cannot find a given value in dddw source
>> it displays original value.
>>
>
>

Check for any filters applied to DW used in dddw.


GW Posted on 2009-11-30 16:09:39.0Z
From: "GW" <gw@gw>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4b1228b4@forums-1-dub> <4b122ec7$1@forums-1-dub> <4b135206$1@forums-1-dub> <4b13614b$1@forums-1-dub>
Subject: Re: dropdowndatawindow acting strange displaying random values
Lines: 51
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b13ee43$1@forums-1-dub>
Date: 30 Nov 2009 08:09:39 -0800
X-Trace: forums-1-dub 1259597379 10.22.241.152 (30 Nov 2009 08:09:39 -0800)
X-Original-Trace: 30 Nov 2009 08:09:39 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90372
Article PK: 409976

Thanks....decided to start from the beginning and it turns out I had
inadvertently selected an id from the wrong table

time to get my hands slapped<g>

thanks again for your help

"fisher" <fisher_NO@SPAM_star.wckp.lodz.pl_PLEASE> wrote in message
news:4b13614b$1@forums-1-dub...
> GW wrote:
>> .....the data looks fine between both tables
>>
>>
>> "fisher" <fisher_NO@SPAM_star.wckp.lodz.pl_PLEASE> wrote in message
>> news:4b122ec7$1@forums-1-dub...
>>> GW wrote:
>>>> Hi all
>>>>
>>>> Can't seem to figure out what's going on here. I have a dddw, the data
>>>> value is the table key and the display value is a computed field
>>>> concatenating 3 columns. For some reason sometimes it will display the
>>>> data as expected whereas more often than not it only displays the id
>>>> instead.
>>>>
>>>> There are no nulls present. It does the same thing in the IDE and
>>>> compiled. I've even changed the display value to one of the 3 columns
>>>> as a test and it still does the same thing.... so it's not the computed
>>>> field.
>>>>
>>>> Can anyone tell me what to look for here?
>>>>
>>>> TIA
>>>>
>>>> 10.5.2 7611
>>> It usually happens when value in column has no related id in dddw.
>>>
>>> check it like this:
>>>
>>> select distinct <id_column> from <detail_table>
>>> minus
>>> select id_column from <dddw_dource_table>
>>>
>>> dw engine does a lookup, when it cannot find a given value in dddw
>>> source it displays original value.
>>>
>>
>>
> Check for any filters applied to DW used in dddw.
>