Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Background/Gradient dw features not visible at runtime

3 posts in DataWindow Last posting was on 2009-12-02 10:28:11.0Z
Marco Meoni Posted on 2009-11-30 17:28:49.0Z
Sender: 1177.4b13fc65.1804289383@sybase.com
From: Marco Meoni
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Background/Gradient dw features not visible at runtime
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4b1400d1.1405.1681692777@sybase.com>
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="-=_forums-1-dub4b1400d1"
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 30 Nov 2009 09:28:49 -0800
X-Trace: forums-1-dub 1259602129 10.22.241.41 (30 Nov 2009 09:28:49 -0800)
X-Original-Trace: 30 Nov 2009 09:28:49 -0800, 10.22.241.41
Lines: 561
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90375
Article PK: 409979

Hello,
I read many documents about the new datawindow GUI
functionality available in PB 11.5. Among these, the
possibility to apply background/gradient to, for example, dw
buttons.
However, they seem not be applied, i.e. I see differences
already between the painter and the preview, see attachment.
The dw button "Button" in the painter shows a background
effect that is not reported in the preview (and neither at
runtime).
How am I supposed to apply this effect?
Cheers,
M.

Picture 1.png

O Steine Posted on 2009-12-01 12:56:32.0Z
From: "O Steine" <osteine@gmail.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4b1400d1.1405.1681692777@sybase.com>
In-Reply-To: <4b1400d1.1405.1681692777@sybase.com>
Subject: Re: Background/Gradient dw features not visible at runtime
Lines: 1
MIME-Version: 1.0
Content-Type: text/plain; format=flowed; charset="iso-8859-1"; reply-type=original
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
Importance: Normal
X-Newsreader: Microsoft Windows Live Mail 14.0.8089.726
X-MimeOLE: Produced By Microsoft MimeOLE V14.0.8089.726
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b151280@forums-1-dub>
Date: 1 Dec 2009 04:56:32 -0800
X-Trace: forums-1-dub 1259672192 10.22.241.152 (1 Dec 2009 04:56:32 -0800)
X-Original-Trace: 1 Dec 2009 04:56:32 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90381
Article PK: 409986

Is the datawindow property 'Show Backcolor On XP' checked?

"Marco Meoni" skrev i nyhetsmeldingen: 4b1400d1.1405.1681692777@sybase.com
...

> Hello,
> I read many documents about the new datawindow GUI
> functionality available in PB 11.5. Among these, the
> possibility to apply background/gradient to, for example, dw
> buttons.
> However, they seem not be applied, i.e. I see differences
> already between the painter and the preview, see attachment.
> The dw button "Button" in the painter shows a background
> effect that is not reported in the preview (and neither at
> runtime).
> How am I supposed to apply this effect?
> Cheers,
> M.
>


Marco Meoni Posted on 2009-12-02 10:28:11.0Z
Sender: 3fe9.4b14ccf8.1804289383@sybase.com
From: Marco Meoni
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: Background/Gradient dw features not visible at runtime
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4b16413b.6677.1681692777@sybase.com>
References: <4b151280@forums-1-dub>
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="-=_forums-1-dub4b16413b"
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 2 Dec 2009 02:28:11 -0800
X-Trace: forums-1-dub 1259749691 10.22.241.41 (2 Dec 2009 02:28:11 -0800)
X-Original-Trace: 2 Dec 2009 02:28:11 -0800, 10.22.241.41
Lines: 155
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90384
Article PK: 409989

Hello,
apparently this has the side effect to draw a (not desired)
white outline around the button (borders), see attachment.
It is documented in Bug ID 582001 and reported as fixed in
PB 11.5 Build 4566 but it does not seem to be the case.
I have tried with both builds 4566 and 4608 but the white
outline is there.
Cheers,
M.

> Is the datawindow property 'Show Backcolor On XP' checked?
>
> "Marco Meoni" skrev i nyhetsmeldingen:
> 4b1400d1.1405.1681692777@sybase.com ....
> > Hello,
> > I read many documents about the new datawindow GUI
> > functionality available in PB 11.5. Among these, the
> > possibility to apply background/gradient to, for example
> > , dw buttons.
> > However, they seem not be applied, i.e. I see
> > differences already between the painter and the preview,
> > see attachment. The dw button "Button" in the painter
> > shows a background effect that is not reported in the
> > preview (and neither at runtime).
> > How am I supposed to apply this effect?
> > Cheers,
> > M.
> >

Picture 1.png