Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Mousemove over nested report incorrect retireval

3 posts in DataWindow Last posting was on 2009-12-21 10:51:05.0Z
Milan Stolarik Posted on 2009-12-17 19:58:30.0Z
Sender: 5600.4b2a6441.1804289383@sybase.com
From: Milan Stolarik
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Mousemove over nested report incorrect retireval
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4b2a8d66.5af0.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 17 Dec 2009 11:58:30 -0800
X-Trace: forums-1-dub 1261079910 10.22.241.41 (17 Dec 2009 11:58:30 -0800)
X-Original-Trace: 17 Dec 2009 11:58:30 -0800, 10.22.241.41
Lines: 20
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90448
Article PK: 410053

Hi guys,
we have a real weird issue in production with one of our
reports.
Report contains 4 nested reports, when rows are being
retrieved and user moves mouse pointer over report, than
first page is retrieved incorrectly (seems some of nesteds
failed), other pages seems fine.

We've tried to play with SetRedraw on a datawindow and
window, removed all code in retrieverow event (causing
yield) and even created and coded mousemove on a datawindow
(originally there was no such event in dw control), but no
luck.
(It seems only one report specific issue.)

Have you ever encountered such a strange dw behavior?.

Thanks for any feedback

PB 11.2 8407


Scott Morris Posted on 2009-12-17 20:37:04.0Z
From: "Scott Morris" <bogus@bogus.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <4b2a8d66.5af0.1681692777@sybase.com>
Subject: Re: Mousemove over nested report incorrect retireval
Lines: 6
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b2a9670$1@forums-1-dub>
Date: 17 Dec 2009 12:37:04 -0800
X-Trace: forums-1-dub 1261082224 10.22.241.152 (17 Dec 2009 12:37:04 -0800)
X-Original-Trace: 17 Dec 2009 12:37:04 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90449
Article PK: 410056

> Have you ever encountered such a strange dw behavior?.

No. I would try copying the datawindows into a completely new application
that does not use your existing base classes/code.


Milan Stolarik Posted on 2009-12-21 10:51:05.0Z
Sender: 724a.4b2f5163.1804289383@sybase.com
From: Milan Stolarik
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: Mousemove over nested report incorrect retireval
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4b2f5319.7274.1681692777@sybase.com>
References: <4b2a8d66.5af0.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 21 Dec 2009 02:51:05 -0800
X-Trace: forums-1-dub 1261392665 10.22.241.41 (21 Dec 2009 02:51:05 -0800)
X-Original-Trace: 21 Dec 2009 02:51:05 -0800, 10.22.241.41
Lines: 32
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90469
Article PK: 410073

.. FYI, after all we found out the culprit for these strange
behaviour - it was realy code in retrieverow dw event, when
code was removed from event completly retrieval was ok.

We resolved this issue by opening response window, then dw
retrieve method was called from this window and from back
from retrieverow dw event response windows was handled (row
counter was shown there).
Mousemove over report when response window is opened does
not cause the above issue.

> Hi guys,
> we have a real weird issue in production with one of our
> reports.
> Report contains 4 nested reports, when rows are being
> retrieved and user moves mouse pointer over report, than
> first page is retrieved incorrectly (seems some of nesteds
> failed), other pages seems fine.
>
> We've tried to play with SetRedraw on a datawindow and
> window, removed all code in retrieverow event (causing
> yield) and even created and coded mousemove on a
> datawindow (originally there was no such event in dw
> control), but no luck.
> (It seems only one report specific issue.)
>
> Have you ever encountered such a strange dw behavior?.
>
> Thanks for any feedback
>
> PB 11.2 8407