Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Deployed MSI for x64 crashes on install ASA 10

7 posts in General Discussion Last posting was on 2010-01-06 18:33:57.0Z
Charles W Posted on 2010-01-05 21:00:50.0Z
Sender: 28db.4b43a340.1804289383@sybase.com
From: Charles W
Newsgroups: ianywhere.public.general
Subject: Deployed MSI for x64 crashes on install ASA 10
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4b43a882.2973.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 5 Jan 2010 13:00:50 -0800
X-Trace: forums-1-dub 1262725250 10.22.241.41 (5 Jan 2010 13:00:50 -0800)
X-Original-Trace: 5 Jan 2010 13:00:50 -0800, 10.22.241.41
Lines: 30
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:7860
Article PK: 6894

I am attempting to build a deployment MSI for installation
on a Windows 64bit OS, but when installing the MSI seems to
flicker as if it is being opened repeatedly then it errors
out. The event data seems to suggestion it is Windows
Installer that is crashing I am not sure why that would be.
I have tried this on two seperate Windows 7 machines (one
physical machine, attempted on the host and the guest OS)
with the same result. The reported error information is:

Problem signature:
Problem Event Name: APPCRASH
Application Name: msiexec.exe
Application Version: 5.0.7100.0
Application Timestamp: 49ee952f
Fault Module Name: USP10.dll
Fault Module Version: 1.626.7100.0
Fault Module Timestamp: 49eeab89
Exception Code: c000041d
Exception Offset: 0000000000075241
OS Version: 6.1.7100.2.0.0.256.1
Locale ID: 1033
Additional Information 1: f0e6
Additional Information 2: f0e609f67073745cad6b99ba70136073
Additional Information 3: 5da8
Additional Information 4: 5da82329d296a6c38e95739ffdc0771b

I have found similar problems with other isntallers in
Windows but I am not sure if I am doing something wrong
during the deployable creation or if the problem is entirely
in Windows. Any insight would be greatly appreciated.


Josh Savill [Sybase] Posted on 2010-01-06 14:51:53.0Z
From: "Josh Savill [Sybase]" <no_spam_jsavill_no_spam@sybase.com>
Organization: Sybase iAnywhere
User-Agent: Thunderbird 2.0.0.23 (Windows/20090812)
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: Deployed MSI for x64 crashes on install ASA 10
References: <4b43a882.2973.1681692777@sybase.com>
In-Reply-To: <4b43a882.2973.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b44a389$1@forums-1-dub>
Date: 6 Jan 2010 06:51:53 -0800
X-Trace: forums-1-dub 1262789513 10.22.241.152 (6 Jan 2010 06:51:53 -0800)
X-Original-Trace: 6 Jan 2010 06:51:53 -0800, vip152.sybase.com
Lines: 39
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:7862
Article PK: 6897

The Deployment wizard only creates 32-bit installs. What build and version of SQL Anywhere 10 are
you running (dbsrv10 -v)? To get Windows 7 support, you need to be running 10.0.1 build 3960 or higher.

--
Joshua Savill
Sybase Inc. - Product Manager

Charles W wrote:
> I am attempting to build a deployment MSI for installation
> on a Windows 64bit OS, but when installing the MSI seems to
> flicker as if it is being opened repeatedly then it errors
> out. The event data seems to suggestion it is Windows
> Installer that is crashing I am not sure why that would be.
> I have tried this on two seperate Windows 7 machines (one
> physical machine, attempted on the host and the guest OS)
> with the same result. The reported error information is:
>
> Problem signature:
> Problem Event Name: APPCRASH
> Application Name: msiexec.exe
> Application Version: 5.0.7100.0
> Application Timestamp: 49ee952f
> Fault Module Name: USP10.dll
> Fault Module Version: 1.626.7100.0
> Fault Module Timestamp: 49eeab89
> Exception Code: c000041d
> Exception Offset: 0000000000075241
> OS Version: 6.1.7100.2.0.0.256.1
> Locale ID: 1033
> Additional Information 1: f0e6
> Additional Information 2: f0e609f67073745cad6b99ba70136073
> Additional Information 3: 5da8
> Additional Information 4: 5da82329d296a6c38e95739ffdc0771b
>
> I have found similar problems with other isntallers in
> Windows but I am not sure if I am doing something wrong
> during the deployable creation or if the problem is entirely
> in Windows. Any insight would be greatly appreciated.


Josh Savill [Sybase] Posted on 2010-01-06 15:57:11.0Z
From: "Josh Savill [Sybase]" <no_spam_jsavill_no_spam@sybase.com>
Organization: Sybase iAnywhere
User-Agent: Thunderbird 2.0.0.23 (Windows/20090812)
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: Deployed MSI for x64 crashes on install ASA 10
References: <4b43a882.2973.1681692777@sybase.com> <4b44a389$1@forums-1-dub>
In-Reply-To: <4b44a389$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b44b2d7$1@forums-1-dub>
Date: 6 Jan 2010 07:57:11 -0800
X-Trace: forums-1-dub 1262793431 10.22.241.152 (6 Jan 2010 07:57:11 -0800)
X-Original-Trace: 6 Jan 2010 07:57:11 -0800, vip152.sybase.com
Lines: 15
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:7864
Article PK: 6896

If this crashes while installing other applications, then this might help:
http://www.technipages.com/windows-7-msiexec-and-explorer-crash-when-installing-programs.html

Also make sure your virus scanning software is not affecting the install.

--
Joshua Savill
Sybase Inc. - Product Manager

Josh Savill [Sybase] wrote:
> The Deployment wizard only creates 32-bit installs. What build and
> version of SQL Anywhere 10 are you running (dbsrv10 -v)? To get Windows
> 7 support, you need to be running 10.0.1 build 3960 or higher.
>


Charles W Posted on 2010-01-06 16:32:22.0Z
Sender: 28db.4b43a340.1804289383@sybase.com
From: Charles W
Newsgroups: ianywhere.public.general
Subject: Re: Deployed MSI for x64 crashes on install ASA 10
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4b44bb16.549f.1681692777@sybase.com>
References: <4b44b2d7$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 6 Jan 2010 08:32:22 -0800
X-Trace: forums-1-dub 1262795542 10.22.241.41 (6 Jan 2010 08:32:22 -0800)
X-Original-Trace: 6 Jan 2010 08:32:22 -0800, 10.22.241.41
Lines: 25
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:7866
Article PK: 6900

Nothing else crashes on install, I tried the registry change
anyway but it no effect, the MSI still crashes. The event
viewer specifies Windows Installer as the crashing
application, not Explorer.

> If this crashes while installing other applications, then
> this might help:
>
http://www.technipages.com/windows-7-msiexec-and-explorer-crash-when-installing-programs.html
>
> Also make sure your virus scanning software is not
> affecting the install.
>
> --
> Joshua Savill
> Sybase Inc. - Product Manager
>
>
> Josh Savill [Sybase] wrote:
> > The Deployment wizard only creates 32-bit installs. What
> > build and version of SQL Anywhere 10 are you running
> > (dbsrv10 -v)? To get Windows 7 support, you need to be
> > running 10.0.1 build 3960 or higher.


Jeff Albion [Sybase iAnywhere] Posted on 2010-01-06 16:10:14.0Z
From: "Jeff Albion [Sybase iAnywhere]" <firstname.lastname@ianywhere.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: Deployed MSI for x64 crashes on install ASA 10
References: <4b44a389$1@forums-1-dub> <4b44ad40.5225.1681692777@sybase.com>
In-Reply-To: <4b44ad40.5225.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b44b5e6$1@forums-1-dub>
Date: 6 Jan 2010 08:10:14 -0800
X-Trace: forums-1-dub 1262794214 10.22.241.152 (6 Jan 2010 08:10:14 -0800)
X-Original-Trace: 6 Jan 2010 08:10:14 -0800, vip152.sybase.com
Lines: 28
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:7865
Article PK: 6899

Hi Charles,

Are you trying to deploy Sybase Central with this MSI? Please note that
there was a recent bug regarding that specific component and MSI files:

http://search.sybase.com/kbx/changerequests?bug_id=608743

The 10.0.1.4010 EBF has not yet been released, but it has been requested
to be built.

If not, which components are you trying to deploy?

Regards,

On 1/6/2010 10:33 AM, Charles W wrote:
> We are using version 10.0.1.3976. I actually tried the
> installer on a 32 bit machine with the same results,
> although it was compiled on the 64bit machine.

--
Jeff Albion, Sybase iAnywhere

iAnywhere Developer Community :
http://www.sybase.com/developer/library/sql-anywhere-techcorner
iAnywhere Documentation : http://www.ianywhere.com/developer/product_manuals
SQL Anywhere Patches and EBFs :
http://downloads.sybase.com/swd/summary.do?baseprod=144&client=ianywhere&timeframe=0
Report a Bug/Open a Case : http://case-express.sybase.com/cx/