Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ASE Web Service

5 posts in General Discussion Last posting was on 2013-03-22 11:33:15.0Z
Serkan Birkan Posted on 2010-01-11 12:20:20.0Z
From: "Serkan Birkan" <serkanbirkan@mailcity.com>
Newsgroups: sybase.public.ase.general
Subject: ASE Web Service
Lines: 68
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b4b1784$1@forums-1-dub>
Date: 11 Jan 2010 04:20:20 -0800
X-Trace: forums-1-dub 1263212420 10.22.241.152 (11 Jan 2010 04:20:20 -0800)
X-Original-Trace: 11 Jan 2010 04:20:20 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28866
Article PK: 78110

Hello,

I am using ASE 15.0.3 on Windows XP-SP3. I am trying to create a web service
consumer but I fail all the time.

I modify the ASE server options where necessary as follows:
Enable web services to 1
Enable cis to 1
Enable cis rpc handling to 1
Enable xml to 1

Then I create a consumer by using Sybase Central.

After that I run the following command as mentioned in the web services
manual:
C:\sybase\WS-15_0\bin\runws -U sa -P 123456 -S SYBEDU1 -f
"C:\sybase\WS-15_0\props\ws.properties" -v

It doesn't do anything. Only writing a message on screen that tells the user
to check the log file. But it doesn't even create the log file.

Then I remove the "-v" parameter and run again. This time it is trying to
run something then quits. And in the log file it says:

2010-01-11 14:18:57.078 INFO [main] - ASE Web
Services/15.0.0/P/1.4.2_06/generic/OPT/March 4 2009
2010-01-11 14:18:57.078 INFO [main] - Starting ASE Web Services Producer
2010-01-11 14:18:57.078 INFO [main] - Using property file at:
C:\sybase\WS-15_0\props\ws.properties
2010-01-11 14:18:57.093 DEBUG [main] - DateStamp: Mon Jan 11 14:18:57 EET
2010
2010-01-11 14:18:57.093 INFO [main] - Version String: 15.0.0
2010-01-11 14:18:57.093 INFO [main] - JRE Version: 1.6.0_06
2010-01-11 14:18:57.093 INFO [main] - Java Home:
C:\sybase\Shared\JRE-6_0_6_32BIT
2010-01-11 14:18:57.093 DEBUG [main] - Java Classpath:
C:\sybase\WS-15_0\lib\axis.jar;C:\sybase\WS-15_0\lib\jaxrpc.jar;C:\sybase\WS-15_0\lib\saaj.jar;C:\sybase\WS-15_0\lib\commons-logging-1.0.4.jar;C:\sybase\WS-15_0\lib\commons-discovery-0.2.jar;C:\sybase\WS-15_0\lib\log4j-1.2.4.jar;C:\sybase\WS-15_0\lib\wsdl4j-1.5.1.jar;C:\sybase\jConnect-6_0\classes\jconn3.jar;C:\sybase\jConnect-6_0\classes\jTDS3.jar;C:\sybase\WS-15_0\lib\xercesImpl.jar;C:\sybase\WS-15_0\lib\xmlParserAPIs.jar;C:\sybase\WS-15_0\lib\javax.servlet.jar;C:\sybase\WS-15_0\lib\server.jar;C:\sybase\WS-15_0\lib\sqlx.jar;C:\sybase\WS-15_0\lib\flexlm.jar;C:\sybase\WS-15_0\lib\org.mortbay.jetty.jar;C:\sybase\WS-15_0\lib\tools.jar;C:\sybase\WS-15_0\lib\jcert.jar;C:\sybase\WS-15_0\lib\jnet.jar;C:\sybase\WS-15_0\lib\jsse.jar;C:\sybase\WS-15_0\lib\jce1_2_2.jar;C:\sybase\WS-15_0\lib\sunjce_provider.jar;C:\sybase\WS-15_0\lib\ws.jar;C:\sybase\shared\lib\dsparser.jar;C:\sybase\WS-15_0\props
2010-01-11 14:18:57.093 DEBUG [main] - XMLreceiver.constructor
2010-01-11 14:18:57.093 DEBUG [main] - Entering ServerInterfaces constructor
2010-01-11 14:18:57.093 DEBUG [main] - Entering initServerEntries
2010-01-11 14:18:57.093 DEBUG [main] - Entering initLDAPValues
2010-01-11 14:18:57.093 DEBUG [main] - Exiting initLDAPValues
2010-01-11 14:18:57.093 DEBUG [main] - Entering isInterfacesFileModified
2010-01-11 14:18:57.093 DEBUG [main] - Entering isWindows
2010-01-11 14:18:57.109 DEBUG [main] - Exiting isWindows with: true
2010-01-11 14:18:57.109 DEBUG [main] - Interface file name is:
C:\sybase\ini\sql.ini
2010-01-11 14:18:57.109 DEBUG [main] - Exiting isInterfacesFileModified with
true
2010-01-11 14:18:57.109 DEBUG [main] - Entering getInterfacesDriver
2010-01-11 14:18:57.125 DEBUG [main] - Exiting getInterfacesDriver
2010-01-11 14:18:57.125 DEBUG [main] - Found entry: ws
2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_XP
2010-01-11 14:18:57.125 DEBUG [main] - Found entry: ws_sybedu1
2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1
2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_MS
2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_BS
2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_JSAGENT
2010-01-11 14:18:57.125 DEBUG [main] - Entering isLDAPFileModified
2010-01-11 14:18:57.125 DEBUG [main] - Using file from property:
2010-01-11 14:18:57.125 FATAL [main] - A NullPointer was encountered:
java.lang.NullPointerException

Is there anyone who can tell why am I getting this error?

Thanks.


J Posted on 2010-01-11 17:09:23.0Z
From: jtotally_bogus@sbcglobal.net (J)
Newsgroups: sybase.public.ase.general
Subject: Re: ASE Web Service
Reply-To: J@bogusemailAddress.com
Message-ID: <4b4b5466.2312124@forums.sybase.com>
References: <4b4b1784$1@forums-1-dub>
X-Newsreader: Forte Free Agent 1.21/32.243
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 11 Jan 2010 09:09:23 -0800
X-Trace: forums-1-dub 1263229763 10.22.241.152 (11 Jan 2010 09:09:23 -0800)
X-Original-Trace: 11 Jan 2010 09:09:23 -0800, vip152.sybase.com
Lines: 86
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28867
Article PK: 78109

On 11 Jan 2010 04:20:20 -0800, "Serkan Birkan"
<serkanbirkan@mailcity.com> wrote:

For your first command when you ask for the version (-v) you should
not have a log created.

I would think that there is something missing in the ws.properties
file for the null pointer. Can you post the non-commented lines from
ws.properties. Try using double backslashes or omitting the -f
parameter:

I think they ask you to use \\ if specifying the sql.ini file location
so I am guessing the properties file location would not use different
syntax.

Jay

>Hello,
>
>I am using ASE 15.0.3 on Windows XP-SP3. I am trying to create a web service
>consumer but I fail all the time.
>
>I modify the ASE server options where necessary as follows:
>Enable web services to 1
>Enable cis to 1
>Enable cis rpc handling to 1
>Enable xml to 1
>
>Then I create a consumer by using Sybase Central.
>
>After that I run the following command as mentioned in the web services
>manual:
>C:\sybase\WS-15_0\bin\runws -U sa -P 123456 -S SYBEDU1 -f
>"C:\sybase\WS-15_0\props\ws.properties" -v
>
>It doesn't do anything. Only writing a message on screen that tells the user
>to check the log file. But it doesn't even create the log file.
>
>Then I remove the "-v" parameter and run again. This time it is trying to
>run something then quits. And in the log file it says:
>
>2010-01-11 14:18:57.078 INFO [main] - ASE Web
>Services/15.0.0/P/1.4.2_06/generic/OPT/March 4 2009
>2010-01-11 14:18:57.078 INFO [main] - Starting ASE Web Services Producer
>2010-01-11 14:18:57.078 INFO [main] - Using property file at:
>C:\sybase\WS-15_0\props\ws.properties
>2010-01-11 14:18:57.093 DEBUG [main] - DateStamp: Mon Jan 11 14:18:57 EET
>2010
>2010-01-11 14:18:57.093 INFO [main] - Version String: 15.0.0
>2010-01-11 14:18:57.093 INFO [main] - JRE Version: 1.6.0_06
>2010-01-11 14:18:57.093 INFO [main] - Java Home:
>C:\sybase\Shared\JRE-6_0_6_32BIT
>2010-01-11 14:18:57.093 DEBUG [main] - Java Classpath:
>C:\sybase\WS-15_0\lib\axis.jar;C:\sybase\WS-15_0\lib\jaxrpc.jar;C:\sybase\WS-15_0\lib\saaj.jar;C:\sybase\WS-15_0\lib\commons-logging-1.0.4.jar;C:\sybase\WS-15_0\lib\commons-discovery-0.2.jar;C:\sybase\WS-15_0\lib\log4j-1.2.4.jar;C:\sybase\WS-15_0\lib\wsdl4j-1.5.1.jar;C:\sybase\jConnect-6_0\classes\jconn3.jar;C:\sybase\jConnect-6_0\classes\jTDS3.jar;C:\sybase\WS-15_0\lib\xercesImpl.jar;C:\sybase\WS-15_0\lib\xmlParserAPIs.jar;C:\sybase\WS-15_0\lib\javax.servlet.jar;C:\sybase\WS-15_0\lib\server.jar;C:\sybase\WS-15_0\lib\sqlx.jar;C:\sybase\WS-15_0\lib\flexlm.jar;C:\sybase\WS-15_0\lib\org.mortbay.jetty.jar;C:\sybase\WS-15_0\lib\tools.jar;C:\sybase\WS-15_0\lib\jcert.jar;C:\sybase\WS-15_0\lib\jnet.jar;C:\sybase\WS-15_0\lib\jsse.jar;C:\sybase\WS-15_0\lib\jce1_2_2.jar;C:\sybase\WS-15_0\lib\sunjce_provider.jar;C:\sybase\WS-15_0\lib\ws.jar;C:\sybase\shared\lib\dsparser.jar;C:\sybase\WS-15_0\props
>2010-01-11 14:18:57.093 DEBUG [main] - XMLreceiver.constructor
>2010-01-11 14:18:57.093 DEBUG [main] - Entering ServerInterfaces constructor
>2010-01-11 14:18:57.093 DEBUG [main] - Entering initServerEntries
>2010-01-11 14:18:57.093 DEBUG [main] - Entering initLDAPValues
>2010-01-11 14:18:57.093 DEBUG [main] - Exiting initLDAPValues
>2010-01-11 14:18:57.093 DEBUG [main] - Entering isInterfacesFileModified
>2010-01-11 14:18:57.093 DEBUG [main] - Entering isWindows
>2010-01-11 14:18:57.109 DEBUG [main] - Exiting isWindows with: true
>2010-01-11 14:18:57.109 DEBUG [main] - Interface file name is:
>C:\sybase\ini\sql.ini
>2010-01-11 14:18:57.109 DEBUG [main] - Exiting isInterfacesFileModified with
>true
>2010-01-11 14:18:57.109 DEBUG [main] - Entering getInterfacesDriver
>2010-01-11 14:18:57.125 DEBUG [main] - Exiting getInterfacesDriver
>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: ws
>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_XP
>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: ws_sybedu1
>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1
>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_MS
>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_BS
>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_JSAGENT
>2010-01-11 14:18:57.125 DEBUG [main] - Entering isLDAPFileModified
>2010-01-11 14:18:57.125 DEBUG [main] - Using file from property:
>2010-01-11 14:18:57.125 FATAL [main] - A NullPointer was encountered:
>java.lang.NullPointerException
>
>Is there anyone who can tell why am I getting this error?
>
>Thanks.
>
>


Serkan Birkan Posted on 2010-01-12 08:26:23.0Z
From: "Serkan Birkan" <serkanbirkan@mailcity.com>
Newsgroups: sybase.public.ase.general
References: <4b4b1784$1@forums-1-dub> <4b4b5466.2312124@forums.sybase.com>
Subject: Re: ASE Web Service
Lines: 119
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b4c322f$1@forums-1-dub>
Date: 12 Jan 2010 00:26:23 -0800
X-Trace: forums-1-dub 1263284783 10.22.241.152 (12 Jan 2010 00:26:23 -0800)
X-Original-Trace: 12 Jan 2010 00:26:23 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28870
Article PK: 78112

Hello,

Here is the non-commented lines from:

com.sybase.ase.ws.name = ws
com.sybase.ase.ws.producer.httpport = 8181
com.sybase.ase.ws.consumer.cisport = 8183
com.sybase.ase.ws.logfilename = ../logs/webservice.log
com.sybase.ase.ws.producer.jettylogfile = ../logs/http.log
com.sybase.ase.ws.ui.activate = true
com.sybase.ase.ws.producer.tuning.maxthreads = 250
com.sybase.ase.ws.producer.tuning.minthreads = 45
com.sybase.ase.ws.producer.tuning.maxidletime = 60000
com.sybase.ase.ws.producer.tuning.ssl.maxthreads = 125
com.sybase.ase.ws.producer.tuning.ssl.minthreads = 10
com.sybase.ase.ws.producer.tuning.ssl.maxidletime = 60000
com.sybase.ase.ws.producer.ssl.password =
com.sybase.ase.ws.producer.ssl.httpsport =
com.sybase.ase.ws.producer.ssl.keystore =
com.sybase.ase.ws.producer.ssl.keypassword =




> ws.properties

"J" <jtotally_bogus@sbcglobal.net> wrote in message
news:4b4b5466.2312124@forums.sybase.com...
> On 11 Jan 2010 04:20:20 -0800, "Serkan Birkan"
> <serkanbirkan@mailcity.com> wrote:
>
> For your first command when you ask for the version (-v) you should
> not have a log created.
>
> I would think that there is something missing in the ws.properties
> file for the null pointer. Can you post the non-commented lines from
> ws.properties. Try using double backslashes or omitting the -f
> parameter:
>
> I think they ask you to use \\ if specifying the sql.ini file location
> so I am guessing the properties file location would not use different
> syntax.
>
> Jay
>
>>Hello,
>>
>>I am using ASE 15.0.3 on Windows XP-SP3. I am trying to create a web
>>service
>>consumer but I fail all the time.
>>
>>I modify the ASE server options where necessary as follows:
>>Enable web services to 1
>>Enable cis to 1
>>Enable cis rpc handling to 1
>>Enable xml to 1
>>
>>Then I create a consumer by using Sybase Central.
>>
>>After that I run the following command as mentioned in the web services
>>manual:
>>C:\sybase\WS-15_0\bin\runws -U sa -P 123456 -S SYBEDU1 -f
>>"C:\sybase\WS-15_0\props\ws.properties" -v
>>
>>It doesn't do anything. Only writing a message on screen that tells the
>>user
>>to check the log file. But it doesn't even create the log file.
>>
>>Then I remove the "-v" parameter and run again. This time it is trying to
>>run something then quits. And in the log file it says:
>>
>>2010-01-11 14:18:57.078 INFO [main] - ASE Web
>>Services/15.0.0/P/1.4.2_06/generic/OPT/March 4 2009
>>2010-01-11 14:18:57.078 INFO [main] - Starting ASE Web Services Producer
>>2010-01-11 14:18:57.078 INFO [main] - Using property file at:
>>C:\sybase\WS-15_0\props\ws.properties
>>2010-01-11 14:18:57.093 DEBUG [main] - DateStamp: Mon Jan 11 14:18:57 EET
>>2010
>>2010-01-11 14:18:57.093 INFO [main] - Version String: 15.0.0
>>2010-01-11 14:18:57.093 INFO [main] - JRE Version: 1.6.0_06
>>2010-01-11 14:18:57.093 INFO [main] - Java Home:
>>C:\sybase\Shared\JRE-6_0_6_32BIT
>>2010-01-11 14:18:57.093 DEBUG [main] - Java Classpath:
>>C:\sybase\WS-15_0\lib\axis.jar;C:\sybase\WS-15_0\lib\jaxrpc.jar;C:\sybase\WS-15_0\lib\saaj.jar;C:\sybase\WS-15_0\lib\commons-logging-1.0.4.jar;C:\sybase\WS-15_0\lib\commons-discovery-0.2.jar;C:\sybase\WS-15_0\lib\log4j-1.2.4.jar;C:\sybase\WS-15_0\lib\wsdl4j-1.5.1.jar;C:\sybase\jConnect-6_0\classes\jconn3.jar;C:\sybase\jConnect-6_0\classes\jTDS3.jar;C:\sybase\WS-15_0\lib\xercesImpl.jar;C:\sybase\WS-15_0\lib\xmlParserAPIs.jar;C:\sybase\WS-15_0\lib\javax.servlet.jar;C:\sybase\WS-15_0\lib\server.jar;C:\sybase\WS-15_0\lib\sqlx.jar;C:\sybase\WS-15_0\lib\flexlm.jar;C:\sybase\WS-15_0\lib\org.mortbay.jetty.jar;C:\sybase\WS-15_0\lib\tools.jar;C:\sybase\WS-15_0\lib\jcert.jar;C:\sybase\WS-15_0\lib\jnet.jar;C:\sybase\WS-15_0\lib\jsse.jar;C:\sybase\WS-15_0\lib\jce1_2_2.jar;C:\sybase\WS-15_0\lib\sunjce_provider.jar;C:\sybase\WS-15_0\lib\ws.jar;C:\sybase\shared\lib\dsparser.jar;C:\sybase\WS-15_0\props
>>2010-01-11 14:18:57.093 DEBUG [main] - XMLreceiver.constructor
>>2010-01-11 14:18:57.093 DEBUG [main] - Entering ServerInterfaces
>>constructor
>>2010-01-11 14:18:57.093 DEBUG [main] - Entering initServerEntries
>>2010-01-11 14:18:57.093 DEBUG [main] - Entering initLDAPValues
>>2010-01-11 14:18:57.093 DEBUG [main] - Exiting initLDAPValues
>>2010-01-11 14:18:57.093 DEBUG [main] - Entering isInterfacesFileModified
>>2010-01-11 14:18:57.093 DEBUG [main] - Entering isWindows
>>2010-01-11 14:18:57.109 DEBUG [main] - Exiting isWindows with: true
>>2010-01-11 14:18:57.109 DEBUG [main] - Interface file name is:
>>C:\sybase\ini\sql.ini
>>2010-01-11 14:18:57.109 DEBUG [main] - Exiting isInterfacesFileModified
>>with
>>true
>>2010-01-11 14:18:57.109 DEBUG [main] - Entering getInterfacesDriver
>>2010-01-11 14:18:57.125 DEBUG [main] - Exiting getInterfacesDriver
>>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: ws
>>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_XP
>>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: ws_sybedu1
>>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1
>>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_MS
>>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_BS
>>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_JSAGENT
>>2010-01-11 14:18:57.125 DEBUG [main] - Entering isLDAPFileModified
>>2010-01-11 14:18:57.125 DEBUG [main] - Using file from property:
>>2010-01-11 14:18:57.125 FATAL [main] - A NullPointer was encountered:
>>java.lang.NullPointerException
>>
>>Is there anyone who can tell why am I getting this error?
>>
>>Thanks.
>>
>>
>


J Posted on 2010-01-12 16:50:32.0Z
From: jtotally_bogus@sbcglobal.net (J)
Newsgroups: sybase.public.ase.general
Subject: Re: ASE Web Service
Reply-To: J@bogusemailAddress.com
Message-ID: <4b4ca834.2354425@forums.sybase.com>
References: <4b4b1784$1@forums-1-dub> <4b4b5466.2312124@forums.sybase.com> <4b4c322f$1@forums-1-dub>
X-Newsreader: Forte Free Agent 1.21/32.243
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 12 Jan 2010 08:50:32 -0800
X-Trace: forums-1-dub 1263315032 10.22.241.152 (12 Jan 2010 08:50:32 -0800)
X-Original-Trace: 12 Jan 2010 08:50:32 -0800, vip152.sybase.com
Lines: 128
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28872
Article PK: 78116

On 12 Jan 2010 00:26:23 -0800, "Serkan Birkan"
<serkanbirkan@mailcity.com> wrote:

The documentation says that you should be using "\\" ase file
separators not the "/" as shown.

J

>Hello,
>
>Here is the non-commented lines from:
>
>com.sybase.ase.ws.name = ws
>com.sybase.ase.ws.producer.httpport = 8181
>com.sybase.ase.ws.consumer.cisport = 8183
>com.sybase.ase.ws.logfilename = ../logs/webservice.log
>com.sybase.ase.ws.producer.jettylogfile = ../logs/http.log
>com.sybase.ase.ws.ui.activate = true
>com.sybase.ase.ws.producer.tuning.maxthreads = 250
>com.sybase.ase.ws.producer.tuning.minthreads = 45
>com.sybase.ase.ws.producer.tuning.maxidletime = 60000
>com.sybase.ase.ws.producer.tuning.ssl.maxthreads = 125
>com.sybase.ase.ws.producer.tuning.ssl.minthreads = 10
>com.sybase.ase.ws.producer.tuning.ssl.maxidletime = 60000
>com.sybase.ase.ws.producer.ssl.password =
>com.sybase.ase.ws.producer.ssl.httpsport =
>com.sybase.ase.ws.producer.ssl.keystore =
>com.sybase.ase.ws.producer.ssl.keypassword =
>
>
>
>
>> ws.properties
>"J" <jtotally_bogus@sbcglobal.net> wrote in message
>news:4b4b5466.2312124@forums.sybase.com...
>> On 11 Jan 2010 04:20:20 -0800, "Serkan Birkan"
>> <serkanbirkan@mailcity.com> wrote:
>>
>> For your first command when you ask for the version (-v) you should
>> not have a log created.
>>
>> I would think that there is something missing in the ws.properties
>> file for the null pointer. Can you post the non-commented lines from
>> ws.properties. Try using double backslashes or omitting the -f
>> parameter:
>>
>> I think they ask you to use \\ if specifying the sql.ini file location
>> so I am guessing the properties file location would not use different
>> syntax.
>>
>> Jay
>>
>>>Hello,
>>>
>>>I am using ASE 15.0.3 on Windows XP-SP3. I am trying to create a web
>>>service
>>>consumer but I fail all the time.
>>>
>>>I modify the ASE server options where necessary as follows:
>>>Enable web services to 1
>>>Enable cis to 1
>>>Enable cis rpc handling to 1
>>>Enable xml to 1
>>>
>>>Then I create a consumer by using Sybase Central.
>>>
>>>After that I run the following command as mentioned in the web services
>>>manual:
>>>C:\sybase\WS-15_0\bin\runws -U sa -P 123456 -S SYBEDU1 -f
>>>"C:\sybase\WS-15_0\props\ws.properties" -v
>>>
>>>It doesn't do anything. Only writing a message on screen that tells the
>>>user
>>>to check the log file. But it doesn't even create the log file.
>>>
>>>Then I remove the "-v" parameter and run again. This time it is trying to
>>>run something then quits. And in the log file it says:
>>>
>>>2010-01-11 14:18:57.078 INFO [main] - ASE Web
>>>Services/15.0.0/P/1.4.2_06/generic/OPT/March 4 2009
>>>2010-01-11 14:18:57.078 INFO [main] - Starting ASE Web Services Producer
>>>2010-01-11 14:18:57.078 INFO [main] - Using property file at:
>>>C:\sybase\WS-15_0\props\ws.properties
>>>2010-01-11 14:18:57.093 DEBUG [main] - DateStamp: Mon Jan 11 14:18:57 EET
>>>2010
>>>2010-01-11 14:18:57.093 INFO [main] - Version String: 15.0.0
>>>2010-01-11 14:18:57.093 INFO [main] - JRE Version: 1.6.0_06
>>>2010-01-11 14:18:57.093 INFO [main] - Java Home:
>>>C:\sybase\Shared\JRE-6_0_6_32BIT
>>>2010-01-11 14:18:57.093 DEBUG [main] - Java Classpath:
>>>C:\sybase\WS-15_0\lib\axis.jar;C:\sybase\WS-15_0\lib\jaxrpc.jar;C:\sybase\WS-15_0\lib\saaj.jar;C:\sybase\WS-15_0\lib\commons-logging-1.0.4.jar;C:\sybase\WS-15_0\lib\commons-discovery-0.2.jar;C:\sybase\WS-15_0\lib\log4j-1.2.4.jar;C:\sybase\WS-15_0\lib\wsdl4j-1.5.1.jar;C:\sybase\jConnect-6_0\classes\jconn3.jar;C:\sybase\jConnect-6_0\classes\jTDS3.jar;C:\sybase\WS-15_0\lib\xercesImpl.jar;C:\sybase\WS-15_0\lib\xmlParserAPIs.jar;C:\sybase\WS-15_0\lib\javax.servlet.jar;C:\sybase\WS-15_0\lib\server.jar;C:\sybase\WS-15_0\lib\sqlx.jar;C:\sybase\WS-15_0\lib\flexlm.jar;C:\sybase\WS-15_0\lib\org.mortbay.jetty.jar;C:\sybase\WS-15_0\lib\tools.jar;C:\sybase\WS-15_0\lib\jcert.jar;C:\sybase\WS-15_0\lib\jnet.jar;C:\sybase\WS-15_0\lib\jsse.jar;C:\sybase\WS-15_0\lib\jce1_2_2.jar;C:\sybase\WS-15_0\lib\sunjce_provider.jar;C:\sybase\WS-15_0\lib\ws.jar;C:\sybase\shared\lib\dsparser.jar;C:\sybase\WS-15_0\props
>>>2010-01-11 14:18:57.093 DEBUG [main] - XMLreceiver.constructor
>>>2010-01-11 14:18:57.093 DEBUG [main] - Entering ServerInterfaces
>>>constructor
>>>2010-01-11 14:18:57.093 DEBUG [main] - Entering initServerEntries
>>>2010-01-11 14:18:57.093 DEBUG [main] - Entering initLDAPValues
>>>2010-01-11 14:18:57.093 DEBUG [main] - Exiting initLDAPValues
>>>2010-01-11 14:18:57.093 DEBUG [main] - Entering isInterfacesFileModified
>>>2010-01-11 14:18:57.093 DEBUG [main] - Entering isWindows
>>>2010-01-11 14:18:57.109 DEBUG [main] - Exiting isWindows with: true
>>>2010-01-11 14:18:57.109 DEBUG [main] - Interface file name is:
>>>C:\sybase\ini\sql.ini
>>>2010-01-11 14:18:57.109 DEBUG [main] - Exiting isInterfacesFileModified
>>>with
>>>true
>>>2010-01-11 14:18:57.109 DEBUG [main] - Entering getInterfacesDriver
>>>2010-01-11 14:18:57.125 DEBUG [main] - Exiting getInterfacesDriver
>>>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: ws
>>>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_XP
>>>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: ws_sybedu1
>>>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1
>>>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_MS
>>>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_BS
>>>2010-01-11 14:18:57.125 DEBUG [main] - Found entry: SYBEDU1_JSAGENT
>>>2010-01-11 14:18:57.125 DEBUG [main] - Entering isLDAPFileModified
>>>2010-01-11 14:18:57.125 DEBUG [main] - Using file from property:
>>>2010-01-11 14:18:57.125 FATAL [main] - A NullPointer was encountered:
>>>java.lang.NullPointerException
>>>
>>>Is there anyone who can tell why am I getting this error?
>>>
>>>Thanks.
>>>
>>>
>>
>
>


Jan Pernica Posted on 2013-03-22 11:33:15.0Z
Sender: 5142.514c286f.1804289383@sybase.com
From: Jan Pernica
Newsgroups: sybase.public.ase.general
Subject: Re: ASE Web Service
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <514c417a.5916.1681692777@sybase.com>
References: <4b4b5466.2312124@forums.sybase.com>
NNTP-Posting-Host: 172.20.134.41
X-Original-NNTP-Posting-Host: 172.20.134.41
Date: 22 Mar 2013 03:33:15 -0800
X-Trace: forums-1-dub 1363951995 172.20.134.41 (22 Mar 2013 03:33:15 -0800)
X-Original-Trace: 22 Mar 2013 03:33:15 -0800, 172.20.134.41
Lines: 120
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:31737
Article PK: 1308570

Hi in the EBF 20809 for Sybase 15

The relative paths in ws.properties have to be replaced by
full path names. Relative pathnames does not work anymode.

Jan

> On 11 Jan 2010 04:20:20 -0800, "Serkan Birkan"
> <serkanbirkan@mailcity.com> wrote:
>
> For your first command when you ask for the version (-v)
> you should not have a log created.
>
> I would think that there is something missing in the
> ws.properties file for the null pointer. Can you post the
> non-commented lines from ws.properties. Try using double
> backslashes or omitting the -f parameter:
>
> I think they ask you to use \\ if specifying the sql.ini
> file location so I am guessing the properties file
> location would not use different syntax.
>
> Jay
>
> >Hello,
> >
> >I am using ASE 15.0.3 on Windows XP-SP3. I am trying to
> create a web service >consumer but I fail all the time.
> >
> >I modify the ASE server options where necessary as
> follows: >Enable web services to 1
> >Enable cis to 1
> >Enable cis rpc handling to 1
> >Enable xml to 1
> >
> >Then I create a consumer by using Sybase Central.
> >
> >After that I run the following command as mentioned in
> the web services >manual:
> >C:\sybase\WS-15_0\bin\runws -U sa -P 123456 -S SYBEDU1 -f
> >"C:\sybase\WS-15_0\props\ws.properties" -v
> >
> >It doesn't do anything. Only writing a message on screen
> that tells the user >to check the log file. But it
> doesn't even create the log file. >
> >Then I remove the "-v" parameter and run again. This time
> it is trying to >run something then quits. And in the log
> file it says: >
> >2010-01-11 14:18:57.078 INFO [main] - ASE Web
> >Services/15.0.0/P/1.4.2_06/generic/OPT/March 4 2009
> >2010-01-11 14:18:57.078 INFO [main] - Starting ASE Web
> Services Producer >2010-01-11 14:18:57.078 INFO [main] -
> Using property file at:
> >C:\sybase\WS-15_0\props\ws.properties >2010-01-11
> 14:18:57.093 DEBUG [main] - DateStamp: Mon Jan 11 14:18:57
> EET >2010
> >2010-01-11 14:18:57.093 INFO [main] - Version String:
> 15.0.0 >2010-01-11 14:18:57.093 INFO [main] - JRE
> Version: 1.6.0_06 >2010-01-11 14:18:57.093 INFO [main] -
> Java Home: >C:\sybase\Shared\JRE-6_0_6_32BIT
> >2010-01-11 14:18:57.093 DEBUG [main] - Java Classpath:
> >C:\sybase\WS-15_0\lib\axis.jar
> ;C:\sybase\WS-15_0\lib\jaxrpc.jar
> ;C:\sybase\WS-15_0\lib\saaj.jar
> ;C:\sybase\WS-15_0\lib\commons-logging-1.0.4.jar
> ;C:\sybase\WS-15_0\lib\commons-discovery-0.2.jar
> ;C:\sybase\WS-15_0\lib\log4j-1.2.4.jar
> ;C:\sybase\WS-15_0\lib\wsdl4j-1.5.1.jar
> ;C:\sybase\jConnect-6_0\classes\jconn3.jar
> ;C:\sybase\jConnect-6_0\classes\jTDS3.jar
> ;C:\sybase\WS-15_0\lib\xercesImpl.jar
> ;C:\sybase\WS-15_0\lib\xmlParserAPIs.jar
> ;C:\sybase\WS-15_0\lib\javax.servlet.jar
> ;C:\sybase\WS-15_0\lib\server.jar
> ;C:\sybase\WS-15_0\lib\sqlx.jar
> ;C:\sybase\WS-15_0\lib\flexlm.jar
> ;C:\sybase\WS-15_0\lib\org.mortbay.jetty.jar
> ;C:\sybase\WS-15_0\lib\tools.jar
> ;C:\sybase\WS-15_0\lib\jcert.jar
> ;C:\sybase\WS-15_0\lib\jnet.jar
> ;C:\sybase\WS-15_0\lib\jsse.jar
> ;C:\sybase\WS-15_0\lib\jce1_2_2.jar
> ;C:\sybase\WS-15_0\lib\sunjce_provider.jar
> ;C:\sybase\WS-15_0\lib\ws.jar
> ;C:\sybase\shared\lib\dsparser.jar;C:\sybase\WS-15_0\props
> >2010-01-11 14:18:57.093 DEBUG [main] -
> XMLreceiver.constructor >2010-01-11 14:18:57.093 DEBUG
> [main] - Entering ServerInterfaces constructor >2010-01-11
> 14:18:57.093 DEBUG [main] - Entering initServerEntries
> >2010-01-11 14:18:57.093 DEBUG [main] - Entering
> initLDAPValues >2010-01-11 14:18:57.093 DEBUG [main] -
> Exiting initLDAPValues >2010-01-11 14:18:57.093 DEBUG
> [main] - Entering isInterfacesFileModified >2010-01-11
> 14:18:57.093 DEBUG [main] - Entering isWindows >2010-01-11
> 14:18:57.109 DEBUG [main] - Exiting isWindows with: true
> >2010-01-11 14:18:57.109 DEBUG [main] - Interface file
> name is: >C:\sybase\ini\sql.ini
> >2010-01-11 14:18:57.109 DEBUG [main] - Exiting
> isInterfacesFileModified with >true
> >2010-01-11 14:18:57.109 DEBUG [main] - Entering
> getInterfacesDriver >2010-01-11 14:18:57.125 DEBUG [main]
> - Exiting getInterfacesDriver >2010-01-11 14:18:57.125
> DEBUG [main] - Found entry: ws >2010-01-11 14:18:57.125
> DEBUG [main] - Found entry: SYBEDU1_XP >2010-01-11
> 14:18:57.125 DEBUG [main] - Found entry: ws_sybedu1
> >2010-01-11 14:18:57.125 DEBUG [main] - Found entry:
> SYBEDU1 >2010-01-11 14:18:57.125 DEBUG [main] - Found
> entry: SYBEDU1_MS >2010-01-11 14:18:57.125 DEBUG [main] -
> Found entry: SYBEDU1_BS >2010-01-11 14:18:57.125 DEBUG
> [main] - Found entry: SYBEDU1_JSAGENT >2010-01-11
> 14:18:57.125 DEBUG [main] - Entering isLDAPFileModified
> >2010-01-11 14:18:57.125 DEBUG [main] - Using file from
> property: >2010-01-11 14:18:57.125 FATAL [main] - A
> NullPointer was encountered:
> >java.lang.NullPointerException >
> >Is there anyone who can tell why am I getting this error?
> >
> >Thanks.
> >
> >
>