Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

second report of composite not printing more than one page

3 posts in DataWindow Last posting was on 2010-01-13 18:19:25.0Z
j Posted on 2010-01-12 21:34:04.0Z
Sender: 59a3.4b4ce9b9.1804289383@sybase.com
From: J
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: second report of composite not printing more than one page
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4b4ceacc.59cd.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 12 Jan 2010 13:34:04 -0800
X-Trace: forums-1-dub 1263332044 10.22.241.41 (12 Jan 2010 13:34:04 -0800)
X-Original-Trace: 12 Jan 2010 13:34:04 -0800, 10.22.241.41
Lines: 16
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90576
Article PK: 410182

I have a composite report that has a header report and a
detail report. It's generic and is used in several places.
In the code, a datawindow object (crosstab if that matters)
is assigned to the detail nested report. (The header is also
assigned a datawindow object)

If I retrieve the datawindow object in question (just the
detail data) and print it via the IDE, it prints as many
pages as it needs.

But when the above composite report is used, it only prints
the first page of the detail. I can't figure out where the
SNAFU is...

Any help appreciated!
Thanks


j Posted on 2010-01-12 21:36:36.0Z
Sender: 59a3.4b4ce9b9.1804289383@sybase.com
From: J
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: PB 10.5 and MSSSQL Server 2005
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4b4ceb64.59da.1681692777@sybase.com>
References: <4b4ceacc.59cd.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 12 Jan 2010 13:36:36 -0800
X-Trace: forums-1-dub 1263332196 10.22.241.41 (12 Jan 2010 13:36:36 -0800)
X-Original-Trace: 12 Jan 2010 13:36:36 -0800, 10.22.241.41
Lines: 2
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90577
Article PK: 410181

Sorry, forgot release of PB etc...see above.


j Posted on 2010-01-13 18:19:25.0Z
Sender: 59e9.4b4cec0f.1804289383@sybase.com
From: J
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: second report of composite not printing more than one page
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4b4e0ead.249.1681692777@sybase.com>
References: <4b4ceacc.59cd.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 13 Jan 2010 10:19:25 -0800
X-Trace: forums-1-dub 1263406765 10.22.241.41 (13 Jan 2010 10:19:25 -0800)
X-Original-Trace: 13 Jan 2010 10:19:25 -0800, 10.22.241.41
Lines: 3
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90581
Article PK: 410186

Seems like the old object was corrupted somehow. I was able
to create a new duplicate report and it seems to work just
fine with the existing code...strange...