Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Winform Target "Deploy Failed"

3 posts in .NET Winform Last posting was on 2010-05-27 10:36:57.0Z
Ben Dodds Posted on 2010-01-19 21:27:03.0Z
Reply-To: "Ben Dodds" <kaboomer13@gmail.com>
From: "Ben Dodds" <kaboomer13@gmail.com>
Newsgroups: sybase.public.powerbuilder.net.winform
Subject: Winform Target "Deploy Failed"
Lines: 63
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b5623a7$1@forums-1-dub>
Date: 19 Jan 2010 13:27:03 -0800
X-Trace: forums-1-dub 1263936423 10.22.241.152 (19 Jan 2010 13:27:03 -0800)
X-Original-Trace: 19 Jan 2010 13:27:03 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.net.winform:922
Article PK: 707657

Hi, I am new to Powerbuilder, and I wish to complie to a .NET winform
target. I have created a new workspace, and new project from template and
and new winform target just as many tutorials have instructed me, however,
when I click "Deploy" on the winform target I get "Deploy Failed" and this
is my DeployLog.txt file:


----------------Begin File DeployLog.txt--------------------------
C:\Documents and Settings\ben.dodds\Desktop\SheriffTest\pbBC9.tmp>csc
Microsoft (R) Visual C# 2005 Compiler version 8.00.50727.3053
for Microsoft (R) Windows (R) 2005 Framework version 2.0.50727
Copyright (C) Microsoft Corporation 2001-2005. All rights reserved.

fatal error CS2008: No inputs specified

C:\Documents and Settings\ben.dodds\Desktop\SheriffTest\pbBC9.tmp>if
errorlevel 9009 exit 3

C:\Documents and
Settings\ben.dodds\Desktop\SheriffTest\pbBC9.tmp>"C:\Program
Files\Sybase\PowerBuilder 11.0\DotNET\bin\pb2cs" @"projectinfo.txt"
'"C:\Program Files\Sybase\PowerBuilder 11.0\DotNET\bin\pb2cs"' is not
recognized as an internal or external command,
operable program or batch file.

C:\Documents and Settings\ben.dodds\Desktop\SheriffTest\pbBC9.tmp>if
ERRORLEVEL 1 exit 1
----------------End File DeployLog.txt--------------------------


I have found that there are others that have had this problem, but there
have been no solutions posted. What I see in this file is the csc (C-Sharp
compiler) being invoke with no arguments, and behold, it complains. I have
tested my c# compiler, and it runs, so I know I have the Microsoft.NET 2.0
SDK installed (csc -? confirms this as well) I have also check and I did
set the path variable to inlclude the SDK's bin directory correctly. I am
running PowerBuilder 11.0.6525 on Windowx XP Professional. If it is any
help, here is the output I get when I deply the winform target:


-------------------------Begin
Output---------------------------------------------
---------- Deploy: Deploy of target genapp_winform
--------- Deploying project p_genapp_winform
Checking project settings...
Project is being deployed to output path: C:\Documents and
Settings\ben.dodds\Desktop\SheriffTest\genapp_winform_WinformOutput
Generating PBD files...
Copying PBD files to output path: C:\Documents and
Settings\ben.dodds\Desktop\SheriffTest\genapp_winform_WinformOutput
Generating .NET assembly file ...
Deploy failed.
---------- Finished Deploy of target genapp_winform (2:02:53 PM)
-------------------------End
Output---------------------------------------------

Any insite will be very much appresiated.

Thank You,
Benjamin Dodds,
Edmonton, Alberta, Canada


Ben Dodds Posted on 2010-02-16 18:12:31.0Z
Reply-To: "Ben Dodds" <kaboomer13@gmail.com>
From: "Ben Dodds" <kaboomer13@gmail.com>
Newsgroups: sybase.public.powerbuilder.net.winform
References: <4b5623a7$1@forums-1-dub>
Subject: Re: Winform Target "Deploy Failed"
Lines: 78
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b7ae00f$1@forums-1-dub>
Date: 16 Feb 2010 10:12:31 -0800
X-Trace: forums-1-dub 1266343951 10.22.241.152 (16 Feb 2010 10:12:31 -0800)
X-Original-Trace: 16 Feb 2010 10:12:31 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.net.winform:931
Article PK: 707658

Hi Guys, I eventually figured out the solution to this problem. I found
that I had not installed the neccessary .NET stuff on installing PB, and
there were Assemblies in the GAC that were not there that needed to be. The
"fatal error CS2008: No inputs specified" still appears in the successful
deploy log, so I am guessing that PB is just checking to see if csc is
there. The solution, then, is to make sure you install the dependencies
correctly, and that the needed assemblies are in the GAC.

Ben

"Ben Dodds" <kaboomer13@gmail.com> wrote in message
news:4b5623a7$1@forums-1-dub...
> Hi, I am new to Powerbuilder, and I wish to complie to a .NET winform
> target. I have created a new workspace, and new project from template and
> and new winform target just as many tutorials have instructed me, however,
> when I click "Deploy" on the winform target I get "Deploy Failed" and this
> is my DeployLog.txt file:
>
>
> ----------------Begin File DeployLog.txt--------------------------
> C:\Documents and Settings\ben.dodds\Desktop\SheriffTest\pbBC9.tmp>csc
> Microsoft (R) Visual C# 2005 Compiler version 8.00.50727.3053
> for Microsoft (R) Windows (R) 2005 Framework version 2.0.50727
> Copyright (C) Microsoft Corporation 2001-2005. All rights reserved.
>
> fatal error CS2008: No inputs specified
>
> C:\Documents and Settings\ben.dodds\Desktop\SheriffTest\pbBC9.tmp>if
> errorlevel 9009 exit 3
>
> C:\Documents and
> Settings\ben.dodds\Desktop\SheriffTest\pbBC9.tmp>"C:\Program
> Files\Sybase\PowerBuilder 11.0\DotNET\bin\pb2cs" @"projectinfo.txt"
> '"C:\Program Files\Sybase\PowerBuilder 11.0\DotNET\bin\pb2cs"' is not
> recognized as an internal or external command,
> operable program or batch file.
>
> C:\Documents and Settings\ben.dodds\Desktop\SheriffTest\pbBC9.tmp>if
> ERRORLEVEL 1 exit 1
> ----------------End File DeployLog.txt--------------------------
>
>
> I have found that there are others that have had this problem, but there
> have been no solutions posted. What I see in this file is the csc
> (C-Sharp compiler) being invoke with no arguments, and behold, it
> complains. I have tested my c# compiler, and it runs, so I know I have
> the Microsoft.NET 2.0 SDK installed (csc -? confirms this as well) I have
> also check and I did set the path variable to inlclude the SDK's bin
> directory correctly. I am running PowerBuilder 11.0.6525 on Windowx XP
> Professional. If it is any help, here is the output I get when I deply
> the winform target:
>
>
> -------------------------Begin
> Output---------------------------------------------
> ---------- Deploy: Deploy of target genapp_winform
> --------- Deploying project p_genapp_winform
> Checking project settings...
> Project is being deployed to output path: C:\Documents and
> Settings\ben.dodds\Desktop\SheriffTest\genapp_winform_WinformOutput
> Generating PBD files...
> Copying PBD files to output path: C:\Documents and
> Settings\ben.dodds\Desktop\SheriffTest\genapp_winform_WinformOutput
> Generating .NET assembly file ...
> Deploy failed.
> ---------- Finished Deploy of target genapp_winform (2:02:53 PM)
> -------------------------End
> Output---------------------------------------------
>
> Any insite will be very much appresiated.
>
> Thank You,
> Benjamin Dodds,
> Edmonton, Alberta, Canada
>


Tech Posted on 2010-05-27 10:36:57.0Z
From: "Tech" <kalpana_t@rediffmail.com>
Newsgroups: sybase.public.powerbuilder.net.winform
Organization: 59.160.193.34
References: <4b5623a7$1@forums-1-dub>
X-Newsreader: AspNNTP 1.50 (JodoHost)
Subject: Re: Winform Target "Deploy Failed"
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4bfe4b49$1@forums-1-dub>
Date: 27 May 2010 03:36:57 -0700
X-Trace: forums-1-dub 1274956617 10.22.241.152 (27 May 2010 03:36:57 -0700)
X-Original-Trace: 27 May 2010 03:36:57 -0700, vip152.sybase.com
Lines: 76
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.net.winform:949
Article PK: 707683

Hi Ben,
Could you tell what are the .Net assemblies required by PB to make a call to
.Net Library (framework 2.0).

We are facing same problem. Unable to find solutions in other blogs. I did know
that it could be todo with other missing libraries, but unsure of what they are.

Thanks in advance,
Tech

On 19 Jan 2010 13:27:03 -0800,
in sybase.public.powerbuilder.net.winform

Ben Dodds <kaboomer13@gmail.com> wrote:
>Hi, I am new to Powerbuilder, and I wish to complie to a .NET winform
>target. I have created a new workspace, and new project from template and
>and new winform target just as many tutorials have instructed me, however,
>when I click "Deploy" on the winform target I get "Deploy Failed" and this
>is my DeployLog.txt file:
>
>
>----------------Begin File DeployLog.txt--------------------------
>C:\Documents and Settings\ben.dodds\Desktop\SheriffTest\pbBC9.tmp>csc
>Microsoft (R) Visual C# 2005 Compiler version 8.00.50727.3053
>for Microsoft (R) Windows (R) 2005 Framework version 2.0.50727
>Copyright (C) Microsoft Corporation 2001-2005. All rights reserved.
>
>fatal error CS2008: No inputs specified
>
>C:\Documents and Settings\ben.dodds\Desktop\SheriffTest\pbBC9.tmp>if
>errorlevel 9009 exit 3
>
>C:\Documents and
>Settings\ben.dodds\Desktop\SheriffTest\pbBC9.tmp>"C:\Program
>Files\Sybase\PowerBuilder 11.0\DotNET\bin\pb2cs" @"projectinfo.txt"
>'"C:\Program Files\Sybase\PowerBuilder 11.0\DotNET\bin\pb2cs"' is not
>recognized as an internal or external command,
>operable program or batch file.
>
>C:\Documents and Settings\ben.dodds\Desktop\SheriffTest\pbBC9.tmp>if
>ERRORLEVEL 1 exit 1
>----------------End File DeployLog.txt--------------------------
>
>
>I have found that there are others that have had this problem, but there
>have been no solutions posted. What I see in this file is the csc (C-Sharp
>compiler) being invoke with no arguments, and behold, it complains. I have
>tested my c# compiler, and it runs, so I know I have the Microsoft.NET 2.0
>SDK installed (csc -? confirms this as well) I have also check and I did
>set the path variable to inlclude the SDK's bin directory correctly. I am
>running PowerBuilder 11.0.6525 on Windowx XP Professional. If it is any
>help, here is the output I get when I deply the winform target:
>
>
>-------------------------Begin
>Output---------------------------------------------
> ---------- Deploy: Deploy of target genapp_winform
> --------- Deploying project p_genapp_winform
>Checking project settings...
>Project is being deployed to output path: C:\Documents and
>Settings\ben.dodds\Desktop\SheriffTest\genapp_winform_WinformOutput
>Generating PBD files...
>Copying PBD files to output path: C:\Documents and
>Settings\ben.dodds\Desktop\SheriffTest\genapp_winform_WinformOutput
>Generating .NET assembly file ...
>Deploy failed.
> ---------- Finished Deploy of target genapp_winform (2:02:53 PM)
>-------------------------End
>Output---------------------------------------------
>
>Any insite will be very much appresiated.
>
>Thank You,
>Benjamin Dodds,
>Edmonton, Alberta, Canada
>
>