Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Upgrade from 15.0.3 to 15.5 question

9 posts in General Discussion Last posting was on 2010-01-28 14:59:24.0Z
lnielsen Posted on 2010-01-20 20:26:51.0Z
Sender: 60d5.4b576589.1804289383@sybase.com
From: LNielsen
Newsgroups: sybase.public.ase.general
Subject: Upgrade from 15.0.3 to 15.5 question
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4b57670b.6103.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 20 Jan 2010 12:26:51 -0800
X-Trace: forums-1-dub 1264019211 10.22.241.41 (20 Jan 2010 12:26:51 -0800)
X-Original-Trace: 20 Jan 2010 12:26:51 -0800, 10.22.241.41
Lines: 5
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28899
Article PK: 78141

I am doing a upgrade from ASE 15.0.3 to ASE15.5. Do I just
shutdown the server, run the runInstaller in the same
directory as ASE 15.0.3, and then startup the server?

It seems too easy.


Rob V [ Sybase ] Posted on 2010-01-20 22:55:18.0Z
Reply-To: "Rob V [ Sybase ]" <robv@DO.NOT.SPAM.sypron.nl.REMOVE.THIS.DECOY>
From: "Rob V [ Sybase ]" <robv@DO.NOT.SPAM.sypron.nl.REMOVE.THIS.DECOY>
Newsgroups: sybase.public.ase.general
References: <4b57670b.6103.1681692777@sybase.com>
Subject: Re: Upgrade from 15.0.3 to 15.5 question
Lines: 35
Organization: Sypron BV / TeamSybase / Sybase
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b5789d6$1@forums-1-dub>
Date: 20 Jan 2010 14:55:18 -0800
X-Trace: forums-1-dub 1264028118 10.22.241.152 (20 Jan 2010 14:55:18 -0800)
X-Original-Trace: 20 Jan 2010 14:55:18 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28900
Article PK: 78143

Yes, that should basically be enough. Moving from 15.0.3 -> 15.5 is not a
major upgrade as from 12.5->15. Upgrading from 15.0.2 to 15.5 is very
similar to upgrading from 15.0.2 to 15.0.3.
Make sure the scripts (installmaster etc) have been loaded in 15.5 -- check
with sp_version.

HTH,

Rob V.
-----------------------------------------------------------------
Rob Verschoor

Certified Sybase Professional DBA for ASE 15.0/12.5/12.0/11.5/11.0
and Replication Server 15.0.1/12.5 // TeamSybase

Author of Sybase books (order online at www.sypron.nl/shop):
"Tips, Tricks & Recipes for Sybase ASE" (ASE 15 edition)
"The Complete Sybase ASE Quick Reference Guide"
"The Complete Sybase Replication Server Quick Reference Guide"

mailto:rob@YOUR.SPAM.sypron.nl.NOT.FOR.ME
http://www.sypron.nl
Sypron B.V., Amersfoort, The Netherlands
Chamber of Commerce 27138666
-----------------------------------------------------------------

<LNielsen> wrote in message news:4b57670b.6103.1681692777@sybase.com...
>I am doing a upgrade from ASE 15.0.3 to ASE15.5. Do I just
> shutdown the server, run the runInstaller in the same
> directory as ASE 15.0.3, and then startup the server?
>
> It seems too easy.


Cory Sane [TeamSybase] Posted on 2010-01-22 02:56:14.0Z
From: "Cory Sane [TeamSybase]" <cory!=sane>
Newsgroups: sybase.public.ase.general
References: <4b57670b.6103.1681692777@sybase.com> <4b5789d6$1@forums-1-dub>
In-Reply-To: <4b5789d6$1@forums-1-dub>
Subject: Re: Upgrade from 15.0.3 to 15.5 question
Lines: 44
MIME-Version: 1.0
Content-Type: text/plain; format=flowed; charset="iso-8859-1"; reply-type=response
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Windows Mail 6.0.6002.18005
X-MimeOLE: Produced By Microsoft MimeOLE V6.0.6002.18005
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b5913ce$1@forums-1-dub>
Date: 21 Jan 2010 18:56:14 -0800
X-Trace: forums-1-dub 1264128974 10.22.241.152 (21 Jan 2010 18:56:14 -0800)
X-Original-Trace: 21 Jan 2010 18:56:14 -0800, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28902
Article PK: 78142

Rob,
Do you need a new license for sysam?
I tried last week and the server failed due to sysam errors.

--
Cory Sane
[TeamSybase]
Certified Sybase Associate DBA for ASE 15.0

"Rob V [ Sybase ]" <robv@DO.NOT.SPAM.sypron.nl.REMOVE.THIS.DECOY> wrote in message news:4b5789d6$1@forums-1-dub...
> Yes, that should basically be enough. Moving from 15.0.3 -> 15.5 is not a
> major upgrade as from 12.5->15. Upgrading from 15.0.2 to 15.5 is very
> similar to upgrading from 15.0.2 to 15.0.3.
> Make sure the scripts (installmaster etc) have been loaded in 15.5 -- check
> with sp_version.
>
> HTH,
>
> Rob V.
> -----------------------------------------------------------------
> Rob Verschoor
>
> Certified Sybase Professional DBA for ASE 15.0/12.5/12.0/11.5/11.0
> and Replication Server 15.0.1/12.5 // TeamSybase
>
> Author of Sybase books (order online at www.sypron.nl/shop):
> "Tips, Tricks & Recipes for Sybase ASE" (ASE 15 edition)
> "The Complete Sybase ASE Quick Reference Guide"
> "The Complete Sybase Replication Server Quick Reference Guide"
>
> mailto:rob@YOUR.SPAM.sypron.nl.NOT.FOR.ME
> http://www.sypron.nl
> Sypron B.V., Amersfoort, The Netherlands
> Chamber of Commerce 27138666
> -----------------------------------------------------------------
>
> <LNielsen> wrote in message news:4b57670b.6103.1681692777@sybase.com...
>>I am doing a upgrade from ASE 15.0.3 to ASE15.5. Do I just
>> shutdown the server, run the runInstaller in the same
>> directory as ASE 15.0.3, and then startup the server?
>>
>> It seems too easy.
>
>
>


Rob V [ Sybase ] Posted on 2010-01-22 14:51:53.0Z
Reply-To: "Rob V [ Sybase ]" <robv@DO.NOT.SPAM.sypron.nl.REMOVE.THIS.DECOY>
From: "Rob V [ Sybase ]" <robv@DO.NOT.SPAM.sypron.nl.REMOVE.THIS.DECOY>
Newsgroups: sybase.public.ase.general
References: <4b57670b.6103.1681692777@sybase.com> <4b5789d6$1@forums-1-dub> <4b5913ce$1@forums-1-dub>
Subject: Re: Upgrade from 15.0.3 to 15.5 question
Lines: 54
Organization: Sypron BV / TeamSybase / Sybase
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b59bb89$1@forums-1-dub>
Date: 22 Jan 2010 06:51:53 -0800
X-Trace: forums-1-dub 1264171913 10.22.241.152 (22 Jan 2010 06:51:53 -0800)
X-Original-Trace: 22 Jan 2010 06:51:53 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28904
Article PK: 78147

Not that I know....

R.

"Cory Sane [TeamSybase]" <cory!=sane> wrote in message
news:4b5913ce$1@forums-1-dub...
> Rob,
> Do you need a new license for sysam?
> I tried last week and the server failed due to sysam errors.
>
> --
> Cory Sane
> [TeamSybase]
> Certified Sybase Associate DBA for ASE 15.0
> "Rob V [ Sybase ]" <robv@DO.NOT.SPAM.sypron.nl.REMOVE.THIS.DECOY> wrote in
> message news:4b5789d6$1@forums-1-dub...
>> Yes, that should basically be enough. Moving from 15.0.3 -> 15.5 is not a
>> major upgrade as from 12.5->15. Upgrading from 15.0.2 to 15.5 is very
>> similar to upgrading from 15.0.2 to 15.0.3.
>> Make sure the scripts (installmaster etc) have been loaded in 15.5 --
>> check
>> with sp_version.
>>
>> HTH,
>>
>> Rob V.
>> -----------------------------------------------------------------
>> Rob Verschoor
>>
>> Certified Sybase Professional DBA for ASE 15.0/12.5/12.0/11.5/11.0
>> and Replication Server 15.0.1/12.5 // TeamSybase
>>
>> Author of Sybase books (order online at www.sypron.nl/shop):
>> "Tips, Tricks & Recipes for Sybase ASE" (ASE 15 edition)
>> "The Complete Sybase ASE Quick Reference Guide"
>> "The Complete Sybase Replication Server Quick Reference Guide"
>>
>> mailto:rob@YOUR.SPAM.sypron.nl.NOT.FOR.ME
>> http://www.sypron.nl
>> Sypron B.V., Amersfoort, The Netherlands
>> Chamber of Commerce 27138666
>> -----------------------------------------------------------------
>>
>> <LNielsen> wrote in message news:4b57670b.6103.1681692777@sybase.com...
>>>I am doing a upgrade from ASE 15.0.3 to ASE15.5. Do I just
>>> shutdown the server, run the runInstaller in the same
>>> directory as ASE 15.0.3, and then startup the server?
>>>
>>> It seems too easy.
>>
>>


Wildthing Posted on 2010-01-25 11:20:34.0Z
Message-ID: <4B5D7E80.6000207@wassup.f9.co.uk>
From: Wildthing <wildthing@wassup.f9.co.uk>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
To: "Rob V [ Sybase ]" <robv@DO.NOT.SPAM.sypron.nl.REMOVE.THIS.DECOY>
Subject: Re: Upgrade from 15.0.3 to 15.5 question
References: <4b57670b.6103.1681692777@sybase.com> <4b5789d6$1@forums-1-dub> <4b5913ce$1@forums-1-dub> <4b59bb89$1@forums-1-dub>
In-Reply-To: <4b59bb89$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 25 Jan 2010 03:20:34 -0800
X-Trace: forums-1-dub 1264418434 10.22.241.152 (25 Jan 2010 03:20:34 -0800)
X-Original-Trace: 25 Jan 2010 03:20:34 -0800, vip152.sybase.com
Lines: 74
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28906
Article PK: 78148

If it helps I just did the same thing this weekend and have the
following issues:
If you're in a 64bit linux environment - make sure the LD_LIBRARY_PATH
points to $SYBASE/$SYBASE_OCS/lib3p64 - you get library errors on start
up without it. Wasn't an issue in 15.0.3.

LIKE operator not operating as it should eg WHERE Name LIKE "FRED%"
would pull "Fred Bloggs" but not "Fred". However Name like "FRE%" would
pull "Fred". Sybase looking into this at mo. Be aware. Anyone else with
any ideas would be helpful though.

We had some legacy 11.9.2 code that had "DATENAME(cdw,<datevalue>)"
always comes back as "Monday" - this worked fine in 15.0.3. Need to use
dw not cdw. Btw cdw still a type in DATEPART.

If I come across anything else I'll post.

Also

On 22/01/2010 14:51, Rob V [ Sybase ] wrote:
> Not that I know....
>
> R.
>
>
>
> "Cory Sane [TeamSybase]"<cory!=sane> wrote in message
> news:4b5913ce$1@forums-1-dub...
>> Rob,
>> Do you need a new license for sysam?
>> I tried last week and the server failed due to sysam errors.
>>
>> --
>> Cory Sane
>> [TeamSybase]
>> Certified Sybase Associate DBA for ASE 15.0
>> "Rob V [ Sybase ]"<robv@DO.NOT.SPAM.sypron.nl.REMOVE.THIS.DECOY> wrote in
>> message news:4b5789d6$1@forums-1-dub...
>>> Yes, that should basically be enough. Moving from 15.0.3 -> 15.5 is not a
>>> major upgrade as from 12.5->15. Upgrading from 15.0.2 to 15.5 is very
>>> similar to upgrading from 15.0.2 to 15.0.3.
>>> Make sure the scripts (installmaster etc) have been loaded in 15.5 --
>>> check
>>> with sp_version.
>>>
>>> HTH,
>>>
>>> Rob V.
>>> -----------------------------------------------------------------
>>> Rob Verschoor
>>>
>>> Certified Sybase Professional DBA for ASE 15.0/12.5/12.0/11.5/11.0
>>> and Replication Server 15.0.1/12.5 // TeamSybase
>>>
>>> Author of Sybase books (order online at www.sypron.nl/shop):
>>> "Tips, Tricks& Recipes for Sybase ASE" (ASE 15 edition)
>>> "The Complete Sybase ASE Quick Reference Guide"
>>> "The Complete Sybase Replication Server Quick Reference Guide"
>>>
>>> mailto:rob@YOUR.SPAM.sypron.nl.NOT.FOR.ME
>>> http://www.sypron.nl
>>> Sypron B.V., Amersfoort, The Netherlands
>>> Chamber of Commerce 27138666
>>> -----------------------------------------------------------------
>>>
>>> <LNielsen> wrote in message news:4b57670b.6103.1681692777@sybase.com...
>>>> I am doing a upgrade from ASE 15.0.3 to ASE15.5. Do I just
>>>> shutdown the server, run the runInstaller in the same
>>>> directory as ASE 15.0.3, and then startup the server?
>>>>
>>>> It seems too easy.
>>>
>>>
>


Bret Halford Posted on 2010-01-25 22:53:02.0Z
From: Bret Halford <bret@sybase.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: Upgrade from 15.0.3 to 15.5 question
References: <4b57670b.6103.1681692777@sybase.com> <4b5789d6$1@forums-1-dub> <4b5913ce$1@forums-1-dub> <4b59bb89$1@forums-1-dub> <4B5D7E80.6000207@wassup.f9.co.uk>
In-Reply-To: <4B5D7E80.6000207@wassup.f9.co.uk>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b5e20ce$1@forums-1-dub>
Date: 25 Jan 2010 14:53:02 -0800
X-Trace: forums-1-dub 1264459982 10.22.241.152 (25 Jan 2010 14:53:02 -0800)
X-Original-Trace: 25 Jan 2010 14:53:02 -0800, vip152.sybase.com
Lines: 17
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28907
Article PK: 78149


On 1/25/2010 4:20 AM, Wildthing wrote:

> LIKE operator not operating as it should eg WHERE Name LIKE "FRED%"
> would pull "Fred Bloggs" but not "Fred". However Name like "FRE%" would
> pull "Fred". Sybase looking into this at mo. Be aware. Anyone else with
> any ideas would be helpful though.

A few more details on this:

this issue seems to be only on case-insensitive sort orders.
however, the issue doesn't seem to be case sensitivity but that
the % wildcard isn't working properly as a match to 0 characters,
i.e., it doesn't match the end of string.

So Like "FRED%" returns "Fred." or "FRED." but not "Fred" or "FRED"

CR is 616224 (with 615102 marked as a duplicate)


Wildthing Posted on 2010-01-26 17:48:55.0Z
From: Wildthing <wildthing1968@gmail.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: Upgrade from 15.0.3 to 15.5 question
References: <4b57670b.6103.1681692777@sybase.com> <4b5789d6$1@forums-1-dub> <4b5913ce$1@forums-1-dub> <4b59bb89$1@forums-1-dub> <4B5D7E80.6000207@wassup.f9.co.uk> <4b5e20ce$1@forums-1-dub>
In-Reply-To: <4b5e20ce$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b5f2b07$1@forums-1-dub>
Date: 26 Jan 2010 09:48:55 -0800
X-Trace: forums-1-dub 1264528135 10.22.241.152 (26 Jan 2010 09:48:55 -0800)
X-Original-Trace: 26 Jan 2010 09:48:55 -0800, vip152.sybase.com
Lines: 25
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28908
Article PK: 78153


On 25/01/2010 22:53, Bret Halford wrote:
> On 1/25/2010 4:20 AM, Wildthing wrote:
>
>> LIKE operator not operating as it should eg WHERE Name LIKE "FRED%"
>> would pull "Fred Bloggs" but not "Fred". However Name like "FRE%" would
>> pull "Fred". Sybase looking into this at mo. Be aware. Anyone else with
>> any ideas would be helpful though.
>
> A few more details on this:
>
> this issue seems to be only on case-insensitive sort orders.
> however, the issue doesn't seem to be case sensitivity but that
> the % wildcard isn't working properly as a match to 0 characters,
> i.e., it doesn't match the end of string.
>
> So Like "FRED%" returns "Fred." or "FRED." but not "Fred" or "FRED"
>
> CR is 616224 (with 615102 marked as a duplicate)

If anyone else has the same issue use a PATINDEX instead - but dont use
PATINDEX("%",<VARCHAR>) - it won't work - Use PATINDEX("_%",<VARCHAR>)
instead.

I think the Sybase testing department get a big "F" on this one and owe
me a beer for the grief they've put me through. :)


Wildthing Posted on 2010-01-28 14:59:24.0Z
From: Wildthing <wildthing1968@gmail.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: Upgrade from 15.0.3 to 15.5 question
References: <4b57670b.6103.1681692777@sybase.com> <4b5789d6$1@forums-1-dub> <4b5913ce$1@forums-1-dub> <4b59bb89$1@forums-1-dub> <4B5D7E80.6000207@wassup.f9.co.uk> <4b5e20ce$1@forums-1-dub> <4b5f2b07$1@forums-1-dub>
In-Reply-To: <4b5f2b07$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b61a64c$1@forums-1-dub>
Date: 28 Jan 2010 06:59:24 -0800
X-Trace: forums-1-dub 1264690764 10.22.241.152 (28 Jan 2010 06:59:24 -0800)
X-Original-Trace: 28 Jan 2010 06:59:24 -0800, vip152.sybase.com
Lines: 32
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28913
Article PK: 78155


On 26/01/2010 17:48, Wildthing wrote:
> On 25/01/2010 22:53, Bret Halford wrote:
>> On 1/25/2010 4:20 AM, Wildthing wrote:
>>
>>> LIKE operator not operating as it should eg WHERE Name LIKE "FRED%"
>>> would pull "Fred Bloggs" but not "Fred". However Name like "FRE%" would
>>> pull "Fred". Sybase looking into this at mo. Be aware. Anyone else with
>>> any ideas would be helpful though.
>>
>> A few more details on this:
>>
>> this issue seems to be only on case-insensitive sort orders.
>> however, the issue doesn't seem to be case sensitivity but that
>> the % wildcard isn't working properly as a match to 0 characters,
>> i.e., it doesn't match the end of string.
>>
>> So Like "FRED%" returns "Fred." or "FRED." but not "Fred" or "FRED"
>>
>> CR is 616224 (with 615102 marked as a duplicate)
>
> If anyone else has the same issue use a PATINDEX instead - but dont use
> PATINDEX("%",<VARCHAR>) - it won't work - Use PATINDEX("_%",<VARCHAR>)
> instead.
>
> I think the Sybase testing department get a big "F" on this one and owe
> me a beer for the grief they've put me through. :)

Sybase Support and Engineering depts get "A+" though.

:D


syb_dba Posted on 2010-01-20 23:20:38.0Z
Sender: 6575.4b578ef4.1804289383@sybase.com
From: syb_dba
Newsgroups: sybase.public.ase.general
Subject: Re: Upgrade from 15.0.3 to 15.5 question
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4b578fc6.6591.1681692777@sybase.com>
References: <4b57670b.6103.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 20 Jan 2010 15:20:38 -0800
X-Trace: forums-1-dub 1264029638 10.22.241.41 (20 Jan 2010 15:20:38 -0800)
X-Original-Trace: 20 Jan 2010 15:20:38 -0800, 10.22.241.41
Lines: 9
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28901
Article PK: 78144

If you receive compilation errors similar to the following,
then i would recommend running dbcc upgrade_object in each
of the databases:

"execution of procedure ProcName failed because of errors
parsing the source text in syscomments during upgrade."

We ran into some of these errors when upgrading from 15.0.2
to 15.0.3. Might apply to the upgrade to 15.5 also