Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Creating a linked Sybase ASE 12.5.3 server in MS SQL Server 2005....

5 posts in General Discussion Last posting was on 2010-02-05 15:04:32.0Z
Matthew P. Seltzer Posted on 2010-02-03 20:42:41.0Z
Reply-To: "Matthew P. Seltzer" <mseltzer@fideliscare.org>
From: "Matthew P. Seltzer" <mseltzer@fideliscare.org>
Newsgroups: sybase.public.ase.general
Subject: Creating a linked Sybase ASE 12.5.3 server in MS SQL Server 2005....
Lines: 20
Organization: Fidelis Care New York
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b69dfc1$1@forums-1-dub>
Date: 3 Feb 2010 12:42:41 -0800
X-Trace: forums-1-dub 1265229761 10.22.241.152 (3 Feb 2010 12:42:41 -0800)
X-Original-Trace: 3 Feb 2010 12:42:41 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28941
Article PK: 78183

All--
Am curious if anyone has been able to do this without getting an arcane
OLE DB interface error:

Cannot obtain the required interface "IID_IDBSchemaRowSet" from OLEDB
provider "ASEOLEDB" for linked server "<our server name>". Microsoft SQL
Server, Error: 7399.

I have been reading Wayne Smith's white paper, "Configuring Microsoft SQL
Server 2005 'Linked Server' with Sybase Organic OLE DB Provider" for
pointers, but, no luck so far. Despite the error message, I have a feeling
that the error I am getting is occurring on the Sybase side (the various
OLEDB-related stored procedures in sybsystemprocs may be out of date). If
you care to share your experiences with this, please do, as I am stuck.

TIA,

Matt in NYC


"Mark A. Parsons" <iron_horse Posted on 2010-02-03 20:54:55.0Z
From: "Mark A. Parsons" <iron_horse@no_spamola.compuserve.com>
User-Agent: Thunderbird 1.5.0.10 (Windows/20070221)
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: Creating a linked Sybase ASE 12.5.3 server in MS SQL Server 2005....
References: <4b69dfc1$1@forums-1-dub>
In-Reply-To: <4b69dfc1$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Antivirus: avast! (VPS 100126-1, 01/26/2010), Outbound message
X-Antivirus-Status: Clean
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b69e29f$1@forums-1-dub>
Date: 3 Feb 2010 12:54:55 -0800
X-Trace: forums-1-dub 1265230495 10.22.241.152 (3 Feb 2010 12:54:55 -0800)
X-Original-Trace: 3 Feb 2010 12:54:55 -0800, vip152.sybase.com
Lines: 34
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28942
Article PK: 78180

Sorry, no comments/suggestions on linked servers ...

As for your comment about OLEDB procs (possibly) being out of date ...

Have you asked your DBA to check the version of OLEDB procs in use? (sp_version)

I'm not near an ASE 12.x datasever, but for ASE 15.x there are several SQL scripts in the $SYBASE/DataAccess/sp for
installing the OLEDB procs.

The script names are of the form "oledb_mda_<ASEversion>.sql" ... should be easy enough for the DBA to load the file
that corresponds to the ASE version.

Matthew P. Seltzer wrote:
> All--
> Am curious if anyone has been able to do this without getting an arcane
> OLE DB interface error:
>
> Cannot obtain the required interface "IID_IDBSchemaRowSet" from OLEDB
> provider "ASEOLEDB" for linked server "<our server name>". Microsoft SQL
> Server, Error: 7399.
>
> I have been reading Wayne Smith's white paper, "Configuring Microsoft SQL
> Server 2005 'Linked Server' with Sybase Organic OLE DB Provider" for
> pointers, but, no luck so far. Despite the error message, I have a feeling
> that the error I am getting is occurring on the Sybase side (the various
> OLEDB-related stored procedures in sybsystemprocs may be out of date). If
> you care to share your experiences with this, please do, as I am stuck.
>
> TIA,
>
> Matt in NYC
>
>


Matthew P. Seltzer Posted on 2010-02-03 20:59:20.0Z
Reply-To: "Matthew P. Seltzer" <mseltzer@fideliscare.org>
From: "Matthew P. Seltzer" <mseltzer@fideliscare.org>
Newsgroups: sybase.public.ase.general
References: <4b69dfc1$1@forums-1-dub> <4b69e29f$1@forums-1-dub>
Subject: Re: Creating a linked Sybase ASE 12.5.3 server in MS SQL Server 2005....
Lines: 45
Organization: Fidelis Care New York
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b69e3a8$1@forums-1-dub>
Date: 3 Feb 2010 12:59:20 -0800
X-Trace: forums-1-dub 1265230760 10.22.241.152 (3 Feb 2010 12:59:20 -0800)
X-Original-Trace: 3 Feb 2010 12:59:20 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28943
Article PK: 78181

Thanks, Mark, I've seen these scripts in the 12.5.x client subfolders.
However, I've been researching the MS SQL Server error 7399 and it appears
to be somehow security-related. My search continues, and I am going to try
to get in touch with Wayne Smith to see if he has any suggestions.

M.

"Mark A. Parsons" <iron_horse@no_spamola.compuserve.com> wrote in message
news:4b69e29f$1@forums-1-dub...
> Sorry, no comments/suggestions on linked servers ...
>
> As for your comment about OLEDB procs (possibly) being out of date ...
>
> Have you asked your DBA to check the version of OLEDB procs in use?
> (sp_version)
>
> I'm not near an ASE 12.x datasever, but for ASE 15.x there are several SQL
> scripts in the $SYBASE/DataAccess/sp for installing the OLEDB procs.
>
> The script names are of the form "oledb_mda_<ASEversion>.sql" ... should
> be easy enough for the DBA to load the file that corresponds to the ASE
> version.
>
>
> Matthew P. Seltzer wrote:
>> All--
>> Am curious if anyone has been able to do this without getting an arcane
>> OLE DB interface error:
>>
>> Cannot obtain the required interface "IID_IDBSchemaRowSet" from OLEDB
>> provider "ASEOLEDB" for linked server "<our server name>". Microsoft SQL
>> Server, Error: 7399.
>>
>> I have been reading Wayne Smith's white paper, "Configuring Microsoft
>> SQL Server 2005 'Linked Server' with Sybase Organic OLE DB Provider" for
>> pointers, but, no luck so far. Despite the error message, I have a
>> feeling that the error I am getting is occurring on the Sybase side (the
>> various OLEDB-related stored procedures in sybsystemprocs may be out of
>> date). If you care to share your experiences with this, please do, as I
>> am stuck.
>>
>> TIA,
>>
>> Matt in NYC


Matthew P. Seltzer Posted on 2010-02-03 21:18:54.0Z
Reply-To: "Matthew P. Seltzer" <mseltzer@fideliscare.org>
From: "Matthew P. Seltzer" <mseltzer@fideliscare.org>
Newsgroups: sybase.public.ase.general
References: <4b69dfc1$1@forums-1-dub> <4b69e29f$1@forums-1-dub> <4b69e3a8$1@forums-1-dub>
Subject: Re: Creating a linked Sybase ASE 12.5.3 server in MS SQL Server 2005....
Lines: 62
Organization: Fidelis Care New York
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b69e83e@forums-1-dub>
Date: 3 Feb 2010 13:18:54 -0800
X-Trace: forums-1-dub 1265231934 10.22.241.152 (3 Feb 2010 13:18:54 -0800)
X-Original-Trace: 3 Feb 2010 13:18:54 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28944
Article PK: 78185

OK, got past the error 7399. I can now see Sybase tables and views from
MSSQL 2005. When I try to query Sybase (a 'conventional' SELECT), I get this
error:

The OLE DB provider "ASEOLEDB" for linked server "FIDELIS_DEV" could not map
ordinals for one or more columns of object "DBSCHEMA_TABLES".

I see this as progress...onward!



M.

"Matthew P. Seltzer" <mseltzer@fideliscare.org> wrote in message
news:4b69e3a8$1@forums-1-dub...
> Thanks, Mark, I've seen these scripts in the 12.5.x client subfolders.
> However, I've been researching the MS SQL Server error 7399 and it appears
> to be somehow security-related. My search continues, and I am going to
> try to get in touch with Wayne Smith to see if he has any suggestions.
>
> M.
> "Mark A. Parsons" <iron_horse@no_spamola.compuserve.com> wrote in message
> news:4b69e29f$1@forums-1-dub...
>> Sorry, no comments/suggestions on linked servers ...
>>
>> As for your comment about OLEDB procs (possibly) being out of date ...
>>
>> Have you asked your DBA to check the version of OLEDB procs in use?
>> (sp_version)
>>
>> I'm not near an ASE 12.x datasever, but for ASE 15.x there are several
>> SQL scripts in the $SYBASE/DataAccess/sp for installing the OLEDB procs.
>>
>> The script names are of the form "oledb_mda_<ASEversion>.sql" ... should
>> be easy enough for the DBA to load the file that corresponds to the ASE
>> version.
>>
>>
>> Matthew P. Seltzer wrote:
>>> All--
>>> Am curious if anyone has been able to do this without getting an
>>> arcane OLE DB interface error:
>>>
>>> Cannot obtain the required interface "IID_IDBSchemaRowSet" from OLEDB
>>> provider "ASEOLEDB" for linked server "<our server name>". Microsoft
>>> SQL Server, Error: 7399.
>>>
>>> I have been reading Wayne Smith's white paper, "Configuring Microsoft
>>> SQL Server 2005 'Linked Server' with Sybase Organic OLE DB Provider" for
>>> pointers, but, no luck so far. Despite the error message, I have a
>>> feeling that the error I am getting is occurring on the Sybase side (the
>>> various OLEDB-related stored procedures in sybsystemprocs may be out of
>>> date). If you care to share your experiences with this, please do, as I
>>> am stuck.
>>>
>>> TIA,
>>>
>>> Matt in NYC
>
>


Matthew P. Seltzer Posted on 2010-02-05 15:04:32.0Z
Reply-To: "Matthew P. Seltzer" <mseltzer@fideliscare.org>
From: "Matthew P. Seltzer" <mseltzer@fideliscare.org>
Newsgroups: sybase.public.ase.general
References: <4b69dfc1$1@forums-1-dub> <4b69e29f$1@forums-1-dub> <4b69e3a8$1@forums-1-dub> <4b69e83e@forums-1-dub>
Subject: Re: Creating a linked Sybase ASE 12.5.3 server in MS SQL Server 2005....
Lines: 70
Organization: Fidelis Care New York
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b6c3380$1@forums-1-dub>
Date: 5 Feb 2010 07:04:32 -0800
X-Trace: forums-1-dub 1265382272 10.22.241.152 (5 Feb 2010 07:04:32 -0800)
X-Original-Trace: 5 Feb 2010 07:04:32 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28956
Article PK: 78196

OK, got this to work with OPENQUERY. I can get an enumeration of Sybase
tables and views, although the stored procs do not get listed in the MSSQL
2005 UI. Should I expect to see stored procs, also?

"Matthew P. Seltzer" <mseltzer@fideliscare.org> wrote in message
news:4b69e83e@forums-1-dub...
> OK, got past the error 7399. I can now see Sybase tables and views from
> MSSQL 2005. When I try to query Sybase (a 'conventional' SELECT), I get
> this error:
>
> The OLE DB provider "ASEOLEDB" for linked server "FIDELIS_DEV" could not
> map ordinals for one or more columns of object "DBSCHEMA_TABLES".
>
> I see this as progress...onward!
>
>
>
> M.
>
> "Matthew P. Seltzer" <mseltzer@fideliscare.org> wrote in message
> news:4b69e3a8$1@forums-1-dub...
>> Thanks, Mark, I've seen these scripts in the 12.5.x client subfolders.
>> However, I've been researching the MS SQL Server error 7399 and it
>> appears to be somehow security-related. My search continues, and I am
>> going to try to get in touch with Wayne Smith to see if he has any
>> suggestions.
>>
>> M.
>> "Mark A. Parsons" <iron_horse@no_spamola.compuserve.com> wrote in message
>> news:4b69e29f$1@forums-1-dub...
>>> Sorry, no comments/suggestions on linked servers ...
>>>
>>> As for your comment about OLEDB procs (possibly) being out of date ...
>>>
>>> Have you asked your DBA to check the version of OLEDB procs in use?
>>> (sp_version)
>>>
>>> I'm not near an ASE 12.x datasever, but for ASE 15.x there are several
>>> SQL scripts in the $SYBASE/DataAccess/sp for installing the OLEDB procs.
>>>
>>> The script names are of the form "oledb_mda_<ASEversion>.sql" ... should
>>> be easy enough for the DBA to load the file that corresponds to the ASE
>>> version.
>>>
>>>
>>> Matthew P. Seltzer wrote:
>>>> All--
>>>> Am curious if anyone has been able to do this without getting an
>>>> arcane OLE DB interface error:
>>>>
>>>> Cannot obtain the required interface "IID_IDBSchemaRowSet" from OLEDB
>>>> provider "ASEOLEDB" for linked server "<our server name>". Microsoft
>>>> SQL Server, Error: 7399.
>>>>
>>>> I have been reading Wayne Smith's white paper, "Configuring Microsoft
>>>> SQL Server 2005 'Linked Server' with Sybase Organic OLE DB Provider"
>>>> for pointers, but, no luck so far. Despite the error message, I have a
>>>> feeling that the error I am getting is occurring on the Sybase side
>>>> (the various OLEDB-related stored procedures in sybsystemprocs may be
>>>> out of date). If you care to share your experiences with this, please
>>>> do, as I am stuck.
>>>>
>>>> TIA,
>>>>
>>>> Matt in NYC
>>
>>
>
>