Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Showplan is Confusing

3 posts in General Discussion Last posting was on 2010-03-23 18:13:33.0Z
Jim Thomas Posted on 2010-03-23 16:16:21.0Z
Sender: 10dd.4ba8e883.1804289383@sybase.com
From: Jim Thomas
Newsgroups: sybase.public.ase.general
Subject: Showplan is Confusing
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4ba8e955.1100.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 23 Mar 2010 08:16:21 -0800
X-Trace: forums-1-dub 1269360981 10.22.241.41 (23 Mar 2010 08:16:21 -0800)
X-Original-Trace: 23 Mar 2010 08:16:21 -0800, 10.22.241.41
Lines: 8
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29068
Article PK: 78306

Would someone from Sybase please respond to my March 16
response to their question on March 3 re the topic 'Showplan
is confusing'?

Since the same thing happens on my co-workers desk I am
going to get the System Administrator to look at server side
configuration. But it would help if Sybase could point us in
some direction.....


Rob V [ Sybase ] Posted on 2010-03-23 17:46:46.0Z
Reply-To: "Rob V [ Sybase ]" <robv@DO.NOT.SPAM.sypron.nl.REMOVE.THIS.DECOY>
From: "Rob V [ Sybase ]" <robv@DO.NOT.SPAM.sypron.nl.REMOVE.THIS.DECOY>
Newsgroups: sybase.public.ase.general
References: <4ba8e955.1100.1681692777@sybase.com>
Subject: Re: Showplan is Confusing
Lines: 41
Organization: Sypron BV / TeamSybase / Sybase
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5843
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4ba8fe86$1@forums-1-dub>
Date: 23 Mar 2010 09:46:46 -0800
X-Trace: forums-1-dub 1269366406 10.22.241.152 (23 Mar 2010 09:46:46 -0800)
X-Original-Trace: 23 Mar 2010 09:46:46 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29069
Article PK: 78307

It seems unlikely that the very first query plan that you posted was for
that single select statement -- there was just too much other stuff in
there. Having said that, I never use Interactive SQL, and I would not
exclude the possibility that it did something funny with its output.
If things like these happen, revert to the command-line ASCII tool 'isql' to
verify the ASE server is behaving correctly. With weird problems, that will
always be the advice. If it doesn't reproduce with 'isql' then I reckon it's
a quirk of the GUI. I'm not trying to duck the issue but as good as it
gets -- with me at least...

HTH,

Rob V.
-----------------------------------------------------------------
Rob Verschoor

Certified Sybase Professional DBA for ASE 15.0/12.5/12.0/11.5/11.0
and Replication Server 15.0.1/12.5 // TeamSybase

Author of Sybase books (order online at www.sypron.nl/shop):
"Tips, Tricks & Recipes for Sybase ASE" (ASE 15 edition)
"The Complete Sybase ASE Quick Reference Guide"
"The Complete Sybase Replication Server Quick Reference Guide"

mailto:rob@YOUR.SPAM.sypron.nl.NOT.FOR.ME
http://www.sypron.nl
Sypron B.V., Amersfoort, The Netherlands
Chamber of Commerce 27138666
-----------------------------------------------------------------

<Jim Thomas> wrote in message news:4ba8e955.1100.1681692777@sybase.com...
> Would someone from Sybase please respond to my March 16
> response to their question on March 3 re the topic 'Showplan
> is confusing'?
>
> Since the same thing happens on my co-workers desk I am
> going to get the System Administrator to look at server side
> configuration. But it would help if Sybase could point us in
> some direction.....


Jim Thomas Posted on 2010-03-23 18:13:33.0Z
Sender: 10dd.4ba8e883.1804289383@sybase.com
From: Jim Thomas
Newsgroups: sybase.public.ase.general
Subject: Re: Showplan is Confusing
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4ba904cd.1365.1681692777@sybase.com>
References: <4ba8fe86$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 23 Mar 2010 10:13:33 -0800
X-Trace: forums-1-dub 1269368013 10.22.241.41 (23 Mar 2010 10:13:33 -0800)
X-Original-Trace: 23 Mar 2010 10:13:33 -0800, 10.22.241.41
Lines: 53
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29070
Article PK: 78308

Thanks for the response. I will assume it is a quirk of the
GUI (introduced sometime in the last 6 months with an
upgrade we did). Since both ISQL and Tools/Plan Viewer
(within that same GUI) correctly report the plan I will
stick to one of these alternatives in the future.

> It seems unlikely that the very first query plan that you
> posted was for that single select statement -- there was
> just too much other stuff in there. Having said that, I
> never use Interactive SQL, and I would not exclude the
> possibility that it did something funny with its output.
> If things like these happen, revert to the command-line
> ASCII tool 'isql' to verify the ASE server is behaving
> correctly. With weird problems, that will always be the
> advice. If it doesn't reproduce with 'isql' then I reckon
> it's a quirk of the GUI. I'm not trying to duck the
> issue but as good as it gets -- with me at least...
>
> HTH,
>
> Rob V.
> ----------------------------------------------------------
> ------- Rob Verschoor
>
> Certified Sybase Professional DBA for ASE
> 15.0/12.5/12.0/11.5/11.0 and Replication Server
> 15.0.1/12.5 // TeamSybase
>
> Author of Sybase books (order online at
> www.sypron.nl/shop): "Tips, Tricks & Recipes for Sybase
> ASE" (ASE 15 edition) "The Complete Sybase ASE Quick
> Reference Guide" "The Complete Sybase Replication Server
> Quick Reference Guide"
>
> mailto:rob@YOUR.SPAM.sypron.nl.NOT.FOR.ME
> http://www.sypron.nl
> Sypron B.V., Amersfoort, The Netherlands
> Chamber of Commerce 27138666
> ----------------------------------------------------------
> -------
>
> <Jim Thomas> wrote in message
> > news:4ba8e955.1100.1681692777@sybase.com... Would
> > someone from Sybase please respond to my March 16
> response to their question on March 3 re the topic
> > 'Showplan is confusing'?
> >
> > Since the same thing happens on my co-workers desk I am
> > going to get the System Administrator to look at server
> > side configuration. But it would help if Sybase could
> > point us in some direction.....
>
>