Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Change character set

6 posts in General Discussion Last posting was on 2010-05-07 01:30:40.0Z
Rajasekhar Reddy Posted on 2010-04-28 10:49:24.0Z
Sender: 5254.4bd7ad0e.1804289383@sybase.com
From: Rajasekhar Reddy
Newsgroups: sybase.public.ase.general
Subject: Change character set
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4bd812b4.5d73.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 28 Apr 2010 03:49:24 -0700
X-Trace: forums-1-dub 1272451764 10.22.241.41 (28 Apr 2010 03:49:24 -0700)
X-Original-Trace: 28 Apr 2010 03:49:24 -0700, 10.22.241.41
Lines: 31
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29154
Article PK: 78391

Hi,

How can I change character set to iso_1 from ascii_8 ?
sp_helpsort showing character set is iso_1, But Errorlog
showing ascii_8 when I reboot the server.Below are the
outputs.
How can I change it ?? I want it to be iso_1 in errorlog
when I start server as well. I have run charset utility
also. It doesn't seems to be working. Thanks.

sp_helpsort
-------------

Character Set = 1, iso_1
ISO 8859-1 (Latin-1) - Western European 8-bit character
set.
Sort Order = 50, bin_iso_1
Binary sort order for the ISO 8859/1 character set
(iso_1).
Characters, in Order

Errorlog
------------
00:00:00000:00001:2010/04/28 14:53:04.39 server ASE's
default sort order is:
00:00:00000:00001:2010/04/28 14:53:04.39 server
'bin_iso_1' (ID = 50)
00:00:00000:00001:2010/04/28 14:53:04.39 server on top of
default character set:
00:00:00000:00001:2010/04/28 14:53:04.39 server
'ascii_8' (ID = 1).


ET Posted on 2010-04-29 20:48:23.0Z
From: ET <dbccjob@gmail.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: Change character set
References: <4bd812b4.5d73.1681692777@sybase.com>
In-Reply-To: <4bd812b4.5d73.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4bd9f097$1@forums-1-dub>
Date: 29 Apr 2010 13:48:23 -0700
X-Trace: forums-1-dub 1272574103 10.22.241.152 (29 Apr 2010 13:48:23 -0700)
X-Original-Trace: 29 Apr 2010 13:48:23 -0700, vip152.sybase.com
Lines: 38
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29160
Article PK: 78398

Le 28/04/2010 12:49, Rajasekhar Reddy a écrit :

> Hi,
>
> How can I change character set to iso_1 from ascii_8 ?
> sp_helpsort showing character set is iso_1, But Errorlog
> showing ascii_8 when I reboot the server.Below are the
> outputs.
> How can I change it ?? I want it to be iso_1 in errorlog
> when I start server as well. I have run charset utility
> also. It doesn't seems to be working. Thanks.
>
> sp_helpsort
> -------------
>
> Character Set = 1, iso_1
> ISO 8859-1 (Latin-1) - Western European 8-bit character
> set.
> Sort Order = 50, bin_iso_1
> Binary sort order for the ISO 8859/1 character set
> (iso_1).
> Characters, in Order
>
> Errorlog
> ------------
> 00:00:00000:00001:2010/04/28 14:53:04.39 server ASE's
> default sort order is:
> 00:00:00000:00001:2010/04/28 14:53:04.39 server
> 'bin_iso_1' (ID = 50)
> 00:00:00000:00001:2010/04/28 14:53:04.39 server on top of
> default character set:
> 00:00:00000:00001:2010/04/28 14:53:04.39 server
> 'ascii_8' (ID = 1).

Hi

Is there a specific reason for doing such an operation ? Do you already
have user databases using ascii_8 ?

Emmanuel