Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

FileServer Logon

4 posts in Appeon (partner product) Last posting was on 2010-05-03 18:36:06.0Z
Shenn Sellers Posted on 2010-04-28 20:02:16.0Z
From: "Shenn Sellers" <ssellers@co.riverside.ca.us>
Newsgroups: sybase.public.appeon
Subject: FileServer Logon
Lines: 2
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="----=_NextPart_000_000C_01CAE6D3.07652EC0"
X-Priority: 3
X-MSMail-Priority: Normal
Importance: Normal
X-Newsreader: Microsoft Windows Live Mail 14.0.8089.726
X-MimeOLE: Produced By Microsoft MimeOLE V14.0.8089.726
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4bd89448$1@forums-1-dub>
Date: 28 Apr 2010 13:02:16 -0700
X-Trace: forums-1-dub 1272484936 10.22.241.152 (28 Apr 2010 13:02:16 -0700)
X-Original-Trace: 28 Apr 2010 13:02:16 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:2491
Article PK: 13457

I'm using PB 11.5 with Appeon Distribution version 6.2.0105.00. I am unable
to logon to the fileserver. Whenever I call of_logonfileserver(), I get a
return value of -1. I've setup the FileServer in IIS on my development PC.
I've also tried using my PC name instead of "localhost" as well as my IP
address. My sample code is below and my fileserver settings file is
attached. What am I doing wrong? Thanks.

Shenn Sellers


////////////////////////////////////////////////////////////
long ll_ret

app_file = create appeonfileservice

ll_ret = app_file.of_logonfileserver ("localhost", 80,
"username=test;password=password" )

if (ll_ret < 0) then
MessageBox("LOGON ERROR", string(ll_ret))
return
end if

ll_ret = app_file.of_appeondownload ("/DRS/DWReport.pdf")

if (ll_ret < 0) then
MessageBox("DOWNLOAD ERROR", string(ll_ret))
return
end if

ll_ret = app_file.of_logofffileserver()

if (ll_ret < 0) then
MessageBox("LOGOFF ERROR", string(ll_ret))
return
end if

if (isValid(app_file)) then destroy app_file


Steven Posted on 2010-04-29 08:28:50.0Z
Sender: 6ef1.4bd63878.1804289383@sybase.com
From: steven
Newsgroups: sybase.public.appeon
Subject: Re: FileServer Logon
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4bd94341.535.1681692777@sybase.com>
References: <4bd89448$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 29 Apr 2010 01:28:50 -0700
X-Trace: forums-1-dub 1272529730 10.22.241.41 (29 Apr 2010 01:28:50 -0700)
X-Original-Trace: 29 Apr 2010 01:28:50 -0700, 10.22.241.41
Lines: 13
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:2494
Article PK: 13460

Hi Shenn Sellers,

Appeon File Server does not work in your the client/server
application, it just only work in the Web applicaiton.
Do you grant right to the fileservice folder? And do you
restart the IIS service? You can refer to the Appeon Help |
Appeon Workarounds guide | File Upload and Download |
Configuring and deploying Appeon File Server | Deploying
Appeon File Server to IIS | Deploy an Appeon File Server to
get detail information.

Regards,
Steven


Shenn Sellers Posted on 2010-05-03 15:34:36.0Z
From: "Shenn Sellers" <ssellers@co.riverside.ca.us>
Newsgroups: sybase.public.appeon
References: <4bd89448$1@forums-1-dub> <4bd94341.535.1681692777@sybase.com>
In-Reply-To: <4bd94341.535.1681692777@sybase.com>
Subject: Re: FileServer Logon
Lines: 1
MIME-Version: 1.0
Content-Type: text/plain; format=flowed; charset="iso-8859-1"; reply-type=original
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
Importance: Normal
X-Newsreader: Microsoft Windows Live Mail 14.0.8089.726
X-MimeOLE: Produced By Microsoft MimeOLE V14.0.8089.726
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4bdeed0c$1@forums-1-dub>
Date: 3 May 2010 08:34:36 -0700
X-Trace: forums-1-dub 1272900876 10.22.241.152 (3 May 2010 08:34:36 -0700)
X-Original-Trace: 3 May 2010 08:34:36 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:2499
Article PK: 21727

I have the Appeon Web Server running on my development PC, so it's the same
PC that I'm using Appeon Developer on. The fileserver folder has "Full
Control" rights granted to the IIS user and the IIS service has been
restarted. I've gone through everything in the help file multiple times and
nothing seems to be working. I still can't connect to the File Server.

Shenn Sellers

"steven" wrote in message news:4bd94341.535.1681692777@sybase.com...
> Hi Shenn Sellers,
>
> Appeon File Server does not work in your the client/server
> application, it just only work in the Web applicaiton.
> Do you grant right to the fileservice folder? And do you
> restart the IIS service? You can refer to the Appeon Help |
> Appeon Workarounds guide | File Upload and Download |
> Configuring and deploying Appeon File Server | Deploying
> Appeon File Server to IIS | Deploy an Appeon File Server to
> get detail information.
>
> Regards,
> Steven


Shenn Sellers Posted on 2010-05-03 18:36:06.0Z
From: "Shenn Sellers" <ssellers@co.riverside.ca.us>
Newsgroups: sybase.public.appeon
References: <4bd89448$1@forums-1-dub> <4bd94341.535.1681692777@sybase.com> <4bdeed0c$1@forums-1-dub>
In-Reply-To: <4bdeed0c$1@forums-1-dub>
Subject: Re: FileServer Logon
Lines: 3
MIME-Version: 1.0
Content-Type: text/plain; format=flowed; charset="iso-8859-1"; reply-type=response
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
Importance: Normal
X-Newsreader: Microsoft Windows Live Mail 14.0.8089.726
X-MimeOLE: Produced By Microsoft MimeOLE V14.0.8089.726
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4bdf1796$1@forums-1-dub>
Date: 3 May 2010 11:36:06 -0700
X-Trace: forums-1-dub 1272911766 10.22.241.152 (3 May 2010 11:36:06 -0700)
X-Original-Trace: 3 May 2010 11:36:06 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:2500
Article PK: 13463

I've resolved the issue by digging around in the IIS settings. The
application pool for the fileservice was set for the DefaultAppPool, once I
changed it to the AppeonAppPool, it worked. Nowhere in the manuals did I
see where you had to modify this setting, so it's good to know for future
reference.

Shenn Sellers

"Shenn Sellers" <ssellers@co.riverside.ca.us> wrote in message
news:4bdeed0c$1@forums-1-dub...
> I have the Appeon Web Server running on my development PC, so it's the
> same PC that I'm using Appeon Developer on. The fileserver folder has
> "Full Control" rights granted to the IIS user and the IIS service has been
> restarted. I've gone through everything in the help file multiple times
> and nothing seems to be working. I still can't connect to the File
> Server.
>
> Shenn Sellers
>
>
> "steven" wrote in message news:4bd94341.535.1681692777@sybase.com...
>> Hi Shenn Sellers,
>>
>> Appeon File Server does not work in your the client/server
>> application, it just only work in the Web applicaiton.
>> Do you grant right to the fileservice folder? And do you
>> restart the IIS service? You can refer to the Appeon Help |
>> Appeon Workarounds guide | File Upload and Download |
>> Configuring and deploying Appeon File Server | Deploying
>> Appeon File Server to IIS | Deploy an Appeon File Server to
>> get detail information.
>>
>> Regards,
>> Steven
>