Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

sybase 15 create proc problem

4 posts in General Discussion Last posting was on 2010-05-12 12:59:08.0Z
vstenzel Posted on 2010-05-11 14:13:23.0Z
From: "vstenzel" <viniciusstenzel@gmail.com>
Newsgroups: sybase.public.ase.general
Subject: sybase 15 create proc problem
Lines: 23
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4be96603@forums-1-dub>
Date: 11 May 2010 07:13:23 -0700
X-Trace: forums-1-dub 1273587203 10.22.241.152 (11 May 2010 07:13:23 -0700)
X-Original-Trace: 11 May 2010 07:13:23 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29195
Article PK: 78433

I am having a big problem with ASE 15.0.3 with frozen rollback process.

Sometimes when I submit to create a new proc (it is a large proc with
several nested procedures calls) passed few seconds, the ASE reply me "ASE
is terminating this process" and the process receive ROLLBACK; but it never
finish.

Also I cannot kill this process using SA and the current database turns
frozen. There are others dabatase in same server and they continue working
well.

The unique way to kill this frozen rollback process is restarting the
server.

Have been anybody with a similar problem?

My ASE version is: "Adaptive Server Enterprise/15.0.3/EBF 16549
ESD#1/P/x86_64/Enterprise Linux/ase1503/2681/64-bit/FBO/Mon Mar 9 04:10:47
2009"

tks


Leonid Gvirtz Posted on 2010-05-11 14:23:02.0Z
From: Leonid Gvirtz <lgvirtz@yahoo.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: sybase 15 create proc problem
References: <4be96603@forums-1-dub>
In-Reply-To: <4be96603@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4be96846$1@forums-1-dub>
Date: 11 May 2010 07:23:02 -0700
X-Trace: forums-1-dub 1273587782 10.22.241.152 (11 May 2010 07:23:02 -0700)
X-Original-Trace: 11 May 2010 07:23:02 -0700, vip152.sybase.com
Lines: 37
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29196
Article PK: 78432

Hi

I would suggest checking the ASE errorlog. Do you see processes that
terminated with a stack trace? If the answer is yes - analysis of stack
traces may help. Also, you can try to increase the procedure cache and
see if it helps.

Hope it helps
Leonid Gvirtz
http://www.gvirtz-consulting.com

On 5/11/2010 5:13 PM, vstenzel wrote:
> I am having a big problem with ASE 15.0.3 with frozen rollback process.
>
> Sometimes when I submit to create a new proc (it is a large proc with
> several nested procedures calls) passed few seconds, the ASE reply me "ASE
> is terminating this process" and the process receive ROLLBACK; but it never
> finish.
>
> Also I cannot kill this process using SA and the current database turns
> frozen. There are others dabatase in same server and they continue working
> well.
>
> The unique way to kill this frozen rollback process is restarting the
> server.
>
> Have been anybody with a similar problem?
>
> My ASE version is: "Adaptive Server Enterprise/15.0.3/EBF 16549
> ESD#1/P/x86_64/Enterprise Linux/ase1503/2681/64-bit/FBO/Mon Mar 9 04:10:47
> 2009"
>
> tks
>
>
>


Cory Sane [TeamSybase] Posted on 2010-05-12 08:11:46.0Z
From: "Cory Sane [TeamSybase]" <cory!=sane>
Newsgroups: sybase.public.ase.general
References: <4be96603@forums-1-dub>
In-Reply-To: <4be96603@forums-1-dub>
Subject: Re: sybase 15 create proc problem
Lines: 31
MIME-Version: 1.0
Content-Type: text/plain; format=flowed; charset="iso-8859-1"; reply-type=response
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Windows Mail 6.0.6002.18005
X-MimeOLE: Produced By Microsoft MimeOLE V6.0.6002.18005
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4bea62c2$1@forums-1-dub>
Date: 12 May 2010 01:11:46 -0700
X-Trace: forums-1-dub 1273651906 10.22.241.152 (12 May 2010 01:11:46 -0700)
X-Original-Trace: 12 May 2010 01:11:46 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29197
Article PK: 78437

What does "kill xxx with statusonly" report?


--
Cory Sane
[TeamSybase]
Certified Sybase Associate DBA for ASE 15.0

"vstenzel" <viniciusstenzel@gmail.com> wrote in message news:4be96603@forums-1-dub...
>I am having a big problem with ASE 15.0.3 with frozen rollback process.
>
> Sometimes when I submit to create a new proc (it is a large proc with
> several nested procedures calls) passed few seconds, the ASE reply me "ASE
> is terminating this process" and the process receive ROLLBACK; but it never
> finish.
>
> Also I cannot kill this process using SA and the current database turns
> frozen. There are others dabatase in same server and they continue working
> well.
>
> The unique way to kill this frozen rollback process is restarting the
> server.
>
> Have been anybody with a similar problem?
>
> My ASE version is: "Adaptive Server Enterprise/15.0.3/EBF 16549
> ESD#1/P/x86_64/Enterprise Linux/ase1503/2681/64-bit/FBO/Mon Mar 9 04:10:47
> 2009"
>
> tks
>
>


vstenzel Posted on 2010-05-12 12:59:08.0Z
From: "vstenzel" <viniciusstenzel@gmail.com>
Newsgroups: sybase.public.ase.general
References: <4be96603@forums-1-dub> <4bea62c2$1@forums-1-dub>
Subject: Re: sybase 15 create proc problem
Lines: 122
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4beaa61c$1@forums-1-dub>
Date: 12 May 2010 05:59:08 -0700
X-Trace: forums-1-dub 1273669148 10.22.241.152 (12 May 2010 05:59:08 -0700)
X-Original-Trace: 12 May 2010 05:59:08 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29199
Article PK: 78434

I didnt try that. As it happens just few sometimes, I gonna try using on the
next one.
Anyway I found a Solved Case in Sybase website with very similar problem
reported that I hope it could help me...
Solved Cases (#11573748)- 1503-Linux x86-64

I will keep you posted about...

This was the last server log report error:

02:00000:00233:2010/05/11 21:19:05.57 kernel lasterror = 0 preverror = 0
transtate = 1
02:00000:00233:2010/05/11 21:19:05.57 kernel curcmd = 0 program =
SQL_Advantage
02:00000:00233:2010/05/11 21:19:05.57 kernel extended error information:
hostname: [XXXXXXXXX] login: [OWNERLOGIN]
02:00000:00233:2010/05/11 21:19:05.60 kernel pc: 0x0000000001673b95
pcstkwalk+0x30()
02:00000:00233:2010/05/11 21:19:05.60 kernel pc: 0x0000000001673989
ucstkgentrace+0x199()
02:00000:00233:2010/05/11 21:19:05.60 kernel pc: 0x000000000162cede
ucbacktrace+0x40()
02:00000:00233:2010/05/11 21:19:05.60 kernel pc: 0x000000000074ac5b
terminate_process+0xccb()
02:00000:00233:2010/05/11 21:19:05.60 kernel pc: 0x0000003d62c0de60
(null)+0x3d62c0de60()
02:00000:00233:2010/05/11 21:19:05.61 kernel pc: 0x000000000189db46
cm_writedes+0x626()
02:00000:00233:2010/05/11 21:19:05.61 kernel pc: 0x0000000001896b1e
bufwritedes_log+0xae()
02:00000:00233:2010/05/11 21:19:05.61 kernel pc: 0x000000000186a8b0
xls_flush+0xd0()
02:00000:00233:2010/05/11 21:19:05.61 kernel pc: 0x00000000018474b8
finishlog+0x1b8()
02:00000:00233:2010/05/11 21:19:05.61 kernel pc: 0x00000000018d1442
xact__endxact+0xb2()
02:00000:00233:2010/05/11 21:19:05.61 kernel pc: 0x00000000018d09d8
xact__commitxact+0x168()
02:00000:00233:2010/05/11 21:19:05.61 kernel pc: 0x00000000018d03cb
xact__commit_local+0xcb()
02:00000:00233:2010/05/11 21:19:05.61 kernel pc: 0x00000000018d0285
xact_commit+0x25()
02:00000:00233:2010/05/11 21:19:05.61 kernel [Handler pc:
0x0x0000000000cd1da0 ut_handle installed by the following function:-]
02:00000:00233:2010/05/11 21:19:05.61 kernel pc: 0x0000000000caa4b9
proccreate+0xdf9()
02:00000:00233:2010/05/11 21:19:05.61 kernel pc: 0x0000000000c233cb
s_crtproc+0x1db()
02:00000:00233:2010/05/11 21:19:05.61 kernel [Handler pc:
0x0x0000000000c458c0 hdl_stack installed by the following function:-]
02:00000:00233:2010/05/11 21:19:05.61 kernel [Handler pc:
0x0x0000000000c23ac0 s_handle installed by the following function:-]
02:00000:00233:2010/05/11 21:19:05.61 kernel pc: 0x0000000001949c46
sequencer+0x9c6()
02:00000:00233:2010/05/11 21:19:05.61 kernel pc: 0x000000000075c33a
tdsrecv_language+0xaa()
02:00000:00233:2010/05/11 21:19:05.61 kernel [Handler pc:
0x0x0000000000cd1da0 ut_handle installed by the following function:-]
02:00000:00233:2010/05/11 21:19:05.61 kernel pc: 0x000000000180a6db
conn_hdlr+0xb0b()
02:00000:00233:2010/05/11 21:19:05.61 kernel end of stack trace, spid 233,
kpid 1941373088, suid 2342
03:00000:00076:2010/05/11 21:19:05.61 kernel Cannot send, host process
disconnected: 4620 suid: 679
03:00000:00076:2010/05/11 21:19:05.61 server Error: 1608, Severity: 18,
State: 4
03:00000:00076:2010/05/11 21:19:05.61 server A client process exited
abnormally, or a network error was encountered. Unless other errors
occurred, continue processing normally.
03:00000:00076:2010/05/11 21:19:05.61 kernel extended error information:
hostname: login: operator
03:00000:00246:2010/05/11 21:19:07.66 kernel Cannot send, host process
disconnected: [XXXXXXXX] 4064 suid: 2233
02:00000:00233:2010/05/11 21:19:12.12 server Error: 21, Severity: 21,
State: 1
02:00000:00233:2010/05/11 21:19:12.12 server WARNING - Fatal Error 12583
occurred at May 11 2010 9:19PM. Please note the error and time, and
contact a user with System Administrator (SA) authorization.
02:00000:00233:2010/05/11 21:19:12.12 server WARNING - Fatal Error 12583
occurred at May 11 2010 9:19PM. Please note the error and time, and
contact a user with System Administrator (SA) authorization.
02:00000:00233:2010/05/11 21:19:12.19 server Error: 12583, Severity: 21,
State: 1

"Cory Sane [TeamSybase]" <cory!=sane> wrote in message
news:4bea62c2$1@forums-1-dub...
> What does "kill xxx with statusonly" report?
>
>
> --
> Cory Sane
> [TeamSybase]
> Certified Sybase Associate DBA for ASE 15.0
> "vstenzel" <viniciusstenzel@gmail.com> wrote in message
> news:4be96603@forums-1-dub...
>>I am having a big problem with ASE 15.0.3 with frozen rollback process.
>>
>> Sometimes when I submit to create a new proc (it is a large proc with
>> several nested procedures calls) passed few seconds, the ASE reply me
>> "ASE is terminating this process" and the process receive ROLLBACK; but
>> it never finish.
>>
>> Also I cannot kill this process using SA and the current database turns
>> frozen. There are others dabatase in same server and they continue
>> working well.
>>
>> The unique way to kill this frozen rollback process is restarting the
>> server.
>>
>> Have been anybody with a similar problem?
>>
>> My ASE version is: "Adaptive Server Enterprise/15.0.3/EBF 16549
>> ESD#1/P/x86_64/Enterprise Linux/ase1503/2681/64-bit/FBO/Mon Mar 9
>> 04:10:47 2009"
>>
>> tks