Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

6420 error

2 posts in Networking Last posting was on 2010-05-17 19:28:37.0Z
Randall H. Carpenter Posted on 2010-05-17 18:00:48.0Z
From: "Randall H. Carpenter" <rhcarpenter@gcwins.com>
Newsgroups: Advantage.Networking
Subject: 6420 error
Date: Mon, 17 May 2010 14:00:48 -0400
Lines: 1
MIME-Version: 1.0
Content-Type: text/plain; format=flowed; charset="iso-8859-1"; reply-type=original
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
Importance: Normal
X-Newsreader: Microsoft Windows Live Mail 14.0.8089.726
X-MimeOLE: Produced By Microsoft MimeOLE V14.0.8089.726
NNTP-Posting-Host: 67.76.168.239
Message-ID: <4bf183b7@solutions.advantagedatabase.com>
X-Trace: 17 May 2010 11:58:15 -0700, 67.76.168.239
Path: solutions.advantagedatabase.com!67.76.168.239
Xref: solutions.advantagedatabase.com Advantage.Networking:932
Article PK: 1132342

I'm getting a 6420 error I hope someone can help me resolve.

I have 11 workstations on my network. I have a Windows 2008 Small Business
Server on which the Advantage Database Server is installed. At each
workstation, the ADS.INI file contains the following lines (among others)

[GCWSERVER]
LAN_IP=192.168.X.XX <- the internal IP address of my server
LAN_PORT=XXXX <- my lan port

By placing these lines in the ADS.INI file, all my workstations find the
Advantage server with no problem when trying to connect to it from our
primary application. The above lines are in everyone's ADS.INI file
including mine.

On my workstation, which is my development machine, I also have the
Advantage Data Architect installed. When I open our primary application to
access the database, I have no problem connecting to the database. But when
I open ADS and try to login to the database, I get the 6420 error (even
though my ADS.INI file contains the above lines). Usually after attempting
to connect three times, it will finally find the server.

Anyone have any ideas on why the Advantage Data Architect is giving me this
problem?


"Josh Neider" Posted on 2010-05-17 19:28:37.0Z
From: "Josh Neider" <jneider (at) sybase.com>
Newsgroups: Advantage.Networking
References: <4bf183b7@solutions.advantagedatabase.com>
In-Reply-To: <4bf183b7@solutions.advantagedatabase.com>
Subject: Re: 6420 error
Date: Mon, 17 May 2010 13:28:37 -0600
Lines: 1
MIME-Version: 1.0
Content-Type: text/plain; format=flowed; charset="iso-8859-1"; reply-type=response
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
Importance: Normal
X-Newsreader: Microsoft Windows Live Mail 14.0.8089.726
X-MimeOLE: Produced By Microsoft MimeOLE V14.0.8089.726
NNTP-Posting-Host: 10.24.34.232
Message-ID: <4bf19860@solutions.advantagedatabase.com>
X-Trace: 17 May 2010 13:26:24 -0700, 10.24.34.232
Path: solutions.advantagedatabase.com!10.24.34.232
Xref: solutions.advantagedatabase.com Advantage.Networking:933
Article PK: 1132343

It is very likely ARC is using a different ADS.INI file than your
application. If you're using Vista or 7 then you may check this path to see
if the ads.ini file is here:
C:\Users\<username>\AppData\Local\VirtualStore\Windows where <username> is
the name of the user.

You can refer to this knowledgebase item:
http://devzone.advantagedatabase.com/dz/content.aspx?Key=17&RefNo=090128-2126

Josh

"Randall H. Carpenter" <rhcarpenter@gcwins.com> wrote in message
news:4bf183b7@solutions.advantagedatabase.com...
> I'm getting a 6420 error I hope someone can help me resolve.
>
> I have 11 workstations on my network. I have a Windows 2008 Small
> Business Server on which the Advantage Database Server is installed. At
> each workstation, the ADS.INI file contains the following lines (among
> others)
>
> [GCWSERVER]
> LAN_IP=192.168.X.XX <- the internal IP address of my server
> LAN_PORT=XXXX <- my lan port
>
> By placing these lines in the ADS.INI file, all my workstations find the
> Advantage server with no problem when trying to connect to it from our
> primary application. The above lines are in everyone's ADS.INI file
> including mine.
>
> On my workstation, which is my development machine, I also have the
> Advantage Data Architect installed. When I open our primary application
> to access the database, I have no problem connecting to the database. But
> when I open ADS and try to login to the database, I get the 6420 error
> (even though my ADS.INI file contains the above lines). Usually after
> attempting to connect three times, it will finally find the server.
>
> Anyone have any ideas on why the Advantage Data Architect is giving me
> this problem?
>
>
>
>
>