Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

OMA DM server not responding

6 posts in Trial information Last posting was on 2010-07-26 08:19:52.0Z
Sampo Niinikoski Posted on 2010-06-03 12:05:37.0Z
Sender: 480c.4c04e7d2.1804289383@sybase.com
From: Sampo Niinikoski
Newsgroups: ianywhere.public.afaria.trial
Subject: OMA DM server not responding
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4c079a91.60b3.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 3 Jun 2010 05:05:37 -0700
X-Trace: forums-1-dub 1275566737 10.22.241.41 (3 Jun 2010 05:05:37 -0700)
X-Original-Trace: 3 Jun 2010 05:05:37 -0700, 10.22.241.41
Lines: 18
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.afaria.trial:136
Article PK: 136

Hi,

I try to setup the Afaria OMA DM server. The Afaria client
connection to Afaria server works ok but the OMA DM server
is not responding. From server I can see that connection is
attempted but socket is not listening. When I tried to use
relay server in same server and I setup the relay server
localhost:80 to localhost:80 and set the OMA DM server
setting port to 8088, I got "connection error" note and saw
in packet capture Bad request invalid host name from server
response. So I guess the setup was not so good.
So my question is that does the OMA DM server require the RS
(Relay Server) and if it does need RS then is it possible to
run RS in same machine as OMA DM server? If RS is not needed
then how to setup OMA DM server so that it is listening the
socket?

Sampo


Tim Roberts Posted on 2010-06-14 10:31:48.0Z
Sender: 8dc.4c16033d.1804289383@sybase.com
From: Tim Roberts
Newsgroups: ianywhere.public.afaria.trial
Subject: Re: OMA DM server not responding
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4c160514.92b.1681692777@sybase.com>
References: <4c079a91.60b3.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 14 Jun 2010 03:31:48 -0700
X-Trace: forums-1-dub 1276511508 10.22.241.41 (14 Jun 2010 03:31:48 -0700)
X-Original-Trace: 14 Jun 2010 03:31:48 -0700, 10.22.241.41
Lines: 36
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.afaria.trial:139
Article PK: 143

Hi Sampo,

As Daryl stated you don't have to use the OMA DM Server with
the relay server. It should be pretty easy to get set up and
running on it's own.

The first thing to check is that the service is running OK
(you should see a separate service up and running in the
services list). If it isn't check that it's installed and
starting up OK - this will show up as a message in the
Afaria server logs when the OMA DM Service starts, as well
as in the event viewer. If it isn't it may be worth
re-running the setup which is in a separate OMA DM
sub-directory on the install files.

Regards,

Tim

> Hi,
>
> I try to setup the Afaria OMA DM server. The Afaria client
> connection to Afaria server works ok but the OMA DM server
> is not responding. From server I can see that connection
> is attempted but socket is not listening. When I tried to
> use relay server in same server and I setup the relay
> server localhost:80 to localhost:80 and set the OMA DM
> server setting port to 8088, I got "connection error" note
> and saw in packet capture Bad request invalid host name
> from server response. So I guess the setup was not so
> good. So my question is that does the OMA DM server
> require the RS (Relay Server) and if it does need RS then
> is it possible to run RS in same machine as OMA DM server?
> If RS is not needed then how to setup OMA DM server so
> that it is listening the socket?
>
> Sampo


Sampo Niinikoski Posted on 2010-07-19 13:06:10.0Z
Sender: 10fb.4c4441e8.1804289383@sybase.com
From: Sampo Niinikoski
Newsgroups: ianywhere.public.afaria.trial
Subject: Re: OMA DM server not responding
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4c444dc2.13af.1681692777@sybase.com>
References: <4c160514.92b.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 19 Jul 2010 06:06:10 -0700
X-Trace: forums-1-dub 1279544770 10.22.241.41 (19 Jul 2010 06:06:10 -0700)
X-Original-Trace: 19 Jul 2010 06:06:10 -0700, 10.22.241.41
Lines: 68
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.afaria.trial:146
Article PK: 160

Hi Tim,

Thanks for your response. I was able to get response from
OMA DM server. Unfortunately it is not working yet.

Phone sends the following frame after TCP connection is
established. Xxx.xxx.xxx.xxx contains the server public IP
address in numeric format:
POST./.HTTP/1.1..Cache-Control:.no-store..Host:.xxx.xxx.xxx.xxx:81..Accept:.application/vnd.syncml.dm+wbxml
,.application/vnd.nokia.headwrapper..Accept-Charset:.utf-8..Accept-Language:.en..User-Agent:.S60.SyncML.HTTP.Client..Content-Length:.563..Content-Type:.application/vnd.syncml.dm+wbxml..PnP:.ver="urn:liberty:PnP:2003-08";
.urn:"http://pnpms.nokia.com/signkey"..X-Nokia-MusicShop-Version:.09.0939.15..X-Nokia-MusicShop-Bearer:.GPRS/3G....

OMA DM server responds to client query with following
string:

'HTTP/1.1.400.Bad.Request..Content-Type:.text/html..Date:.Mon
,.19.Jul.2010.12:26:15.GMT..Connection:.close..Content-Length:.39....<h1>Bad.Request.(Invalid.Hostname)</h1>'

After that phone sends some device data and then the TCP
connection terminates to checksum failure?

Since I don't have the SMS sending possibility I have
manually configured the Nokia E55 OMA DM settings. I have
set the Server ID in phone same as in the Afaria Server
Configuration / Properties /OMA DM Server.

Any help appreciated.

Regards
Sampo

> Hi Sampo,
>
> As Daryl stated you don't have to use the OMA DM Server
> with the relay server. It should be pretty easy to get set
> up and running on it's own.
>
> The first thing to check is that the service is running OK
> (you should see a separate service up and running in the
> services list). If it isn't check that it's installed and
> starting up OK - this will show up as a message in the
> Afaria server logs when the OMA DM Service starts, as well
> as in the event viewer. If it isn't it may be worth
> re-running the setup which is in a separate OMA DM
> sub-directory on the install files.
>
> Regards,
>
> Tim
> > Hi,
> >
> > I try to setup the Afaria OMA DM server. The Afaria
> > client connection to Afaria server works ok but the OMA
> > DM server is not responding. From server I can see that
> > connection is attempted but socket is not listening.
> > When I tried to use relay server in same server and I
> > setup the relay server localhost:80 to localhost:80 and
> > set the OMA DM server setting port to 8088, I got
> > "connection error" note and saw in packet capture Bad
> > request invalid host name from server response. So I
> > guess the setup was not so good. So my question is that
> > does the OMA DM server require the RS (Relay Server) and
> > if it does need RS then is it possible to run RS in same
> > machine as OMA DM server? If RS is not needed then how
> > to setup OMA DM server so that it is listening the
> socket? >
> > Sampo


Darryl Endo Posted on 2010-06-07 14:25:58.0Z
Sender: 4880.4c0d004e.1804289383@sybase.com
From: Darryl Endo
Newsgroups: ianywhere.public.afaria.trial
Subject: Re: OMA DM server not responding
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4c0d0176.48a9.1681692777@sybase.com>
References: <4c079a91.60b3.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 7 Jun 2010 07:25:58 -0700
X-Trace: forums-1-dub 1275920758 10.22.241.41 (7 Jun 2010 07:25:58 -0700)
X-Original-Trace: 7 Jun 2010 07:25:58 -0700, 10.22.241.41
Lines: 36
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.afaria.trial:138
Article PK: 147

Sampo,

OMA DM server does not require the use of the Relay Server,
but it can work with the Relay Server. It would just
require another instance of RSOE to be started. It is
possible to run the Relay Server on the same machine as the
OMA DM server although, it is not usually configured this
way.

If you are interested, I do have a document that outlines
the use of a Relay Server with OMA DM. If you are
interested in it, please email me and I'll send it out to
you.

Thank you,
Darryl Endo
darryl.endo@sybase.com

> Hi,
>
> I try to setup the Afaria OMA DM server. The Afaria client
> connection to Afaria server works ok but the OMA DM server
> is not responding. From server I can see that connection
> is attempted but socket is not listening. When I tried to
> use relay server in same server and I setup the relay
> server localhost:80 to localhost:80 and set the OMA DM
> server setting port to 8088, I got "connection error" note
> and saw in packet capture Bad request invalid host name
> from server response. So I guess the setup was not so
> good. So my question is that does the OMA DM server
> require the RS (Relay Server) and if it does need RS then
> is it possible to run RS in same machine as OMA DM server?
> If RS is not needed then how to setup OMA DM server so
> that it is listening the socket?
>
> Sampo


Darryl Endo Posted on 2010-06-04 21:48:23.0Z
Sender: 3269.4c06539c.1804289383@sybase.com
From: Darryl Endo
Newsgroups: ianywhere.public.afaria.trial
Subject: Re: OMA DM server not responding
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4c0974a7.2834.1681692777@sybase.com>
References: <4c079a91.60b3.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 4 Jun 2010 14:48:23 -0700
X-Trace: forums-1-dub 1275688103 10.22.241.41 (4 Jun 2010 14:48:23 -0700)
X-Original-Trace: 4 Jun 2010 14:48:23 -0700, 10.22.241.41
Lines: 26
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.afaria.trial:137
Article PK: 154

Sampo,

Thanks for your question. Your question is being reviewed
and I will answer shortly.

Thank you,
Darryl

> Hi,
>
> I try to setup the Afaria OMA DM server. The Afaria client
> connection to Afaria server works ok but the OMA DM server
> is not responding. From server I can see that connection
> is attempted but socket is not listening. When I tried to
> use relay server in same server and I setup the relay
> server localhost:80 to localhost:80 and set the OMA DM
> server setting port to 8088, I got "connection error" note
> and saw in packet capture Bad request invalid host name
> from server response. So I guess the setup was not so
> good. So my question is that does the OMA DM server
> require the RS (Relay Server) and if it does need RS then
> is it possible to run RS in same machine as OMA DM server?
> If RS is not needed then how to setup OMA DM server so
> that it is listening the socket?
>
> Sampo