We currently have a project running with JSF 1.1 on EAServer
6.3. We would like to update to JSF 1.2, but currently we
cannot get a 1.2 project to deploy. As was needed for the
1.1 project, we have run the script to disable the built-in
JSF implementation. I have checked and the JSF
implementation from our project is being deployed with the
war file. However, the deployer fails with a SAX parser
error, which looks like it is being caused when the TLD file
is being parsed.
Could EAServer be caching the schema for the TLD? Has
enybody successfully gotten JSF 1.2 (Sun RI) to work on
EAServer 6.3? The actual error follows:
SAXParserException: org.xml.sax.SAXParseException:
cvc-complex-type.2.4.a: Invalid content was found starting
with element 'jsp-version'. One of
'{"http://java.sun.com/xml/ns/j2ee":short-name}' is
expected.
Column Number: + 18
Line Number: + 43