Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Issue with select returing only few rows...

8 posts in General Discussion Last posting was on 2010-06-17 18:30:06.0Z
Colt Posted on 2010-06-16 06:58:48.0Z
Sender: 6272.4c18753f.1804289383@sybase.com
From: Colt
Newsgroups: sybase.public.ase.general
Subject: Issue with select returing only few rows...
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4c187628.627e.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 15 Jun 2010 23:58:48 -0700
X-Trace: forums-1-dub 1276671528 10.22.241.41 (15 Jun 2010 23:58:48 -0700)
X-Original-Trace: 15 Jun 2010 23:58:48 -0700, 10.22.241.41
Lines: 9
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29305
Article PK: 78541

Hi All,

I am facing issue with select * from <table> and its
retruning only 3 rows...even though we have inserted
thousends of rows and sp_spaceused show them as well. I have
updated stats and recreated the clustered indexes as well..
still it does not show me all the rows. Where can be issue ?

Cheers


Colt Posted on 2010-06-16 06:59:49.0Z
Sender: 6272.4c18753f.1804289383@sybase.com
From: Colt
Newsgroups: sybase.public.ase.general
Subject: Re: Issue with select returing only few rows...
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4c187665.6289.1681692777@sybase.com>
References: <4c187628.627e.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 15 Jun 2010 23:59:49 -0700
X-Trace: forums-1-dub 1276671589 10.22.241.41 (15 Jun 2010 23:59:49 -0700)
X-Original-Trace: 15 Jun 2010 23:59:49 -0700, 10.22.241.41
Lines: 13
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29306
Article PK: 78540

The server is running on version Adaptive Server
Enterprise/12.5.4/EBF 16800 ESD#10/P/x86_64 on linux.

> Hi All,
>
> I am facing issue with select * from <table> and its
> retruning only 3 rows...even though we have inserted
> thousends of rows and sp_spaceused show them as well. I
> have updated stats and recreated the clustered indexes as
> well.. still it does not show me all the rows. Where can
> be issue ?
>
> Cheers


Sherlock, Kevin [TeamSybase] Posted on 2010-06-16 14:12:03.0Z
From: "Sherlock, Kevin [TeamSybase]" <kevin.sherlock@teamsybase.com>
Newsgroups: sybase.public.ase.general
References: <4c187628.627e.1681692777@sybase.com> <4c187665.6289.1681692777@sybase.com>
Subject: Re: Issue with select returing only few rows...
Lines: 22
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4c18dbb3$1@forums-1-dub>
Date: 16 Jun 2010 07:12:03 -0700
X-Trace: forums-1-dub 1276697523 10.22.241.152 (16 Jun 2010 07:12:03 -0700)
X-Original-Trace: 16 Jun 2010 07:12:03 -0700, vip152.sybase.com
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29308
Article PK: 78545

what does

select count(*) from table

return?

<Colt> wrote in message news:4c187665.6289.1681692777@sybase.com...
> The server is running on version Adaptive Server
> Enterprise/12.5.4/EBF 16800 ESD#10/P/x86_64 on linux.
>
>> Hi All,
>>
>> I am facing issue with select * from <table> and its
>> retruning only 3 rows...even though we have inserted
>> thousends of rows and sp_spaceused show them as well. I
>> have updated stats and recreated the clustered indexes as
>> well.. still it does not show me all the rows. Where can
>> be issue ?
>>
>> Cheers


"Mark A. Parsons" <iron_horse Posted on 2010-06-17 18:30:06.0Z
From: "Mark A. Parsons" <iron_horse@no_spamola.compuserve.com>
User-Agent: Thunderbird 1.5.0.10 (Windows/20070221)
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: Issue with select returing only few rows...
References: <4c18dbb3$1@forums-1-dub> <4c19cc71.f4b.1681692777@sybase.com>
In-Reply-To: <4c19cc71.f4b.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Antivirus: avast! (VPS 100606-0, 06/06/2010), Outbound message
X-Antivirus-Status: Clean
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4c1a69ae$1@forums-1-dub>
Date: 17 Jun 2010 11:30:06 -0700
X-Trace: forums-1-dub 1276799406 10.22.241.152 (17 Jun 2010 11:30:06 -0700)
X-Original-Trace: 17 Jun 2010 11:30:06 -0700, vip152.sybase.com
Lines: 26
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29315
Article PK: 78550

Really? I would've expected it to return a single row, with a value >= 3 ...

Colt wrote:
> It returns only 3 rows...
>
>
>> what does
>>
>> select count(*) from table
>>
>> return?
>>
>> <Colt> wrote in message
>>> news:4c187665.6289.1681692777@sybase.com... The server
>>> is running on version Adaptive Server
>> Enterprise/12.5.4/EBF 16800 ESD#10/P/x86_64 on linux. >
>>>> Hi All,
>>>>
>>>> I am facing issue with select * from <table> and its
>>>> retruning only 3 rows...even though we have inserted
>>>> thousends of rows and sp_spaceused show them as well. I
>>>> have updated stats and recreated the clustered indexes
>> as >> well.. still it does not show me all the rows. Where
>> can >> be issue ?
>>>> Cheers
>>


Carl Kayser Posted on 2010-06-16 15:03:05.0Z
From: "Carl Kayser" <kayser_c@bls.gov>
Newsgroups: sybase.public.ase.general
References: <4c187628.627e.1681692777@sybase.com>
Subject: Re: Issue with select returing only few rows...
Lines: 15
Organization: BLS
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5931
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5931
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4c18e7a9$1@forums-1-dub>
Date: 16 Jun 2010 08:03:05 -0700
X-Trace: forums-1-dub 1276700585 10.22.241.152 (16 Jun 2010 08:03:05 -0700)
X-Original-Trace: 16 Jun 2010 08:03:05 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29309
Article PK: 78544


<Colt> wrote in message news:4c187628.627e.1681692777@sybase.com...
> Hi All,
>
> I am facing issue with select * from <table> and its
> retruning only 3 rows...even though we have inserted
> thousends of rows and sp_spaceused show them as well. I have
> updated stats and recreated the clustered indexes as well..
> still it does not show me all the rows. Where can be issue ?
>
> Cheers

What front-end are you using? Which options are set for your front-end?


Bret Halford Posted on 2010-06-16 15:39:59.0Z
From: Bret Halford <bret@sybase.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: Issue with select returing only few rows...
References: <4c187628.627e.1681692777@sybase.com>
In-Reply-To: <4c187628.627e.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4c18f04f$1@forums-1-dub>
Date: 16 Jun 2010 08:39:59 -0700
X-Trace: forums-1-dub 1276702799 10.22.241.152 (16 Jun 2010 08:39:59 -0700)
X-Original-Trace: 16 Jun 2010 08:39:59 -0700, vip152.sybase.com
Lines: 19
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29310
Article PK: 78551


On 6/16/2010 12:58 AM, Colt wrote:
> Hi All,
>
> I am facing issue with select * from<table> and its
> retruning only 3 rows...even though we have inserted
> thousends of rows and sp_spaceused show them as well. I have
> updated stats and recreated the clustered indexes as well..
> still it does not show me all the rows. Where can be issue ?
>
> Cheers

Any chance "set rowcount 3" was run by this session?
(if so, you'd be seeing the same thing on selects from other tables,
and "set rowcount 0" would revert to showing everything.)

Any chance there is a row-level access control rule on the table
that might limit the rows this login is allowed to look at?

Does this happen for multiple sessions?