Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

SSIS and data transfer from Sybase

3 posts in General Discussion Last posting was on 2010-10-06 11:36:06.0Z
Whatty Posted on 2010-10-04 18:40:58.0Z
From: "Whatty" <steven.whatmore@purefacts.com>
Newsgroups: sybase.public.ase.general
Subject: SSIS and data transfer from Sybase
Lines: 2
MIME-Version: 1.0
Content-Type: text/plain; format=flowed; charset="iso-8859-1"; reply-type=original
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
Importance: Normal
X-Newsreader: Microsoft Windows Live Mail 14.0.8089.726
X-MimeOLE: Produced By Microsoft MimeOLE V14.0.8089.726
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4caa1fba@forums-1-dub>
Date: 4 Oct 2010 11:40:58 -0700
X-Trace: forums-1-dub 1286217658 10.22.241.152 (4 Oct 2010 11:40:58 -0700)
X-Original-Trace: 4 Oct 2010 11:40:58 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29628
Article PK: 78857

Good afternoon,

I am trying to use SSIS to integrate a Sybase DB instance with a MS SQL
Server instance and am having problems with the package connecting to Sybase
properly to retrieve some data

The error that I am getting are shown below

I have seen tons of posting online regarding this problem and the use of
quoted identifiers which you see in my package configuration that I have
turned on (below) but to no avail.

Has anyone gotten this to work properly and what am I doing wrong here.

Thanks in advance.

<Configuration ConfiguredType="Property"
Path="\Package.Connections[OLE.DB.SYBASE].Properties[ConnectionString]"
ValueType="String">
<ConfiguredValue>Data Source=<XXXX>:<XXXX>;User
ID=<UNAME>;Password=<Password>;Catalog=<CATALOG>;Provider=ASEOLEDB.1;Password=password;QuotedIdentifiers=True</ConfiguredValue>
</Configuration>


----------------------

Microsoft (R) SQL Server Execute Package Utility
Version 10.0.1600.22 for 32-bit
Copyright (C) Microsoft Corp 1984-2005. All rights reserved.

Started: 2:30:41 PM
Progress: 2010-10-04 14:30:42.02
Source: Data Flow Task
Validating: 0% complete
End Progress
Error: 2010-10-04 14:30:43.77
Code: 0xC0202009
Source: Data Flow Task OLE DB Source [1]
Description: SSIS Error Code DTS_E_OLEDBERROR. An OLE DB error has
occurred. Error code: 0x80040E37.
An OLE DB record is available. Source: "ASEOLEDB" Hresult: 0x00000000
Description: "dbo.COMPANY_TAX not found. Specify owner.objectname or use
sp_help to check whether the object exists (sp_help may produce lots of
output).
".
End Error
Error: 2010-10-04 14:30:43.78
Code: 0xC02020E8
Source: Data Flow Task OLE DB Source [1]
Description: Opening a rowset for "[dbo].[COMPANY_TAX]" failed. Check
that the object exists in the database.
End Error
Error: 2010-10-04 14:30:43.78
Code: 0xC001410E
Source: Company Connection manager "OLE.DB.SYBASE"
Description: The connection manager failed to defect from the
transaction.
End Error
Error: 2010-10-04 14:30:43.78
Code: 0xC004706B
Source: Data Flow Task SSIS.Pipeline
Description: "component "OLE DB Source" (1)" failed validation and
returned validation status "VS_ISBROKEN".
End Error
Progress: 2010-10-04 14:30:43.79
Source: Data Flow Task
Validating: 50% complete
End Progress
Error: 2010-10-04 14:30:43.79
Code: 0xC004700C
Source: Data Flow Task SSIS.Pipeline
Description: One or more component failed validation.
End Error
Error: 2010-10-04 14:30:43.79
Code: 0xC0024107
Source: Data Flow Task
Description: There were errors during task validation.
End Error
DTExec: The package execution returned DTSER_FAILURE (1).
Started: 2:30:41 PM
Finished: 2:30:43 PM
Elapsed: 2 seconds

----------------------


Manish_Negandhi [TeamSybase] Posted on 2010-10-06 07:24:32.0Z
From: "Manish_Negandhi [TeamSybase]" <no.spam.negandhi.manish@gmail.com>
Newsgroups: sybase.public.ase.general
References: <4caa1fba@forums-1-dub>
Subject: Re: SSIS and data transfer from Sybase
Lines: 64
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5931
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5994
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4cac2430@forums-1-dub>
Date: 6 Oct 2010 00:24:32 -0700
X-Trace: forums-1-dub 1286349872 10.22.241.152 (6 Oct 2010 00:24:32 -0700)
X-Original-Trace: 6 Oct 2010 00:24:32 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29629
Article PK: 78861


"Whatty" <steven.whatmore@purefacts.com> wrote in message
news:4caa1fba@forums-1-dub...
> Good afternoon,
>
> I am trying to use SSIS to integrate a Sybase DB instance with a MS SQL
> Server instance and am having problems with the package connecting to
> Sybase properly to retrieve some data
>
> The error that I am getting are shown below
>
> I have seen tons of posting online regarding this problem and the use of
> quoted identifiers which you see in my package configuration that I have
> turned on (below) but to no avail.
>
> Has anyone gotten this to work properly and what am I doing wrong here.
>
> Thanks in advance.
>
> <Configuration ConfiguredType="Property"
> Path="\Package.Connections[OLE.DB.SYBASE].Properties[ConnectionString]"
> ValueType="String">
> <ConfiguredValue>Data Source=<XXXX>:<XXXX>;User
> ID=<UNAME>;Password=<Password>;Catalog=<CATALOG>;Provider=ASEOLEDB.1;Password=password;QuotedIdentifiers=True</ConfiguredValue>
> </Configuration>
>
>
> ----------------------
>
> Microsoft (R) SQL Server Execute Package Utility
> Version 10.0.1600.22 for 32-bit
> Copyright (C) Microsoft Corp 1984-2005. All rights reserved.
>
> Started: 2:30:41 PM
> Progress: 2010-10-04 14:30:42.02
> Source: Data Flow Task
> Validating: 0% complete
> End Progress
> Error: 2010-10-04 14:30:43.77
> Code: 0xC0202009
> Source: Data Flow Task OLE DB Source [1]
> Description: SSIS Error Code DTS_E_OLEDBERROR. An OLE DB error has
> occurred. Error code: 0x80040E37.
> An OLE DB record is available. Source: "ASEOLEDB" Hresult: 0x00000000
> Description: "dbo.COMPANY_TAX not found. Specify owner.objectname or use
> sp_help to check whether the object exists (sp_help may produce lots of
> output).

when you have turned on quoted identifier , you need to specify table owner
name in separate quotes
for ex.
set quoted_identifier on
go
select * from "dbo.COMPANY_TAX" - this will not work
go
select * from "dbo"."COMPANY_TAX" - this will work
go

Also check if the user is connected to the desired database after logging in

-HTH
Manish Negandhi
[TeamSybase]


Whatty Posted on 2010-10-06 11:36:06.0Z
From: "Whatty" <steven.whatmore@purefacts.com>
Newsgroups: sybase.public.ase.general
References: <4caa1fba@forums-1-dub> <4cac2430@forums-1-dub>
In-Reply-To: <4cac2430@forums-1-dub>
Subject: Re: SSIS and data transfer from Sybase
Lines: 2
MIME-Version: 1.0
Content-Type: text/plain; format=flowed; charset="iso-8859-1"; reply-type=response
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
Importance: Normal
X-Newsreader: Microsoft Windows Live Mail 14.0.8089.726
X-MimeOLE: Produced By Microsoft MimeOLE V14.0.8089.726
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4cac5f26$1@forums-1-dub>
Date: 6 Oct 2010 04:36:06 -0700
X-Trace: forums-1-dub 1286364966 10.22.241.152 (6 Oct 2010 04:36:06 -0700)
X-Original-Trace: 6 Oct 2010 04:36:06 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29630
Article PK: 78860

As far as I can tell - it looks like the OleDB driver that ships with the
15.0.2 client does not work with SSIS - I upgraded to the 15.0.3 drivers and
things are working as expected.

Thanks nonetheless

Whatty

"Manish_Negandhi [TeamSybase]" <no.spam.negandhi.manish@gmail.com> wrote in
message news:4cac2430@forums-1-dub...
> "Whatty" <steven.whatmore@purefacts.com> wrote in message
> news:4caa1fba@forums-1-dub...
>> Good afternoon,
>>
>> I am trying to use SSIS to integrate a Sybase DB instance with a MS SQL
>> Server instance and am having problems with the package connecting to
>> Sybase properly to retrieve some data
>>
>> The error that I am getting are shown below
>>
>> I have seen tons of posting online regarding this problem and the use of
>> quoted identifiers which you see in my package configuration that I have
>> turned on (below) but to no avail.
>>
>> Has anyone gotten this to work properly and what am I doing wrong here.
>>
>> Thanks in advance.
>>
>> <Configuration ConfiguredType="Property"
>> Path="\Package.Connections[OLE.DB.SYBASE].Properties[ConnectionString]"
>> ValueType="String">
>> <ConfiguredValue>Data Source=<XXXX>:<XXXX>;User
>> ID=<UNAME>;Password=<Password>;Catalog=<CATALOG>;Provider=ASEOLEDB.1;Password=password;QuotedIdentifiers=True</ConfiguredValue>
>> </Configuration>
>>
>>
>> ----------------------
>>
>> Microsoft (R) SQL Server Execute Package Utility
>> Version 10.0.1600.22 for 32-bit
>> Copyright (C) Microsoft Corp 1984-2005. All rights reserved.
>>
>> Started: 2:30:41 PM
>> Progress: 2010-10-04 14:30:42.02
>> Source: Data Flow Task
>> Validating: 0% complete
>> End Progress
>> Error: 2010-10-04 14:30:43.77
>> Code: 0xC0202009
>> Source: Data Flow Task OLE DB Source [1]
>> Description: SSIS Error Code DTS_E_OLEDBERROR. An OLE DB error has
>> occurred. Error code: 0x80040E37.
>> An OLE DB record is available. Source: "ASEOLEDB" Hresult: 0x00000000
>> Description: "dbo.COMPANY_TAX not found. Specify owner.objectname or use
>> sp_help to check whether the object exists (sp_help may produce lots of
>> output).
>
> when you have turned on quoted identifier , you need to specify table
> owner name in separate quotes
> for ex.
> set quoted_identifier on
> go
> select * from "dbo.COMPANY_TAX" - this will not work
> go
> select * from "dbo"."COMPANY_TAX" - this will work
> go
>
> Also check if the user is connected to the desired database after logging
> in
>
> -HTH
> Manish Negandhi
> [TeamSybase]
>