Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Linking problem Xcode4

21 posts in Ultralite Last posting was on 2011-03-30 18:16:58.0Z
RobertoG Posted on 2011-03-13 09:13:29.0Z
Sender: 5e68.4d7c80a5.1804289383@sybase.com
From: robertoG
Newsgroups: sybase.public.sqlanywhere.ultralite
Subject: Linking problem Xcode4
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4d7c8ab9.5f6a.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 13 Mar 2011 01:13:29 -0800
X-Trace: forums-1-dub 1300007609 10.22.241.41 (13 Mar 2011 01:13:29 -0800)
X-Original-Trace: 13 Mar 2011 01:13:29 -0800, 10.22.241.41
Lines: 17
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sqlanywhere.ultralite:12399
Article PK: 1048187

Hi all, after install xCode4 with iOs4.3 , when I try to run
my app on device, during the build fase, throw an error:

ld: in
/Applications/SQLAnywhere12/ultralite/iphone/libulrt.a, file
is universal but does not contain a(n) armv7 slice for
architecture armv7
collect2: ld returned 1 exit status
Command
/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/g++-4.2
failed with exit code 1

With xCode3 all work fine.

TIA

RG


Tim McClements [Sybase] Posted on 2011-03-15 21:51:51.0Z
From: "Tim McClements [Sybase]" <mcclemenXnospam@sybase.com>
Newsgroups: sybase.public.sqlanywhere.ultralite
References: <4d7c8ab9.5f6a.1681692777@sybase.com>
Subject: Re: Linking problem Xcode4
Lines: 51
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5931
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5994
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4d7fdf77@forums-1-dub>
Date: 15 Mar 2011 13:51:51 -0800
X-Trace: forums-1-dub 1300225911 10.22.241.152 (15 Mar 2011 13:51:51 -0800)
X-Original-Trace: 15 Mar 2011 13:51:51 -0800, vip152.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sqlanywhere.ultralite:12405
Article PK: 1048116

Here are the instructions to add the armv7 architecture to the UL library in
an existing install so it will work with Xcode 4:

In Terminal, change to the SQLAnywhere12/ultralite/iphone directory and
build
the UltraLite runtime library as usual:
./build.sh
Make a new directory to hold the armv7 build:
mkdir armv7
cd armv7
Unpack the source from the arm directory:
tar xzf ../arm/libulrt.tar.gz
Modify the makefile to build armv7 binaries:
edit libulrt.make with a text editor:
on the line starting 'CCARGS ='
change '-arch armv6' to '-arch armv7'
(leave -mthumb as is)
Build the armv7 library (adjust the SDKVER value as required):
make -j2 -B -f libulrt.make SDKVER=4.3
cd ..
Rebuild the universal library:
rm -f libulrt.a
/Developer/usr/bin/libtool -static -o libulrt.a arm/libulrt.a
armv7/libulrt.a x86/libulrt.a
Confirm the architectures present in the library are 'armv6 armv7 i386':
lipo -info libulrt.a

- Tim

<robertoG> wrote in message news:4d7c8ab9.5f6a.1681692777@sybase.com...
> Hi all, after install xCode4 with iOs4.3 , when I try to run
> my app on device, during the build fase, throw an error:
>
> ld: in
> /Applications/SQLAnywhere12/ultralite/iphone/libulrt.a, file
> is universal but does not contain a(n) armv7 slice for
> architecture armv7
> collect2: ld returned 1 exit status
> Command
> /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/g++-4.2
> failed with exit code 1
>
> With xCode3 all work fine.
>
> TIA
>
> RG


Tim McClements [Sybase] Posted on 2011-03-14 22:05:35.0Z
From: "Tim McClements [Sybase]" <mcclemenXnospam@sybase.com>
Newsgroups: sybase.public.sqlanywhere.ultralite
References: <4d7c8ab9.5f6a.1681692777@sybase.com>
Subject: Re: Linking problem Xcode4
Lines: 26
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5931
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5994
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4d7e912f$1@forums-1-dub>
Date: 14 Mar 2011 14:05:35 -0800
X-Trace: forums-1-dub 1300140335 10.22.241.152 (14 Mar 2011 14:05:35 -0800)
X-Original-Trace: 14 Mar 2011 14:05:35 -0800, vip152.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sqlanywhere.ultralite:12402
Article PK: 1048190

We are looking into this presently. For now, please select the armv6
architecture in Xcode.

- Tim

<robertoG> wrote in message news:4d7c8ab9.5f6a.1681692777@sybase.com...
> Hi all, after install xCode4 with iOs4.3 , when I try to run
> my app on device, during the build fase, throw an error:
>
> ld: in
> /Applications/SQLAnywhere12/ultralite/iphone/libulrt.a, file
> is universal but does not contain a(n) armv7 slice for
> architecture armv7
> collect2: ld returned 1 exit status
> Command
> /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/g++-4.2
> failed with exit code 1
>
> With xCode3 all work fine.
>
> TIA
>
> RG