Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

sso_role password and unix scripts

3 posts in General Discussion Last posting was on 2011-03-16 09:30:01.0Z
Venki Posted on 2011-03-15 15:56:34.0Z
From: "Venki" <venkitachalam.s@gmail.com>
Newsgroups: sybase.public.ase.general
Subject: sso_role password and unix scripts
Lines: 31
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5931
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5931
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4d7f8c32$1@forums-1-dub>
Date: 15 Mar 2011 07:56:34 -0800
X-Trace: forums-1-dub 1300204594 10.22.241.152 (15 Mar 2011 07:56:34 -0800)
X-Original-Trace: 15 Mar 2011 07:56:34 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30041
Article PK: 79270

Hi,

I have some jobs (UNIX Shell scripts) which uses the account having sso_role
as well

Now we are planning to set password for sso_role

However, the jobs fail with following message


=============================================
Could not log in into Sybase Server XXX_UTV_SDS

Msg 11141, Level 16, State 1:
Server 'XXX_UTV_SDS':
Password required to set role 'sso_role' on.
value
-----------
15000

backup_sybase XXX_UTV_SDS -trans started 11-03-15.14:55:01
Program was interrupted before it was finished

=============================================

What would be the way out?

Thanx in advance
Venki


Manish Negandhi [TeamSybase] Posted on 2011-03-15 16:35:26.0Z
From: "Manish Negandhi [TeamSybase]" <negandhi.manish.nospam@gmail.com>
Newsgroups: sybase.public.ase.general
References: <4d7f8c32$1@forums-1-dub>
Subject: Re: sso_role password and unix scripts
Lines: 44
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4d7f954e$1@forums-1-dub>
Date: 15 Mar 2011 08:35:26 -0800
X-Trace: forums-1-dub 1300206926 10.22.241.152 (15 Mar 2011 08:35:26 -0800)
X-Original-Trace: 15 Mar 2011 08:35:26 -0800, vip152.sybase.com
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30042
Article PK: 79271


"Venki" <venkitachalam.s@gmail.com> wrote in message
news:4d7f8c32$1@forums-1-dub...
> Hi,
>
> I have some jobs (UNIX Shell scripts) which uses the account having
> sso_role as well
>
> Now we are planning to set password for sso_role
>
> However, the jobs fail with following message
>
>
> =============================================
> Could not log in into Sybase Server XXX_UTV_SDS
>
> Msg 11141, Level 16, State 1:
> Server 'XXX_UTV_SDS':
> Password required to set role 'sso_role' on.
> value
> -----------
> 15000
>
> backup_sybase XXX_UTV_SDS -trans started 11-03-15.14:55:01
> Program was interrupted before it was finished
>
> =============================================
>
> What would be the way out?
>
> Thanx in advance
> Venki
>
>

You need to set sso_role using with passwd clause.

set role "sso_role" with passwd <password> on

-HTH
Manish Negandhi
[TeamSybase]


Luc Van der Veurst Posted on 2011-03-16 09:30:01.0Z
From: "Luc Van der Veurst" <dba_azvub@hotmail.com>
Newsgroups: sybase.public.ase.general
References: <4d7f8c32$1@forums-1-dub> <4d7f954e$1@forums-1-dub>
Subject: Re: sso_role password and unix scripts
Lines: 82
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5931
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5931
X-RFC2646: Format=Flowed; Response
X-Forwarded: by - (DeleGate/5.8.7)
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4d808319@forums-1-dub>
Date: 16 Mar 2011 01:30:01 -0800
X-Trace: forums-1-dub 1300267801 10.22.241.152 (16 Mar 2011 01:30:01 -0800)
X-Original-Trace: 16 Mar 2011 01:30:01 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30046
Article PK: 79275


"Manish Negandhi [TeamSybase]" <negandhi.manish.nospam@gmail.com> wrote in
message news:4d7f954e$1@forums-1-dub...
>
> "Venki" <venkitachalam.s@gmail.com> wrote in message
> news:4d7f8c32$1@forums-1-dub...
>> Hi,
>>
>> I have some jobs (UNIX Shell scripts) which uses the account having
>> sso_role as well
>>
>> Now we are planning to set password for sso_role
>>
>> However, the jobs fail with following message
>>
>>
>> =============================================
>> Could not log in into Sybase Server XXX_UTV_SDS
>>
>> Msg 11141, Level 16, State 1:
>> Server 'XXX_UTV_SDS':
>> Password required to set role 'sso_role' on.
>> value
>> -----------
>> 15000
>>
>> backup_sybase XXX_UTV_SDS -trans started 11-03-15.14:55:01
>> Program was interrupted before it was finished
>>
>> =============================================
>>
>> What would be the way out?
>>
>> Thanx in advance
>> Venki
>>
>>
>
> You need to set sso_role using with passwd clause.
>
> set role "sso_role" with passwd <password> on

Error message 11141 shows up when you log on to the server, so before you
have the chance to set the password.
What will happen further will depend on the client trying to setup a
connection.
If it ignores the 11141 then it will work fine.
So Venki, Is this an isql session, is there something in the backup_sybase
script
that catches the 11141 errror ?

where does
value
--------
15000

comes from ?

Even when connecting to the server generates a 11141 error, you get a
connection to
the server, so it should continue to work. My guess is that this is what's
happening in
your case, you have a connection to the server, and the scripts generates
the
value
-------
15000
output.
If you get permission errors further in the script, then it's because you
didn't execute the
set role statement as Manish described.

My opinion is that the server should generate the 11141 error only if the
default status
of the role is ON, and not when default status is OFF. When it's OFF, it
should silently
connect to the server.

Luc.