Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

character set error

4 posts in General Discussion Last posting was on 2011-03-19 00:39:55.0Z
guest5 Posted on 2011-03-18 20:38:13.0Z
Sender: 36f0.4d80c49e.1804289383@sybase.com
From: guest5
Newsgroups: sybase.public.ase.general
Subject: character set error
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4d83c2b5.67f.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 18 Mar 2011 12:38:13 -0800
X-Trace: forums-1-dub 1300480693 10.22.241.41 (18 Mar 2011 12:38:13 -0800)
X-Original-Trace: 18 Mar 2011 12:38:13 -0800, 10.22.241.41
Lines: 15
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30059
Article PK: 79288

Hi

Installed rep server 15.2 ESD2 on new Linux redhat machine
on IBM. Getting below error when I isql to repserver from
the machine.

Msg 14125, Level 11, State 0:
Application 'isql' is using character set 'utf8', but the
Replication Server is using character set 'iso_1'. Because
the character sets are different, character set conversion
problems may occur.

How to fix this?

Thanks


Neal Stack [Sybase] Posted on 2011-03-18 20:54:49.0Z
From: "Neal Stack [Sybase]" <nstack@nospam.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: character set error
References: <4d83c2b5.67f.1681692777@sybase.com>
In-Reply-To: <4d83c2b5.67f.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4d83c699$1@forums-1-dub>
Date: 18 Mar 2011 12:54:49 -0800
X-Trace: forums-1-dub 1300481689 10.22.241.152 (18 Mar 2011 12:54:49 -0800)
X-Original-Trace: 18 Mar 2011 12:54:49 -0800, vip152.sybase.com
Lines: 60
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30060
Article PK: 79289

Hello,

isql on Linux typically defaults to utf8 but this is based on your
server's locale settings:
$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Look at your $SYBASE/locales/locales.dat file's "linux" section for the
possibilities. Read here for more details:
http://infocenter.sybase.com/help/topic/com.sybase.infocenter.dc38421.1550/html/ntconfig/ntconfig95.htm

There are several ways to override the default (in these examples I log
into ASE so I can easily illustrate things with @@client_csname.
@@client_csname does not exist in Rep Server):

$ isql -Usa -P -S nstack-sun:5055
1> select @@client_csname
2> go

------------------------------------------------------------
utf8

(1 row affected)
1> quit


[nstack@redeye server]$ isql -Usa -P -S nstack-sun:5055 -J iso_1
1> select @@client_csname
2> go

------------------------------
iso_1

(1 row affected)
1> quit


[nstack@redeye server]$ setenv LC_ALL C
[nstack@redeye server]$ isql -Usa -P -S nstack-sun:5055
1> select @@client_csname
2> go

------------------------------
iso_1

(1 row affected)
1> quit


guest5 Posted on 2011-03-19 00:39:55.0Z
Sender: 36f0.4d80c49e.1804289383@sybase.com
From: guest5
Newsgroups: sybase.public.ase.general
Subject: Re: character set error
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4d83fb5b.bce.1681692777@sybase.com>
References: <4d83c699$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 18 Mar 2011 16:39:55 -0800
X-Trace: forums-1-dub 1300495195 10.22.241.41 (18 Mar 2011 16:39:55 -0800)
X-Original-Trace: 18 Mar 2011 16:39:55 -0800, 10.22.241.41
Lines: 67
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30062
Article PK: 79294


> Hello,
>
> isql on Linux typically defaults to utf8 but this is based
> on your server's locale settings:
> $ locale
> LANG=en_US.UTF-8
> LC_CTYPE="en_US.UTF-8"
> LC_NUMERIC="en_US.UTF-8"
> LC_TIME="en_US.UTF-8"
> LC_COLLATE="en_US.UTF-8"
> LC_MONETARY="en_US.UTF-8"
> LC_MESSAGES="en_US.UTF-8"
> LC_PAPER="en_US.UTF-8"
> LC_NAME="en_US.UTF-8"
> LC_ADDRESS="en_US.UTF-8"
> LC_TELEPHONE="en_US.UTF-8"
> LC_MEASUREMENT="en_US.UTF-8"
> LC_IDENTIFICATION="en_US.UTF-8"
> LC_ALL=
>
> Look at your $SYBASE/locales/locales.dat file's "linux"
> section for the possibilities. Read here for more
> details:
>
http://infocenter.sybase.com/help/topic/com.sybase.infocenter.dc38421.1550/html/ntconfig/ntconfig95.htm
>
> There are several ways to override the default (in these
> examples I log into ASE so I can easily illustrate things
> with @@client_csname. @@client_csname does not exist in
> Rep Server):
>
> $ isql -Usa -P -S nstack-sun:5055
> 1> select @@client_csname
> 2> go
>
>
> ----------------------------------------------------------
> --
> utf8
>
> (1 row affected)
> 1> quit
>
>
> [nstack@redeye server]$ isql -Usa -P -S nstack-sun:5055 -J
> iso_1 1> select @@client_csname
> 2> go
>
> ------------------------------
> iso_1
>
> (1 row affected)
> 1> quit
>
>
> [nstack@redeye server]$ setenv LC_ALL C
> [nstack@redeye server]$ isql -Usa -P -S nstack-sun:5055
> 1> select @@client_csname
> 2> go
>
> ------------------------------
> iso_1
>
> (1 row affected)
> 1> quit

Thanks for your help. I will check on this.


J Posted on 2011-03-18 21:26:45.0Z
From: jtotally_bogus@sbcglobal.net (J)
Newsgroups: sybase.public.ase.general
Subject: Re: character set error
Reply-To: J@bogusemailAddress.com
Message-ID: <4d83cdc6.3734465781@forums.sybase.com>
References: <4d83c2b5.67f.1681692777@sybase.com>
X-Newsreader: Forte Free Agent 1.21/32.243
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 18 Mar 2011 13:26:45 -0800
X-Trace: forums-1-dub 1300483605 10.22.241.152 (18 Mar 2011 13:26:45 -0800)
X-Original-Trace: 18 Mar 2011 13:26:45 -0800, vip152.sybase.com
Lines: 23
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30061
Article PK: 79292

On 18 Mar 2011 12:38:13 -0800, guest5 wrote:

Neal is right. echo $LANG. I workaround this all the time by using
setting environment variable LANG to C

Jay

>Hi
>
>Installed rep server 15.2 ESD2 on new Linux redhat machine
>on IBM. Getting below error when I isql to repserver from
>the machine.
>
>Msg 14125, Level 11, State 0:
>Application 'isql' is using character set 'utf8', but the
>Replication Server is using character set 'iso_1'. Because
>the character sets are different, character set conversion
>problems may occur.
>
>How to fix this?
>
>Thanks