Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Workspace 2.5 and #temp tables

3 posts in General Discussion Last posting was on 2011-06-15 06:56:55.0Z
Jamal Posted on 2011-03-28 03:27:40.0Z
Sender: 5eec.4d8ffb80.1804289383@sybase.com
From: Jamal
Newsgroups: sybase.public.workspace.general
Subject: Workspace 2.5 and #temp tables
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4d90002c.5f6e.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 27 Mar 2011 19:27:40 -0800
X-Trace: forums-1-dub 1301282860 10.22.241.41 (27 Mar 2011 19:27:40 -0800)
X-Original-Trace: 27 Mar 2011 19:27:40 -0800, 10.22.241.41
Lines: 19
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:948
Article PK: 1101475

Hi Guys,

I am exploring Workspace 2.5 to use in our compnay as
standard database development tool. My main focus is on
Stored Procedure debugging.

The problem I am facing is that values of temporary tables
are not displayed in Reference Tables tab. I scaned through
this group and found people have had this problem in version
2.1 but an EBF
http://origin1.sybase.com/swx/12562/EBF16678_Buglist.txt has
fixed the problem.
I have also tried it sa role user but problem persists.

I am wondering If anybody else experiencing this problem
with Worspace 2.5.

Thanks,
Jamal


Michael Posted on 2011-04-11 03:07:00.0Z
From: Michael <renj@sybase.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0
MIME-Version: 1.0
Newsgroups: sybase.public.workspace.general
Subject: Re: Workspace 2.5 and #temp tables
References: <4d90002c.5f6e.1681692777@sybase.com>
In-Reply-To: <4d90002c.5f6e.1681692777@sybase.com>
Content-Type: text/plain; charset=GB2312
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4da27054$1@forums-1-dub>
Date: 10 Apr 2011 20:07:00 -0700
X-Trace: forums-1-dub 1302491220 10.22.241.152 (10 Apr 2011 20:07:00 -0700)
X-Original-Trace: 10 Apr 2011 20:07:00 -0700, vip152.sybase.com
Lines: 6
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:952
Article PK: 1101481

Hi Jamal,

You are using ASE, right? Can you provide the stored procedure
(simplified) so we can do the investigation.

Thanks.


Jamal Posted on 2011-06-15 06:56:55.0Z
Sender: 5159.4df853e9.1804289383@sybase.com
From: Jamal
Newsgroups: sybase.public.workspace.general
Subject: Re: Workspace 2.5 and #temp tables
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4df857b6.528c.1681692777@sybase.com>
References: <4da27054$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 14 Jun 2011 23:56:55 -0700
X-Trace: forums-1-dub 1308121015 10.22.241.41 (14 Jun 2011 23:56:55 -0700)
X-Original-Trace: 14 Jun 2011 23:56:55 -0700, 10.22.241.41
Lines: 47
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:957
Article PK: 1101482

Hi Michael,

First sorry of replying so late as I didn't come back to
this forum after waiting for one week.

We are using ASE 15 and stored procedure is very simple, I
am copying below.

When we use the Scrap Book it does show the temp table but
somehow after some time spid gets change and it initialize
all the value temp table values. My major concern is when we
load the stored procedure in Debugging Perspective it
doesn't show temp table.

We have already got the management approval to buy a tool
for database development but unfortunatley this problem will
not allows us to move forward.

I appreciate any quick response.
Thanks,
Jamal

CREATE PROCEDURE sp_test_sp

AS
BEGIN
CREATE TABLE #tmp_table (
cust_id integer,
given_name varchar(50),
last_name varchar(50)
)

Insert into #tmp_table
values(1,'Chris', 'Warren')

Insert into #tmp_table
values(2,'Mat', 'Demon')


END

> Hi Jamal,
>
> You are using ASE, right? Can you provide the stored
> procedure (simplified) so we can do the investigation.
>
> Thanks.